aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-08-06 23:20:07 +0800
committermarino <marino@FreeBSD.org>2014-08-06 23:20:07 +0800
commit4d7b6da4a3fb8589e99dc698b8bc69456a177f93 (patch)
tree553b869a32ef856a554cb0797be959b601b51291
parent8d9120bb15ebeab45e7d3ea30ecc9b75e96ed1be (diff)
downloadfreebsd-ports-graphics-4d7b6da4a3fb8589e99dc698b8bc69456a177f93.tar.gz
freebsd-ports-graphics-4d7b6da4a3fb8589e99dc698b8bc69456a177f93.tar.zst
freebsd-ports-graphics-4d7b6da4a3fb8589e99dc698b8bc69456a177f93.zip
Stage mail/postgrey
PR: 190082 Submitted by: freebsd (nagilum.org) Add'l work by: marino Approved by: maintainer timeout (2.5 months)
-rw-r--r--mail/postgrey/Makefile47
-rw-r--r--mail/postgrey/pkg-plist7
2 files changed, 27 insertions, 27 deletions
diff --git a/mail/postgrey/Makefile b/mail/postgrey/Makefile
index 3ce75b205e9..f3b22ca0e47 100644
--- a/mail/postgrey/Makefile
+++ b/mail/postgrey/Makefile
@@ -34,45 +34,42 @@ PGY_DIR?= /var/db/postgrey
USERS= ${PGY_USERNAME}
GROUPS= ${PGY_GROUPNAME}
-MAN1= ${PORTNAME}.1 policy-test.1 postgreyreport.1
+MPAGES= postgrey.1 policy-test.1 postgreyreport.1
USES= shebangfix perl5
-SHEBANG_FILES= ${WRKSRC}/postgrey
-
-NO_STAGE= yes
+SHEBANG_FILES= postgrey policy-test contrib/postgreyreport
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
post-patch:
- @${REINPLACE_CMD} -e 's#nogroup#${PGY_GROUPNAME}#' ${WRKSRC}/postgrey
- @${REINPLACE_CMD} -e 's#/etc/main.cf#/etc/postfix/main.cf#' ${WRKSRC}/postgrey
- @${REINPLACE_CMD} -e 's#/etc/postfix#${PREFIX}&#' ${WRKSRC}/postgrey ${WRKSRC}/postgrey_whitelist_*
- @${REINPLACE_CMD} -e 's#/var/spool/postfix/postgrey#${PGY_DIR}#' ${WRKSRC}/postgrey ${WRKSRC}/contrib/postgreyreport
-
-pre-install:
- @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+ @${REINPLACE_CMD} -e 's#nogroup#${PGY_GROUPNAME}#' \
+ -e 's#/etc/main.cf#/etc/postfix/main.cf#' ${WRKSRC}/postgrey
+ @${REINPLACE_CMD} -e 's#/etc/postfix#${PREFIX}&#' \
+ ${WRKSRC}/postgrey ${WRKSRC}/postgrey_whitelist_*
+ @${REINPLACE_CMD} -e 's#/var/spool/postfix/postgrey#${PGY_DIR}#' \
+ ${WRKSRC}/postgrey ${WRKSRC}/contrib/postgreyreport
do-install:
- @${POD2MAN} ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.1
- @${POD2MAN} ${WRKSRC}/policy-test ${WRKSRC}/policy-test.1
- @${POD2MAN} ${WRKSRC}/contrib/postgreyreport ${WRKSRC}/postgreyreport.1
- @${INSTALL_SCRIPT} ${WRKSRC}/postgrey ${PREFIX}/sbin
- @${INSTALL_SCRIPT} ${WRKSRC}/policy-test ${PREFIX}/sbin
- @${INSTALL_SCRIPT} ${WRKSRC}/contrib/postgreyreport ${PREFIX}/sbin
- @${INSTALL} -d ${PREFIX}/etc/postfix
+ ${POD2MAN} ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.1
+ ${POD2MAN} ${WRKSRC}/policy-test ${WRKSRC}/policy-test.1
+ ${POD2MAN} ${WRKSRC}/contrib/postgreyreport ${WRKSRC}/postgreyreport.1
+ ${INSTALL_SCRIPT} ${WRKSRC}/postgrey ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_SCRIPT} ${WRKSRC}/policy-test ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_SCRIPT} ${WRKSRC}/contrib/postgreyreport \
+ ${STAGEDIR}${PREFIX}/sbin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/postfix ${STAGEDIR}/${PGY_DIR}
.for i in ${ETCFILES}
- ${INSTALL_DATA} ${WRKSRC}/postgrey_${i} ${PREFIX}/etc/postfix/dist-postgrey_${i}
+ ${INSTALL_DATA} ${WRKSRC}/postgrey_${i} \
+ ${STAGEDIR}${PREFIX}/etc/postfix/dist-postgrey_${i}
.endfor
.if ${PORT_OPTIONS:MDOCS}
- @${INSTALL} -d ${DOCSDIR}
- @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.endif
- @cd ${WRKSRC} && ${INSTALL_MAN} ${MAN1} ${MANPREFIX}/man/man1
-
-post-install:
- @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @cd ${WRKSRC} && \
+ ${INSTALL_MAN} ${MPAGES} ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/mail/postgrey/pkg-plist b/mail/postgrey/pkg-plist
index 6bb75d12dfc..0f06b0f655b 100644
--- a/mail/postgrey/pkg-plist
+++ b/mail/postgrey/pkg-plist
@@ -1,9 +1,12 @@
@unexec if cmp -s %D/etc/postfix/dist-postgrey_whitelist_recipients %D/etc/postfix/postgrey_whitelist_recipients; then rm -f %D/etc/postfix/postgrey_whitelist_recipients; fi
@unexec if cmp -s %D/etc/postfix/dist-postgrey_whitelist_clients %D/etc/postfix/postgrey_whitelist_clients; then rm -f %D/etc/postfix/postgrey_whitelist_clients; fi
+etc/postfix/dist-postgrey_whitelist_recipients
+etc/postfix/dist-postgrey_whitelist_clients
+man/man1/policy-test.1.gz
+man/man1/postgrey.1.gz
+man/man1/postgreyreport.1.gz
sbin/postgrey
sbin/policy-test
sbin/postgreyreport
-etc/postfix/dist-postgrey_whitelist_recipients
-etc/postfix/dist-postgrey_whitelist_clients
@dirrmtry etc/postfix
@unexec rmdir /var/db/postgrey 2>/dev/null || true