aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2002-06-09 22:29:26 +0800
committerskv <skv@FreeBSD.org>2002-06-09 22:29:26 +0800
commit4db22b6f2429134f0eb5167dfd8a50753ba039bc (patch)
treeeb07c393988d3e5c97fdad650a978dd7e0bf921f
parent46cc7fce324ae78262e71541696fd22a7e193a35 (diff)
downloadfreebsd-ports-graphics-4db22b6f2429134f0eb5167dfd8a50753ba039bc.tar.gz
freebsd-ports-graphics-4db22b6f2429134f0eb5167dfd8a50753ba039bc.tar.zst
freebsd-ports-graphics-4db22b6f2429134f0eb5167dfd8a50753ba039bc.zip
Add p5-XML-DBMS 1.03, perl port of Java package XML-DBMS v1.0.
PR: 32970 Submitted by: Sergey Skvortsov <skv@protey.ru>
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-DBMS/Makefile38
-rw-r--r--textproc/p5-XML-DBMS/distinfo1
-rw-r--r--textproc/p5-XML-DBMS/pkg-comment1
-rw-r--r--textproc/p5-XML-DBMS/pkg-descr12
-rw-r--r--textproc/p5-XML-DBMS/pkg-plist12
6 files changed, 65 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 0ae098c917d..beacc905ca1 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -192,6 +192,7 @@
SUBDIR += p5-URI-Find
SUBDIR += p5-WDDX
SUBDIR += p5-XML-Catalog
+ SUBDIR += p5-XML-DBMS
SUBDIR += p5-XML-DOM
SUBDIR += p5-XML-DT
SUBDIR += p5-XML-Directory
diff --git a/textproc/p5-XML-DBMS/Makefile b/textproc/p5-XML-DBMS/Makefile
new file mode 100644
index 00000000000..fb6df49d606
--- /dev/null
+++ b/textproc/p5-XML-DBMS/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: XML::DBMS
+# Date created: 18 Dec 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-DBMS
+PORTVERSION= 1.03
+CATEGORIES= textproc databases perl5
+MASTER_SITES= ftp://ftp.rpbourret.com/
+PKGNAMEPREFIX= p5-
+DISTNAME= perl-xml-dbms-1.03
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= skv@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/XML/Parser/PerlSAX.pm:${PORTSDIR}/textproc/p5-libxml \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
+WRKSRC= ${WRKDIR}/${PORTNAME}
+PERL_CONFIGURE= yes
+
+post-extract:
+ @${FIND} ${WRKSRC} -type f | \
+ xargs ${PERL} -pi -e 's/\x0D(?=\x0A)//g'
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/samples/*.* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-DBMS/distinfo b/textproc/p5-XML-DBMS/distinfo
new file mode 100644
index 00000000000..6eefd7d0c6e
--- /dev/null
+++ b/textproc/p5-XML-DBMS/distinfo
@@ -0,0 +1 @@
+MD5 (perl-xml-dbms-1.03.tgz) = f10dbd7c4f91f6437c45139d15c2fc3a
diff --git a/textproc/p5-XML-DBMS/pkg-comment b/textproc/p5-XML-DBMS/pkg-comment
new file mode 100644
index 00000000000..ba62867cfe7
--- /dev/null
+++ b/textproc/p5-XML-DBMS/pkg-comment
@@ -0,0 +1 @@
+Perl port of Java package XML-DBMS v1.0
diff --git a/textproc/p5-XML-DBMS/pkg-descr b/textproc/p5-XML-DBMS/pkg-descr
new file mode 100644
index 00000000000..4296a1f0aea
--- /dev/null
+++ b/textproc/p5-XML-DBMS/pkg-descr
@@ -0,0 +1,12 @@
+XML-DBMS is middleware for transferring data between XML documents and
+relational databases. It views the XML document as a tree of
+data-specific objects in which element types are generally viewed as
+classes and attributes and PCDATA as properties of those classes. It
+then uses an object-relational mapping to map these objects to the
+database. An XML-based mapping language is used to define the view and
+map it to the database.
+
+WWW: http://www.rpbourret.com/xmldbms/index.htm
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/textproc/p5-XML-DBMS/pkg-plist b/textproc/p5-XML-DBMS/pkg-plist
new file mode 100644
index 00000000000..ec14ed1add8
--- /dev/null
+++ b/textproc/p5-XML-DBMS/pkg-plist
@@ -0,0 +1,12 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/XMLtoDBMS/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/XML/XMLtoDBMS.pm
+%%PORTDOCS%%%%EXAMPLESDIR%%/sales.map
+%%PORTDOCS%%%%EXAMPLESDIR%%/sales.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/sales.sql
+%%PORTDOCS%%%%EXAMPLESDIR%%/sales.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/sales1.map
+%%PORTDOCS%%%%EXAMPLESDIR%%/sales2.map
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/XMLtoDBMS
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true