aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2016-11-08 10:53:22 +0800
committeradamw <adamw@FreeBSD.org>2016-11-08 10:53:22 +0800
commit5076e7bc2473f17fd0d3e3fdf27f83088101a295 (patch)
treedeb9578cf48933b0f284deff2fbed02b64413389
parent024ec62fe3a350f8cb791541d098ae71c107ed21 (diff)
downloadfreebsd-ports-graphics-5076e7bc2473f17fd0d3e3fdf27f83088101a295.tar.gz
freebsd-ports-graphics-5076e7bc2473f17fd0d3e3fdf27f83088101a295.tar.zst
freebsd-ports-graphics-5076e7bc2473f17fd0d3e3fdf27f83088101a295.zip
pick up github commit:
https://github.com/dovecot/pigeonhole/commit/00651e607c6ea9145ec565dcfd2fdf7d04bb32e9 imapsieve plugin: Fixed assert failure occurring when used with virtual mailboxes. In that case a transaction (delayed sync) is perfromed outside of the context of an IMAP command. PR: 214302 Submitted by: maintainer (Larry Rosenman)
-rw-r--r--mail/dovecot2-pigeonhole/Makefile2
-rw-r--r--mail/dovecot2-pigeonhole/files/patch-src_plugins_imapsieve_imap-sieve-storage.c12
2 files changed, 13 insertions, 1 deletions
diff --git a/mail/dovecot2-pigeonhole/Makefile b/mail/dovecot2-pigeonhole/Makefile
index cd19fdf8c34..746e33a10fb 100644
--- a/mail/dovecot2-pigeonhole/Makefile
+++ b/mail/dovecot2-pigeonhole/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dovecot-pigeonhole
PORTVERSION= 0.4.16
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= http://pigeonhole.dovecot.org/releases/${DOVECOTVERSION}/
DISTNAME= ${PORTNAME:C/-/-${DOVECOTVERSION}-/}-${PORTVERSION}
diff --git a/mail/dovecot2-pigeonhole/files/patch-src_plugins_imapsieve_imap-sieve-storage.c b/mail/dovecot2-pigeonhole/files/patch-src_plugins_imapsieve_imap-sieve-storage.c
new file mode 100644
index 00000000000..427b3ed41ae
--- /dev/null
+++ b/mail/dovecot2-pigeonhole/files/patch-src_plugins_imapsieve_imap-sieve-storage.c
@@ -0,0 +1,12 @@
+--- src/plugins/imapsieve/imap-sieve-storage.c.orig 2016-11-08 02:19:04 UTC
++++ src/plugins/imapsieve/imap-sieve-storage.c
+@@ -531,7 +531,8 @@ imap_sieve_mailbox_transaction_begin(str
+ /* commence parent transaction */
+ t = lbox->super.transaction_begin(box, flags);
+
+- if (isuser == NULL || isuser->sieve_active)
++ if (isuser == NULL || isuser->sieve_active ||
++ isuser->cur_cmd == IMAP_SIEVE_CMD_NONE)
+ return t;
+
+ i_assert(isuser->client != NULL);