aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-02-13 10:05:00 +0800
committerpgj <pgj@FreeBSD.org>2012-02-13 10:05:00 +0800
commit50c979dccab77ff0bc5f2f3e26aa4ab8b69a06ce (patch)
tree61c411500dabf133cd69b34c4e5dc78dcf29a5ec
parent59b03a50f8c8c5b80d07977087d3f8751b7430d6 (diff)
downloadfreebsd-ports-graphics-50c979dccab77ff0bc5f2f3e26aa4ab8b69a06ce.tar.gz
freebsd-ports-graphics-50c979dccab77ff0bc5f2f3e26aa4ab8b69a06ce.tar.zst
freebsd-ports-graphics-50c979dccab77ff0bc5f2f3e26aa4ab8b69a06ce.zip
The zlib-enum package is a stop-gap to provide enumeratees for zlib
compression and decompression. WWW: http://github.com/maltem/zlib-enum Obtained from: FreeBSD Haskell
-rw-r--r--archivers/hs-zlib-enum/Makefile20
-rw-r--r--archivers/hs-zlib-enum/distinfo2
-rw-r--r--archivers/hs-zlib-enum/pkg-descr4
-rw-r--r--lang/ghc/bsd.hackage.mk3
4 files changed, 28 insertions, 1 deletions
diff --git a/archivers/hs-zlib-enum/Makefile b/archivers/hs-zlib-enum/Makefile
new file mode 100644
index 00000000000..0b090e9d6bc
--- /dev/null
+++ b/archivers/hs-zlib-enum/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: hs-zlib-enum
+# Date created: October 18, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+
+PORTNAME= zlib-enum
+PORTVERSION= 0.2.1
+CATEGORIES= archivers haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Enumerator interface for zlib compression
+
+LICENSE= MIT
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= enumerator>=0.4 transformers>=0.2 zlib-bindings
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/archivers/hs-zlib-enum/distinfo b/archivers/hs-zlib-enum/distinfo
new file mode 100644
index 00000000000..4d62f59825f
--- /dev/null
+++ b/archivers/hs-zlib-enum/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/zlib-enum-0.2.1.tar.gz) = 08cf6c400273399cd007e1aa43e41afd74a8fa881eb36bf07e401bf9963edd32
+SIZE (cabal/zlib-enum-0.2.1.tar.gz) = 4652
diff --git a/archivers/hs-zlib-enum/pkg-descr b/archivers/hs-zlib-enum/pkg-descr
new file mode 100644
index 00000000000..f001f85efd4
--- /dev/null
+++ b/archivers/hs-zlib-enum/pkg-descr
@@ -0,0 +1,4 @@
+The zlib-enum package is a stop-gap to provide enumeratees for zlib
+compression and decompression.
+
+WWW: http://github.com/maltem/zlib-enum
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index a8cb16d6cc1..af41ddbfc4f 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -217,4 +217,5 @@ xmonad_port= x11-wm/hs-xmonad # executable
xmonad-contrib_port= x11-wm/hs-xmonad-contrib
zip-archive_port= archivers/hs-zip-archive
zlib_port= archivers/hs-zlib
-zlib-bindings_port= archivers/hs-zlib-bindings \ No newline at end of file
+zlib-bindings_port= archivers/hs-zlib-bindings
+zlib-enum_port= archivers/hs-zlib-enum