aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2010-12-24 18:52:58 +0800
committergahr <gahr@FreeBSD.org>2010-12-24 18:52:58 +0800
commit52ae74114f94d110cad094e6f367c626967daba3 (patch)
tree14adcc85826cb8265b1ea714e45c28620e088a42
parent61e39eb850fe449dcda957eb154d7f59bca73466 (diff)
downloadfreebsd-ports-graphics-52ae74114f94d110cad094e6f367c626967daba3.tar.gz
freebsd-ports-graphics-52ae74114f94d110cad094e6f367c626967daba3.tar.zst
freebsd-ports-graphics-52ae74114f94d110cad094e6f367c626967daba3.zip
- Update to 05_20101219
-rw-r--r--lang/seed7/Makefile10
-rw-r--r--lang/seed7/distinfo4
-rw-r--r--lang/seed7/files/patch-makefile22
-rw-r--r--lang/seed7/pkg-plist2
4 files changed, 24 insertions, 14 deletions
diff --git a/lang/seed7/Makefile b/lang/seed7/Makefile
index 2f79c09e54f..595fa3f0b4e 100644
--- a/lang/seed7/Makefile
+++ b/lang/seed7/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= seed7
-DISTVERSION= 05_20101107
+DISTVERSION= 05_20101219
CATEGORIES= lang
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTNAME}/
DISTNAME= ${PORTNAME}_${DISTVERSION}
@@ -42,12 +42,12 @@ do-configure:
(cd ${WRKSRC} && ${GMAKE} depend)
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/hi ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/../bin/hi ${PREFIX}/bin
${INSTALL} -d ${PREFIX}/lib/${PORTNAME}
(cd ${WRKSRC}/../lib && ${COPYTREE_SHARE} \* ${PREFIX}/lib/${PORTNAME})
- ${INSTALL_DATA} ${WRKSRC}/s7_comp.a ${PREFIX}/lib/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/s7_data.a ${PREFIX}/lib/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/seed7_05.a ${PREFIX}/lib/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/../bin/s7_comp.a ${PREFIX}/lib/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/../bin/s7_data.a ${PREFIX}/lib/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/../bin/seed7_05.a ${PREFIX}/lib/${PORTNAME}
post-install:
.if !defined(NOPORTDOCS)
diff --git a/lang/seed7/distinfo b/lang/seed7/distinfo
index 84a876fe3f0..47864281bc6 100644
--- a/lang/seed7/distinfo
+++ b/lang/seed7/distinfo
@@ -1,2 +1,2 @@
-SHA256 (seed7_05_20101107.tgz) = d7183a033f82b22e3dd70efef22c63c02a316059c4da084a27826b6fd2620f4a
-SIZE (seed7_05_20101107.tgz) = 1453549
+SHA256 (seed7_05_20101219.tgz) = f574afe9cbda07d5d7f36f3c0c7073e976d22836cd84f64fc53db215d74bdd0a
+SIZE (seed7_05_20101219.tgz) = 1472462
diff --git a/lang/seed7/files/patch-makefile b/lang/seed7/files/patch-makefile
index 15a69af12c3..e239f02d134 100644
--- a/lang/seed7/files/patch-makefile
+++ b/lang/seed7/files/patch-makefile
@@ -1,8 +1,8 @@
---- makefile.orig 2009-07-04 13:27:03.000000000 +0200
-+++ makefile 2009-07-08 16:58:47.000000000 +0200
+--- makefile.orig 2010-12-13 23:22:07.000000000 +0000
++++ makefile 2010-12-24 10:11:19.000000000 +0000
@@ -9,12 +9,12 @@
# CFLAGS = -O2 -fomit-frame-pointer -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith
- # CFLAGS = -O2 -fomit-frame-pointer -Wall -Wextra -Wswitch-default -Wswitch-enum -Wcast-qual -Waggregate-return -Wwrite-strings -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith -Wmissing-noreturn -Wno-multichar
+ # CFLAGS = -O2 -g -Wall -Wextra -Wswitch-default -Wswitch-enum -Wcast-qual -Waggregate-return -Wwrite-strings -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith -Wmissing-noreturn -Wno-multichar
# CFLAGS = -O2 -fomit-frame-pointer -Wall -Wextra -Wswitch-default -Wcast-qual -Waggregate-return -Wwrite-strings -Winline -Wconversion -Wshadow -Wpointer-arith -Wmissing-noreturn -Wno-multichar
-CFLAGS = -O2 -g -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith
+CFLAGS = -O2 -g -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith -I%%LOCALBASE%%/include
@@ -10,8 +10,16 @@
# CFLAGS = -O2 -g -pg -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith
# CFLAGS = -O2 -fomit-frame-pointer -funroll-loops -Wall
# CFLAGS = -O2 -funroll-loops -Wall -pg
--LFLAGS =
-+LFLAGS = -L%%LOCALBASE%%/lib
- # LFLAGS = -pg
- # LFLAGS = -pg -lc_p
+-LDFLAGS =
++LDFLAGS = -L%%LOCALBASE%%/lib
+ # LDFLAGS = -pg
+ # LDFLAGS = -pg -lc_p
# LIBS = /usr/Xlib/libX11.so -lncurses -lm
+@@ -102,6 +102,7 @@
+ $(MAKE) ../prg/hi
+ ../bin/hi level
+
++.PHONY: hi
+ hi: ../bin/hi
+
+ ../prg/hi:
diff --git a/lang/seed7/pkg-plist b/lang/seed7/pkg-plist
index 371f1fa2cec..3421c09dbf1 100644
--- a/lang/seed7/pkg-plist
+++ b/lang/seed7/pkg-plist
@@ -60,6 +60,7 @@ lib/seed7/stdfont24.s7i
lib/seed7/strifile.s7i
lib/seed7/stritext.s7i
lib/seed7/syntax.s7i
+lib/seed7/tar.s7i
lib/seed7/tee.s7i
lib/seed7/time.s7i
lib/seed7/upper.s7i
@@ -137,6 +138,7 @@ lib/seed7/zip.s7i
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kbd.sd7
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lander.sd7
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mahjong.sd7
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/make7.sd7
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mandelbr.sd7
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mind.sd7
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ms.sd7