aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2005-02-28 03:24:45 +0800
committertobez <tobez@FreeBSD.org>2005-02-28 03:24:45 +0800
commit55ed7ae95ac6f1f08e703ff60fcb34abf819f289 (patch)
treedc2303c7d9150395dbe0361f05c8b3a795b76179
parentbf89039293a5e10fd6d32280b789222b92740376 (diff)
downloadfreebsd-ports-graphics-55ed7ae95ac6f1f08e703ff60fcb34abf819f289.tar.gz
freebsd-ports-graphics-55ed7ae95ac6f1f08e703ff60fcb34abf819f289.tar.zst
freebsd-ports-graphics-55ed7ae95ac6f1f08e703ff60fcb34abf819f289.zip
Add p5-File-PathConvert, a perl module to perform various path
manipulations. Although the author of the module has deprecated it and asks to use File::Spec and Cwd instead, it apparently is still being used (by freshports, for example).
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-File-PathConvert/Makefile22
-rw-r--r--devel/p5-File-PathConvert/distinfo2
-rw-r--r--devel/p5-File-PathConvert/pkg-descr8
-rw-r--r--devel/p5-File-PathConvert/pkg-plist5
5 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 07a6e45052d..0c1a06cf66c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -845,6 +845,7 @@
SUBDIR += p5-File-NCopy
SUBDIR += p5-File-NFSLock
SUBDIR += p5-File-Path-Expand
+ SUBDIR += p5-File-PathConvert
SUBDIR += p5-File-ReadBackwards
SUBDIR += p5-File-Remove
SUBDIR += p5-File-Slurp
diff --git a/devel/p5-File-PathConvert/Makefile b/devel/p5-File-PathConvert/Makefile
new file mode 100644
index 00000000000..9633658135b
--- /dev/null
+++ b/devel/p5-File-PathConvert/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: devel/p5-File-PathConvert
+# Date created: 27 February 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-PathConvert
+PORTVERSION= 0.9
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= File::PathConvert - Various path conversion routines
+
+PERL_CONFIGURE= yes
+
+MAN3= File::PathConvert.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-PathConvert/distinfo b/devel/p5-File-PathConvert/distinfo
new file mode 100644
index 00000000000..307f9b373c4
--- /dev/null
+++ b/devel/p5-File-PathConvert/distinfo
@@ -0,0 +1,2 @@
+MD5 (File-PathConvert-0.9.tar.gz) = 64e731d1165a0bd5e8f3de93775d7795
+SIZE (File-PathConvert-0.9.tar.gz) = 23807
diff --git a/devel/p5-File-PathConvert/pkg-descr b/devel/p5-File-PathConvert/pkg-descr
new file mode 100644
index 00000000000..3bc6355345c
--- /dev/null
+++ b/devel/p5-File-PathConvert/pkg-descr
@@ -0,0 +1,8 @@
+File::PathConvert provides functions to convert between absolute and
+relative paths, and from logical paths to physical paths on a variety of
+filesystems, including the URL 'filesystem'.
+
+For new programs, it is probably better to use File::Spec and Cwd
+modules, if you can help it.
+
+WWW: http://search.cpan.org/dist/File-PathConvert
diff --git a/devel/p5-File-PathConvert/pkg-plist b/devel/p5-File-PathConvert/pkg-plist
new file mode 100644
index 00000000000..5e70cba6045
--- /dev/null
+++ b/devel/p5-File-PathConvert/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/File/PathConvert.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/PathConvert/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/PathConvert 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/File 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/File 2>/dev/null || true