aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2013-09-23 04:25:06 +0800
committerak <ak@FreeBSD.org>2013-09-23 04:25:06 +0800
commit5a3e7a2382a3b747f50c75b7e76b1f28ebde3d22 (patch)
tree066bb4f2d0cee41da30592525994849859798eca
parent8746a9604076ddd5f4fa4762f1feebf95f641968 (diff)
downloadfreebsd-ports-graphics-5a3e7a2382a3b747f50c75b7e76b1f28ebde3d22.tar.gz
freebsd-ports-graphics-5a3e7a2382a3b747f50c75b7e76b1f28ebde3d22.tar.zst
freebsd-ports-graphics-5a3e7a2382a3b747f50c75b7e76b1f28ebde3d22.zip
- Fix PKGDB_FIX option
- Improvements to pkgng patch PR: ports/182268 Submitted by: Ken DEGUCHI <kdeguchi@sz.tokoha-u.ac.jp> (maintainer)
-rw-r--r--ports-mgmt/pkg_replace/Makefile4
-rw-r--r--ports-mgmt/pkg_replace/files/patch-pkg_replace_pkgng13
2 files changed, 14 insertions, 3 deletions
diff --git a/ports-mgmt/pkg_replace/Makefile b/ports-mgmt/pkg_replace/Makefile
index 85e607035ad..bcf7b4a036f 100644
--- a/ports-mgmt/pkg_replace/Makefile
+++ b/ports-mgmt/pkg_replace/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pkg_replace
PORTVERSION= 0.8.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ports-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
MASTER_SITE_SUBDIR=portutil/22116
@@ -23,6 +23,8 @@ OPTIONS_DEFINE= ZSH
.if empty(WITH_PKGNG)
OPTIONS_DEFINE+= PKGDB_FIX
PKGDB_FIX_DESC= Fixing tool of installed package dependencies
+.else
+PLIST_SUB+= PKGDB_FIX="@comment "
.endif
OPTIONS_SUB= yes
diff --git a/ports-mgmt/pkg_replace/files/patch-pkg_replace_pkgng b/ports-mgmt/pkg_replace/files/patch-pkg_replace_pkgng
index ea68a49ac66..437379020d1 100644
--- a/ports-mgmt/pkg_replace/files/patch-pkg_replace_pkgng
+++ b/ports-mgmt/pkg_replace/files/patch-pkg_replace_pkgng
@@ -1,5 +1,5 @@
--- sbin/pkg_replace/pkg_replace.sh.orig 2007-01-25 21:55:46.000000000 +0900
-+++ sbin/pkg_replace/pkg_replace.sh 2013-05-31 04:13:29.000000000 +0900
++++ sbin/pkg_replace/pkg_replace.sh 2013-09-03 06:58:43.000000000 +0900
@@ -125,14 +125,27 @@
: ${PACKAGEROOT="ftp://ftp.NetBSD.org"}
: ${PKG_SUFX=".tgz"}
@@ -184,6 +184,15 @@
pkg_depends '_deps' "${_arg}"
for p in ${_deps}; do
+@@ -715,7 +783,7 @@
+ if empty ${_log}; then
+ try "$@" || return $?
+ else
+- _cookie="${tmpdir}/.$1_failed"
++ _cookie="${tmpdir}/.${1##*/}_failed"
+
+ { try "$@" || echo $? > "${_cookie}"; } | tee -a "${_log}" ||
+ warn "tee(1) failed."
@@ -757,9 +825,11 @@
info "Installing '$1'"
@@ -292,7 +301,7 @@
update_dependencies() {
+ if is_yes ${use_pkgng}; then
+ info "Updating the dependencies"
-+ ${PKG_SET} -y -o $1:$2 || return 1
++ [ "x$1" = "x$2" ] && return 0 || ${PKG_SET} -y -o $1:$2
+ info " $1 -> $2"
+ else
local p req_by