aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-06-28 22:35:28 +0800
committerjylefort <jylefort@FreeBSD.org>2005-06-28 22:35:28 +0800
commit5b650d2cf364052794f5e18b89f5f2e197e62b7c (patch)
treed9d19ac5686dbf83d3b813351de5b1f5bad7fb9a
parent0af97410bef185dd0f953c05b28c805f43a41918 (diff)
downloadfreebsd-ports-graphics-5b650d2cf364052794f5e18b89f5f2e197e62b7c.tar.gz
freebsd-ports-graphics-5b650d2cf364052794f5e18b89f5f2e197e62b7c.tar.zst
freebsd-ports-graphics-5b650d2cf364052794f5e18b89f5f2e197e62b7c.zip
Add p5-Data-Taxonomy-Tags.
Data::Taxonomy::Tags will basically take care of easily managing tags for an item. You provide it with a string of tags and it will allow you to call methods to get all the tags and categories as well as add and delete tags from the list. WWW: http://search.cpan.org/dist/Data-Taxonomy-Tags/ PR: ports/82669 Submitted by: Aaron Dalton <aaron@daltons.ca>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Data-Taxonomy-Tags/Makefile22
-rw-r--r--devel/p5-Data-Taxonomy-Tags/distinfo2
-rw-r--r--devel/p5-Data-Taxonomy-Tags/pkg-descr9
-rw-r--r--devel/p5-Data-Taxonomy-Tags/pkg-plist5
5 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6521da3f606..de5d3534449 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -768,6 +768,7 @@
SUBDIR += p5-Data-ShowTable
SUBDIR += p5-Data-Stag
SUBDIR += p5-Data-Table
+ SUBDIR += p5-Data-Taxonomy-Tags
SUBDIR += p5-Data-TemporaryBag
SUBDIR += p5-Data-TreeDumper
SUBDIR += p5-Data-UUID
diff --git a/devel/p5-Data-Taxonomy-Tags/Makefile b/devel/p5-Data-Taxonomy-Tags/Makefile
new file mode 100644
index 00000000000..19dd0515ca2
--- /dev/null
+++ b/devel/p5-Data-Taxonomy-Tags/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Data-Taxonomy-Tags
+# Date created: 26 June 2005
+# Whom: Aaron Dalton <aaron@daltons.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Taxonomy-Tags
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@daltons.ca
+COMMENT= Represents a set of tags for any item
+
+MAN3= Data::Taxonomy::Tags.3 Data::Taxonomy::Tags::Tag.3
+
+PERL_MODBUILD= yes
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Data-Taxonomy-Tags/distinfo b/devel/p5-Data-Taxonomy-Tags/distinfo
new file mode 100644
index 00000000000..fac7d8107de
--- /dev/null
+++ b/devel/p5-Data-Taxonomy-Tags/distinfo
@@ -0,0 +1,2 @@
+MD5 (Data-Taxonomy-Tags-0.04.tar.gz) = a3f3619fabc3c6c0fddea0184c5e08f8
+SIZE (Data-Taxonomy-Tags-0.04.tar.gz) = 4534
diff --git a/devel/p5-Data-Taxonomy-Tags/pkg-descr b/devel/p5-Data-Taxonomy-Tags/pkg-descr
new file mode 100644
index 00000000000..124e3c654a7
--- /dev/null
+++ b/devel/p5-Data-Taxonomy-Tags/pkg-descr
@@ -0,0 +1,9 @@
+Data::Taxonomy::Tags will basically take care of easily managing tags for an
+item. You provide it with a string of tags and it will allow you to call
+methods to get all the tags and categories as well as add and delete tags
+from the list.
+
+WWW: http://search.cpan.org/dist/Data-Taxonomy-Tags/
+
+- Aaron Dalton
+aaron@daltons.ca
diff --git a/devel/p5-Data-Taxonomy-Tags/pkg-plist b/devel/p5-Data-Taxonomy-Tags/pkg-plist
new file mode 100644
index 00000000000..623f50d800b
--- /dev/null
+++ b/devel/p5-Data-Taxonomy-Tags/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Data/Taxonomy/Tags.pm
+%%SITE_PERL%%/Data/Taxonomy/Tags/Tag.pm
+@dirrm %%SITE_PERL%%/Data/Taxonomy/Tags
+@unexec rmdir %D/%%SITE_PERL%%/Data/Taxonomy 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Data 2>/dev/null || true