aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-03-31 11:48:30 +0800
committerwill <will@FreeBSD.org>2001-03-31 11:48:30 +0800
commit5b9c7f0b3b0c0b2a8d3bc42a31467d1d4073fa6e (patch)
tree2a5c49f5e8a862b62200374dc475af44c68d8bbf
parent13d73ec8794b478e5c4e224a0879361c11c430ca (diff)
downloadfreebsd-ports-graphics-5b9c7f0b3b0c0b2a8d3bc42a31467d1d4073fa6e.tar.gz
freebsd-ports-graphics-5b9c7f0b3b0c0b2a8d3bc42a31467d1d4073fa6e.tar.zst
freebsd-ports-graphics-5b9c7f0b3b0c0b2a8d3bc42a31467d1d4073fa6e.zip
Add irc-transport 0.1b-1.40, IRC-Transport for Jabber server.
PR: 25088 Submitted by: Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
-rw-r--r--irc/Makefile1
-rw-r--r--irc/irc-transport/Makefile37
-rw-r--r--irc/irc-transport/distinfo1
-rw-r--r--irc/irc-transport/files/patch-src::Makefile.in19
-rw-r--r--irc/irc-transport/pkg-comment1
-rw-r--r--irc/irc-transport/pkg-descr5
-rw-r--r--irc/irc-transport/pkg-plist2
7 files changed, 66 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index 2864742906e..e80ddd893f3 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -9,6 +9,7 @@
SUBDIR += ezbounce
SUBDIR += infobot
SUBDIR += irc
+ SUBDIR += irc-transport
SUBDIR += ircII
SUBDIR += ircatlite
SUBDIR += ircd-hybrid
diff --git a/irc/irc-transport/Makefile b/irc/irc-transport/Makefile
new file mode 100644
index 00000000000..25eea36d058
--- /dev/null
+++ b/irc/irc-transport/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: irc-transport
+# Date created: 12 December 2000
+# Whom: Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
+#
+# $FreeBSD$
+
+
+PORTNAME= irc-transport
+PORTVERSION= 0.1b-1.40
+CATEGORIES= irc
+MASTER_SITES= http://download.jabber.org/dists/1.4/final/
+DISTFILES= ${PORTNAME}-${PORTVERSION}.linux${EXTRACT_SUFX}
+
+MAINTAINER= leeym@cae.ce.ntu.edu.tw
+
+BUILD_DEPENDS= ${NONEXISTENT}:${JABBER_PORT}:configure
+RUN_DEPENDS= jabberd:${JABBER_PORT}
+
+.include <bsd.port.pre.mk>
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-jabberd=${JABBER_WRKSRC}
+JABBER_PORT= ${PORTSDIR}/net/jabber
+JABBER_WRKSRC!= cd ${JABBER_PORT} && ${MAKE} -V WRKSRC
+
+do-install:
+ @${MKDIR} ${PREFIX}/lib/jabber/${PORTNAME}
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/irc_transport.so ${PREFIX}/lib/jabber/${PORTNAME}
+ @${ECHO} ""
+ @${ECHO} "============================================================================="
+ @${ECHO} "Please read ${WRKSRC}/README first"
+ @${ECHO} "and add \"./${PORTNAME}/irc_transport.so\" ${PREFIX}/etc/jabber.xml"
+ @${ECHO} "then restart jabberd to enable ${PORTNAME}"
+ @${ECHO} "============================================================================="
+ @${ECHO} ""
+
+.include <bsd.port.post.mk>
diff --git a/irc/irc-transport/distinfo b/irc/irc-transport/distinfo
new file mode 100644
index 00000000000..6205a776693
--- /dev/null
+++ b/irc/irc-transport/distinfo
@@ -0,0 +1 @@
+MD5 (irc-transport-0.1b-1.40.linux.tar.gz) = 5ccf1bb828e3d813380f100e4d11f7f6
diff --git a/irc/irc-transport/files/patch-src::Makefile.in b/irc/irc-transport/files/patch-src::Makefile.in
new file mode 100644
index 00000000000..e20a318278d
--- /dev/null
+++ b/irc/irc-transport/files/patch-src::Makefile.in
@@ -0,0 +1,19 @@
+--- src/Makefile.in.orig Thu Feb 8 02:31:02 2001
++++ src/Makefile.in Mon Feb 12 09:32:49 2001
+@@ -31,6 +31,7 @@
+ mandir = @mandir@
+ includedir = @includedir@
+ oldincludedir = /usr/include
++localincludedir = /usr/local/include
+
+ DESTDIR =
+
+@@ -72,7 +73,7 @@
+ VERSION = @VERSION@
+
+ CFLAGS = -g -fPIC -shared
+-INCLUDES = -I$(JABBERD_INC) -I$(top_builddir)/include
++INCLUDES = -I$(JABBERD_INC) -I$(top_builddir)/include -I$(oldincludedir) -I$(localincludedir)
+ bin_PROGRAMS = irc_transport.so
+
+ irc_transport_so_SOURCES = util.c init.c irc_in.c irc_out.c
diff --git a/irc/irc-transport/pkg-comment b/irc/irc-transport/pkg-comment
new file mode 100644
index 00000000000..fc6adb44e7f
--- /dev/null
+++ b/irc/irc-transport/pkg-comment
@@ -0,0 +1 @@
+IRC-Transport for Jabber server
diff --git a/irc/irc-transport/pkg-descr b/irc/irc-transport/pkg-descr
new file mode 100644
index 00000000000..360353760ee
--- /dev/null
+++ b/irc/irc-transport/pkg-descr
@@ -0,0 +1,5 @@
+IRC-Transport allows Jabber users to communicate with IRC
+servers and IRC users, by bridging the gap between the two networks
+
+--
+Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
diff --git a/irc/irc-transport/pkg-plist b/irc/irc-transport/pkg-plist
new file mode 100644
index 00000000000..0d5834a7942
--- /dev/null
+++ b/irc/irc-transport/pkg-plist
@@ -0,0 +1,2 @@
+lib/jabber/irc-transport/irc_transport.so
+@dirrm lib/jabber/irc-transport