aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2011-11-15 21:06:08 +0800
committergahr <gahr@FreeBSD.org>2011-11-15 21:06:08 +0800
commit5c556e0f33c2717af034aa27068fc4325ef0df3b (patch)
tree441f952a394dbfaa645f1bcef9cc3409ed7e7cec
parent434262d99ae319bfb60a06ccb5d7b6ceb0ab58e5 (diff)
downloadfreebsd-ports-graphics-5c556e0f33c2717af034aa27068fc4325ef0df3b.tar.gz
freebsd-ports-graphics-5c556e0f33c2717af034aa27068fc4325ef0df3b.tar.zst
freebsd-ports-graphics-5c556e0f33c2717af034aa27068fc4325ef0df3b.zip
- Unbreak - fix build with latest x11-toolkits/fltk
Feature safe: yes
-rw-r--r--games/toycars/Makefile2
-rw-r--r--games/toycars/files/patch-toycars_track_editor-src_TrackView.cxx21
2 files changed, 21 insertions, 2 deletions
diff --git a/games/toycars/Makefile b/games/toycars/Makefile
index 85733bf0129..e25a66a6971 100644
--- a/games/toycars/Makefile
+++ b/games/toycars/Makefile
@@ -16,8 +16,6 @@ COMMENT= Physics-based 2D racing game
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
-BROKEN= does not compile
-
USE_SDL= image sdl
USE_GL= gl glu
USE_GMAKE= yes
diff --git a/games/toycars/files/patch-toycars_track_editor-src_TrackView.cxx b/games/toycars/files/patch-toycars_track_editor-src_TrackView.cxx
new file mode 100644
index 00000000000..8c55b99004f
--- /dev/null
+++ b/games/toycars/files/patch-toycars_track_editor-src_TrackView.cxx
@@ -0,0 +1,21 @@
+--- toycars_track_editor/src/TrackView.cxx.orig 2011-11-15 13:59:38.000000000 +0100
++++ toycars_track_editor/src/TrackView.cxx 2011-11-15 14:00:41.000000000 +0100
+@@ -6,12 +6,12 @@
+ #include "ScAnimation.h"
+ #include "tinyxml.h"
+ #include "ScException.h"
+-#include <Fl/Fl_JPEG_Image.H>
+-#include <Fl/Fl_PNG_Image.H>
+-#include <Fl/Fl_BMP_Image.H>
+-#include <Fl/Fl_PNM_Image.H>
+-#include <Fl/Fl_GIF_Image.H>
+-#include <Fl/Fl_XPM_Image.H>
++#include <FL/Fl_JPEG_Image.H>
++#include <FL/Fl_PNG_Image.H>
++#include <FL/Fl_BMP_Image.H>
++#include <FL/Fl_PNM_Image.H>
++#include <FL/Fl_GIF_Image.H>
++#include <FL/Fl_XPM_Image.H>
+ #include <FL/Fl_File_Chooser.H> // fl_alert
+ #include "GameConstants.h"
+ #include "TrackEditorUI.h"