aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-01-15 05:16:21 +0800
committerkrion <krion@FreeBSD.org>2004-01-15 05:16:21 +0800
commit5ed15a8e73704e41ad7b412e6b81c0db33c475a9 (patch)
tree0bd9a1fc373c559e0f040cb2622aa38c585519b2
parentb5166fabea744b3be1ed21f6576440833a9827e7 (diff)
downloadfreebsd-ports-graphics-5ed15a8e73704e41ad7b412e6b81c0db33c475a9.tar.gz
freebsd-ports-graphics-5ed15a8e73704e41ad7b412e6b81c0db33c475a9.tar.zst
freebsd-ports-graphics-5ed15a8e73704e41ad7b412e6b81c0db33c475a9.zip
- Update to 0.15.13.2, to fix Alpha SIGFPE (we use -mieee now)
- Support WITH_DB_VER=42 to build against db42 rather than default db4 - Switch to bz2 to reduce download time and data volume. - Fix up forgotten src/version.c update to 0.15.13.2 PR: 61284 Submitted by: maintainer
-rw-r--r--mail/bogofilter-current/Makefile25
-rw-r--r--mail/bogofilter-current/distinfo2
-rw-r--r--mail/bogofilter/Makefile25
-rw-r--r--mail/bogofilter/distinfo2
4 files changed, 44 insertions, 10 deletions
diff --git a/mail/bogofilter-current/Makefile b/mail/bogofilter-current/Makefile
index 000384f4706..58305566f36 100644
--- a/mail/bogofilter-current/Makefile
+++ b/mail/bogofilter-current/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= bogofilter
-PORTVERSION= 0.15.13.1
-PORTREVISION= 0
+PORTVERSION= 0.15.13.2
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,19 +16,28 @@ COMMENT= "Fast, teachable, learning spam detector"
# There is a sibling port, bogofilter-tdb, which presets different
# values for some of our variables
+WITH_DB_VER?= 4
+.if ${WITH_DB_VER} == 42
+LIB_DEPENDS?= db-4.2.2:${PORTSDIR}/databases/db42
+libs= -ldb-4.2
+.else
+WITH_DB_VER= 4
LIB_DEPENDS?= db4.0:${PORTSDIR}/databases/db4
+libs= -ldb4
+.endif
LIB_DEPENDS+= gsl.5:${PORTSDIR}/math/gsl
CONFLICTS?= bogofilter-tdb* bogofilter-qdbm*
+USE_BZIP2= yes
USE_REINPLACE= yes
USE_PERL5_RUN= yes
GNU_CONFIGURE= yes
PATCH_STRIP= -p1
CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc
-CONFIGURE_ENV?= CPPFLAGS="-I${LOCALBASE}/include/db4" \
- LDFLAGS="-L${LOCALBASE}/lib" LIBS="-ldb4"
+CONFIGURE_ENV?= CPPFLAGS="-I${LOCALBASE}/include/db${WITH_DB_VER}" \
+ LDFLAGS="-L${LOCALBASE}/lib" LIBS="${libs}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= bogofilter.1 bogoutil.1 bogoupgrade.1 bogolexer.1 bogotune.1
@@ -38,6 +46,15 @@ post-patch:
${WRKSRC}/contrib/randomtrain \
${WRKSRC}/contrib/scramble \
${WRKSRC}/contrib/trainbogo.sh
+ ${REINPLACE_CMD} -e "s/0.15.13.1/0.15.13.2/" ${WRKSRC}/src/version.c
+
+.if !defined(PKGNAMESUFFIX) && ${WITH_DB_VER} != 42
+pre-everything::
+ @${ECHO} ""
+ @${ECHO} "Use -DWITH_DB_VER=42 to link against db42 instead of the default db4"
+ @${ECHO} ""
+.endif
+
post-build::
cd ${WRKSRC} && make check SHELL=${SH}
diff --git a/mail/bogofilter-current/distinfo b/mail/bogofilter-current/distinfo
index 847f9805050..6b5788694bf 100644
--- a/mail/bogofilter-current/distinfo
+++ b/mail/bogofilter-current/distinfo
@@ -1 +1 @@
-MD5 (bogofilter-0.15.13.1.tar.gz) = 4dff0a39cfa81753c0d3a546ed0bc908
+MD5 (bogofilter-0.15.13.2.tar.bz2) = 1d52ab08c6f198a511dc516a3ce801c5
diff --git a/mail/bogofilter/Makefile b/mail/bogofilter/Makefile
index 000384f4706..58305566f36 100644
--- a/mail/bogofilter/Makefile
+++ b/mail/bogofilter/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= bogofilter
-PORTVERSION= 0.15.13.1
-PORTREVISION= 0
+PORTVERSION= 0.15.13.2
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,19 +16,28 @@ COMMENT= "Fast, teachable, learning spam detector"
# There is a sibling port, bogofilter-tdb, which presets different
# values for some of our variables
+WITH_DB_VER?= 4
+.if ${WITH_DB_VER} == 42
+LIB_DEPENDS?= db-4.2.2:${PORTSDIR}/databases/db42
+libs= -ldb-4.2
+.else
+WITH_DB_VER= 4
LIB_DEPENDS?= db4.0:${PORTSDIR}/databases/db4
+libs= -ldb4
+.endif
LIB_DEPENDS+= gsl.5:${PORTSDIR}/math/gsl
CONFLICTS?= bogofilter-tdb* bogofilter-qdbm*
+USE_BZIP2= yes
USE_REINPLACE= yes
USE_PERL5_RUN= yes
GNU_CONFIGURE= yes
PATCH_STRIP= -p1
CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc
-CONFIGURE_ENV?= CPPFLAGS="-I${LOCALBASE}/include/db4" \
- LDFLAGS="-L${LOCALBASE}/lib" LIBS="-ldb4"
+CONFIGURE_ENV?= CPPFLAGS="-I${LOCALBASE}/include/db${WITH_DB_VER}" \
+ LDFLAGS="-L${LOCALBASE}/lib" LIBS="${libs}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= bogofilter.1 bogoutil.1 bogoupgrade.1 bogolexer.1 bogotune.1
@@ -38,6 +46,15 @@ post-patch:
${WRKSRC}/contrib/randomtrain \
${WRKSRC}/contrib/scramble \
${WRKSRC}/contrib/trainbogo.sh
+ ${REINPLACE_CMD} -e "s/0.15.13.1/0.15.13.2/" ${WRKSRC}/src/version.c
+
+.if !defined(PKGNAMESUFFIX) && ${WITH_DB_VER} != 42
+pre-everything::
+ @${ECHO} ""
+ @${ECHO} "Use -DWITH_DB_VER=42 to link against db42 instead of the default db4"
+ @${ECHO} ""
+.endif
+
post-build::
cd ${WRKSRC} && make check SHELL=${SH}
diff --git a/mail/bogofilter/distinfo b/mail/bogofilter/distinfo
index 847f9805050..6b5788694bf 100644
--- a/mail/bogofilter/distinfo
+++ b/mail/bogofilter/distinfo
@@ -1 +1 @@
-MD5 (bogofilter-0.15.13.1.tar.gz) = 4dff0a39cfa81753c0d3a546ed0bc908
+MD5 (bogofilter-0.15.13.2.tar.bz2) = 1d52ab08c6f198a511dc516a3ce801c5