aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2005-10-14 13:03:35 +0800
committerahze <ahze@FreeBSD.org>2005-10-14 13:03:35 +0800
commit626e877fa9f7ebfd9d983bc5f094dae5edad80c3 (patch)
tree90f7c50b2254fd2b911ec7bd6684a0bf88935aba
parent7249bf3a989c5535bbaeb4f70e8bdb0a183b4f7a (diff)
downloadfreebsd-ports-graphics-626e877fa9f7ebfd9d983bc5f094dae5edad80c3.tar.gz
freebsd-ports-graphics-626e877fa9f7ebfd9d983bc5f094dae5edad80c3.tar.zst
freebsd-ports-graphics-626e877fa9f7ebfd9d983bc5f094dae5edad80c3.zip
- Add p5-HTTP-Cache-Transparent
Implementation of http get that keeps a local cache of fetched pages to avoid fetching the same data from the server if it hasn't been updated. The cache is stored on disk and is thus persistent between invocations.
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTTP-Cache-Transparent/Makefile24
-rw-r--r--www/p5-HTTP-Cache-Transparent/distinfo2
-rw-r--r--www/p5-HTTP-Cache-Transparent/pkg-descr5
-rw-r--r--www/p5-HTTP-Cache-Transparent/pkg-plist7
5 files changed, 39 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 579a7467779..b1837a8cc38 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -549,6 +549,7 @@
SUBDIR += p5-HTML-Webmake
SUBDIR += p5-HTML-Widgets-SelectLayers
SUBDIR += p5-HTTP-BrowserDetect
+ SUBDIR += p5-HTTP-Cache-Transparent
SUBDIR += p5-HTTP-DAV
SUBDIR += p5-HTTP-GHTTP
SUBDIR += p5-HTTP-Lite
diff --git a/www/p5-HTTP-Cache-Transparent/Makefile b/www/p5-HTTP-Cache-Transparent/Makefile
new file mode 100644
index 00000000000..72cf78df5f7
--- /dev/null
+++ b/www/p5-HTTP-Cache-Transparent/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-HTTP-Cache-Transparent
+# Date created: 2005-10-14
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-Cache-Transparent
+PORTVERSION= 0.6
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTTP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ahze@FreeBSD.org
+COMMENT= Implementation of http get that keeps a local cache of fetched pages
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+MAN3= HTTP::Cache::Transparent.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTTP-Cache-Transparent/distinfo b/www/p5-HTTP-Cache-Transparent/distinfo
new file mode 100644
index 00000000000..464ab19ada0
--- /dev/null
+++ b/www/p5-HTTP-Cache-Transparent/distinfo
@@ -0,0 +1,2 @@
+MD5 (HTTP-Cache-Transparent-0.6.tar.gz) = 49208c9cd61f8f687c5f5031845c5de2
+SIZE (HTTP-Cache-Transparent-0.6.tar.gz) = 7571
diff --git a/www/p5-HTTP-Cache-Transparent/pkg-descr b/www/p5-HTTP-Cache-Transparent/pkg-descr
new file mode 100644
index 00000000000..7d7dfae3ed0
--- /dev/null
+++ b/www/p5-HTTP-Cache-Transparent/pkg-descr
@@ -0,0 +1,5 @@
+Implementation of http get that keeps a local cache of fetched pages to
+avoid fetching the same data from the server if it hasn't been updated.
+The cache is stored on disk and is thus persistent between invocations.
+
+WWW: http://search.cpan.org/~mattiash/HTTP-Cache-Transparent/
diff --git a/www/p5-HTTP-Cache-Transparent/pkg-plist b/www/p5-HTTP-Cache-Transparent/pkg-plist
new file mode 100644
index 00000000000..fc2c59401e1
--- /dev/null
+++ b/www/p5-HTTP-Cache-Transparent/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/HTTP/Cache/Transparent.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Cache/Transparent/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Cache/Transparent
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Cache 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTTP/Cache 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTTP 2>/dev/null || true