aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-05-21 02:01:27 +0800
committerpav <pav@FreeBSD.org>2005-05-21 02:01:27 +0800
commit64c2cf3e475675e82470dbf2f1af7c532bd4e2f8 (patch)
treea01a1e925c1b5763221df3cd35baaff0ef222283
parent5355573996e3275b6a508e274fa3a1eabc1f6567 (diff)
downloadfreebsd-ports-graphics-64c2cf3e475675e82470dbf2f1af7c532bd4e2f8.tar.gz
freebsd-ports-graphics-64c2cf3e475675e82470dbf2f1af7c532bd4e2f8.tar.zst
freebsd-ports-graphics-64c2cf3e475675e82470dbf2f1af7c532bd4e2f8.zip
This is a small shell script intended to be used in portable Unix install
scripts for showing progress bars. PR: ports/81216 Submitted by: Erik Greenwald <erik@smluc.org>
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/bar/Makefile25
-rw-r--r--textproc/bar/distinfo2
-rw-r--r--textproc/bar/pkg-descr14
4 files changed, 42 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 7d55820fea0..594d88f0056 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -20,6 +20,7 @@
SUBDIR += asm2html
SUBDIR += aspell
SUBDIR += az-aspell
+ SUBDIR += bar
SUBDIR += be-aspell
SUBDIR += bedic-data
SUBDIR += bg-aspell
diff --git a/textproc/bar/Makefile b/textproc/bar/Makefile
new file mode 100644
index 00000000000..7c3546bd4a5
--- /dev/null
+++ b/textproc/bar/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: bar
+# Date created: Wed May 18 2005
+# Whom: Erik Greenwald <erik@smluc.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bar
+PORTVERSION= 1.2
+CATEGORIES= textproc
+MASTER_SITES= http://www.theiling.de/downloads/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= erik@smluc.org
+COMMENT= Cat with ASCII progress bar
+
+USE_BZIP2= yes
+NO_BUILD= yes
+PLIST_FILES= bin/bar
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bar ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/textproc/bar/distinfo b/textproc/bar/distinfo
new file mode 100644
index 00000000000..ff8f47a3c02
--- /dev/null
+++ b/textproc/bar/distinfo
@@ -0,0 +1,2 @@
+MD5 (bar-1.2-src.tar.bz2) = 2f5d5667b08f2a70ea12f2a58a66cefb
+SIZE (bar-1.2-src.tar.bz2) = 4860
diff --git a/textproc/bar/pkg-descr b/textproc/bar/pkg-descr
new file mode 100644
index 00000000000..494c13ec067
--- /dev/null
+++ b/textproc/bar/pkg-descr
@@ -0,0 +1,14 @@
+This is a small shell script intended to be used in portable Unix install
+scripts for showing progress bars.
+
+The overall goal is to write a minimally complex shell script (thus a program
+that needs no compilation) that is as robust as possible to work on as many
+Bourne shells and operating systems as possible, and that implements 'cat'
+with an ASCII progress bar and some other nifty features.
+
+This is pure Bourne shell code. (For sh, ash, ksh, zsh, bash, ...)
+
+The script is mainly indented to be used in portable install scripts, where
+you can use the body of the script.
+
+WWW: http://www.theiling.de/projects/bar.html