aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2012-06-28 03:52:13 +0800
committerjohans <johans@FreeBSD.org>2012-06-28 03:52:13 +0800
commit65aec6f1482cdbbcff15593ddd76dbc8010a8525 (patch)
tree00379e637907602d3fa097ccab787fbd98953ef4
parent07eda3852bc78d11f86e85e0ee88cefbc606f615 (diff)
downloadfreebsd-ports-graphics-65aec6f1482cdbbcff15593ddd76dbc8010a8525.tar.gz
freebsd-ports-graphics-65aec6f1482cdbbcff15593ddd76dbc8010a8525.tar.zst
freebsd-ports-graphics-65aec6f1482cdbbcff15593ddd76dbc8010a8525.zip
Convert to new options framework
-rw-r--r--news/slrn/Makefile8
-rw-r--r--news/tin/Makefile2
-rw-r--r--print/texinfo/Makefile12
-rw-r--r--security/gsasl/Makefile10
-rw-r--r--security/gss/Makefile12
-rw-r--r--security/shishi/Makefile12
-rw-r--r--textproc/diffutils/Makefile10
-rw-r--r--textproc/flex/Makefile4
-rw-r--r--textproc/ocaml-pxp/Makefile8
-rw-r--r--www/qdecoder/Makefile2
10 files changed, 47 insertions, 33 deletions
diff --git a/news/slrn/Makefile b/news/slrn/Makefile
index 79d63230c27..024eaf76a56 100644
--- a/news/slrn/Makefile
+++ b/news/slrn/Makefile
@@ -30,12 +30,12 @@ OPTIONS_DEFAULT=SSL
.include <bsd.port.options.mk>
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
GNU_CONFIGURE= yes
diff --git a/news/tin/Makefile b/news/tin/Makefile
index 6e54ab5374c..47213bdab0e 100644
--- a/news/tin/Makefile
+++ b/news/tin/Makefile
@@ -119,7 +119,7 @@ post-patch:
${WRKSRC}/tools/tinurl_handler.pl
post-build:
-.ifndef WITHOUT_NLS
+.if ${PORT_OPTIONS:MNLS}
cd ${WRKSRC}/po; ${GMAKE}
.endif
diff --git a/print/texinfo/Makefile b/print/texinfo/Makefile
index f9703dffad2..4f0cb94ca14 100644
--- a/print/texinfo/Makefile
+++ b/print/texinfo/Makefile
@@ -40,14 +40,14 @@ MAN5= info.5 texinfo.5
TEXMF= share/texmf
PLIST_SUB= TEXMF=${TEXMF}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
post-patch:
@@ -59,4 +59,4 @@ post-install:
@${SETENV} PKG_PREFIX=${PREFIX} LOCALBASE=${LOCALBASE} ${SH} \
${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/gsasl/Makefile b/security/gsasl/Makefile
index ea915b443fd..b0ea0989b4e 100644
--- a/security/gsasl/Makefile
+++ b/security/gsasl/Makefile
@@ -27,12 +27,14 @@ USE_LDCONFIG= yes
INFO= gsasl
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
CPPFLAGS+= -nostdinc -I/usr/include -I${LOCALBASE}/include
diff --git a/security/gss/Makefile b/security/gss/Makefile
index 788b6c1e049..59b32ee0c3b 100644
--- a/security/gss/Makefile
+++ b/security/gss/Makefile
@@ -31,14 +31,14 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
.include "Makefile.man"
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.ifdef WITHOUT_NLS
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
post-configure:
@@ -53,4 +53,4 @@ post-install:
cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/shishi/Makefile b/security/shishi/Makefile
index 9af4ae665a9..b70a2c77f0a 100644
--- a/security/shishi/Makefile
+++ b/security/shishi/Makefile
@@ -36,16 +36,18 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
.include "Makefile.man"
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
+.include <bsd.port.pre.mk>
+
.if ${OSVERSION} < 800000
CONFIGURE_ARGS+= gl_cv_func_stat_dir_slash="guessing yes" \
gl_cv_func_stat_file_slash="guessing yes"
diff --git a/textproc/diffutils/Makefile b/textproc/diffutils/Makefile
index 76033a6eeba..160ab9f56b0 100644
--- a/textproc/diffutils/Makefile
+++ b/textproc/diffutils/Makefile
@@ -22,12 +22,14 @@ CONFIGURE_ARGS= --program-prefix=g
INFO= diffutils
MAN1= gcmp.1 gdiff.1 gdiff3.1 gsdiff.1
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
.include <bsd.port.mk>
diff --git a/textproc/flex/Makefile b/textproc/flex/Makefile
index 90cdc8157a1..5a62260f9ab 100644
--- a/textproc/flex/Makefile
+++ b/textproc/flex/Makefile
@@ -26,7 +26,9 @@ USE_GMAKE= yes
MAN1= flex.1
INFO= flex
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USE_ICONV= yes
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
diff --git a/textproc/ocaml-pxp/Makefile b/textproc/ocaml-pxp/Makefile
index 644a6460754..553ad7eb046 100644
--- a/textproc/ocaml-pxp/Makefile
+++ b/textproc/ocaml-pxp/Makefile
@@ -17,11 +17,17 @@ COMMENT= Validating XML parser for OCaml
BUILD_DEPENDS= ${LOCALBASE}/${OCAML_SITELIBDIR}/netstring/netstring.a:${PORTSDIR}/www/ocaml-net
RUN_DEPENDS= ${LOCALBASE}/${OCAML_SITELIBDIR}/netstring/netstring.a:${PORTSDIR}/www/ocaml-net
+OPTIONS_DEFINE= ULEX
+OPTIONS_DEFAULT=ULEX
+ULEX_DESC= Include UTF-8 lexical analyzer support
+
USE_OCAML= true
USE_OCAML_FINDLIB= true
USE_OCAML_LDCONFIG= true
-.if !defined(WITHOUT_ULEX)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MULEX}
BUILD_DEPENDS+= ${LOCALBASE}/${OCAML_SITELIBDIR}/ulex/ulexing.a:${PORTSDIR}/devel/ocaml-ulex
RUN_DEPENDS+= ${LOCALBASE}/${OCAML_SITELIBDIR}/ulex/ulexing.a:${PORTSDIR}/devel/ocaml-ulex
.endif
diff --git a/www/qdecoder/Makefile b/www/qdecoder/Makefile
index 675ce389f97..03186a0475d 100644
--- a/www/qdecoder/Makefile
+++ b/www/qdecoder/Makefile
@@ -28,7 +28,7 @@ PLIST_FILES= include/qdecoder.h \
.include <bsd.port.options.mk>
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+="--enable-debug"
.endif