aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorroger <roger@FreeBSD.org>2002-11-13 20:38:16 +0800
committerroger <roger@FreeBSD.org>2002-11-13 20:38:16 +0800
commit67ac3c54b36917e16f2941ab693d30ea194c8f11 (patch)
treebd6871e0ce2b8449d2654ca3dc6f44601e6f9f6d
parenta6ecf6f6e19ab077af92f3c25f637d12689010d2 (diff)
downloadfreebsd-ports-graphics-67ac3c54b36917e16f2941ab693d30ea194c8f11.tar.gz
freebsd-ports-graphics-67ac3c54b36917e16f2941ab693d30ea194c8f11.tar.zst
freebsd-ports-graphics-67ac3c54b36917e16f2941ab693d30ea194c8f11.zip
Mark broken on 5.x machines
PR: ports/44892 Submitted by: Volker Stolz <vs@foldr.org>
-rw-r--r--comms/ixj/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/comms/ixj/Makefile b/comms/ixj/Makefile
index 3e0cbf7500c..8b635423ee1 100644
--- a/comms/ixj/Makefile
+++ b/comms/ixj/Makefile
@@ -15,6 +15,12 @@ MAINTAINER= roger@freebsd.org
ONLY_FOR_ARCHS= i386
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500000
+BROKEN = "Driver has not been updated for 5.x kernels. Still uses machine/ipl.h"
+.endif
+
WRKSRC= ${WRKDIR}/ixj_freebsd
USE_REINPLACE= yes
MAKEFILE= Makefile.BSD
@@ -23,6 +29,7 @@ post-patch:
${CP} ${FILESDIR}/ixj.sh ${WRKSRC}
${REINPLACE_CMD} -e "s@%%PREFIX%%@${PREFIX}@g" ${WRKSRC}/ixj.sh
+
pre-build:
.if !exists(${SRC_BASE}/sys/Makefile)
@${ECHO} "*************************************************"; \
@@ -45,4 +52,4 @@ header-install: patch
@${INSTALL_DATA} ${WRKSRC}/ixjuser.h ${PREFIX}/include/sys
@${INSTALL_DATA} ${WRKSRC}/telephony.h ${PREFIX}/include/sys
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>