aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-03-14 08:16:54 +0800
committermarcus <marcus@FreeBSD.org>2004-03-14 08:16:54 +0800
commit68173095825888d3b4fb575704e821da78ff9ac4 (patch)
treea02899e7dd3f3a3d11a26dae4a9780fb26b97e69
parent596ce22f6a1aebec3c743e3aa78adf6c52ac1cf3 (diff)
downloadfreebsd-ports-graphics-68173095825888d3b4fb575704e821da78ff9ac4.tar.gz
freebsd-ports-graphics-68173095825888d3b4fb575704e821da78ff9ac4.tar.zst
freebsd-ports-graphics-68173095825888d3b4fb575704e821da78ff9ac4.zip
Fix the threaad support to stay inline with the way it's done for Python.
Prompted by: kris
-rw-r--r--x11-toolkits/py-gtk2/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/x11-toolkits/py-gtk2/Makefile b/x11-toolkits/py-gtk2/Makefile
index 289f7decede..b266bb53c6e 100644
--- a/x11-toolkits/py-gtk2/Makefile
+++ b/x11-toolkits/py-gtk2/Makefile
@@ -34,13 +34,15 @@ CONFLICTS= py*-gtk-0*
# Use the same way as the Python port to determine if we want
# threading support.
#
-LIBC_R!= /sbin/ldconfig -r | grep "c_r\|pthread" || true
-.if (${LIBC_R} != "") && !defined(WITHOUT_THREADS)
+.if !defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --enable-thread
CFLAGS+= ${PTHREAD_CFLAGS}
CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
.else
CONFIGURE_ARGS+= --disable-thread
+.if defined(LDFLAGS)
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
+.endif
.endif
.if !defined(NOPORTDOCS)