aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2015-03-18 06:05:36 +0800
committerantoine <antoine@FreeBSD.org>2015-03-18 06:05:36 +0800
commit6866d1a8ce00692e13d7dd55f8d5693076a98b35 (patch)
treede359b730dfa35be6533f68f6c98fd9e130dc2c6
parent13a41eff433e41d8c3e23a2e7e609c9f5696cfdf (diff)
downloadfreebsd-ports-graphics-6866d1a8ce00692e13d7dd55f8d5693076a98b35.tar.gz
freebsd-ports-graphics-6866d1a8ce00692e13d7dd55f8d5693076a98b35.tar.zst
freebsd-ports-graphics-6866d1a8ce00692e13d7dd55f8d5693076a98b35.zip
Use gmake instead of using rules that may or may not work depending of the
version of sys.mk This fixes build on head after r279980
-rw-r--r--archivers/dzip/Makefile3
-rw-r--r--devel/luafilesystem/Makefile1
-rw-r--r--devel/luafilesystem/files/patch-Makefile2
-rw-r--r--net/redir/Makefile1
-rw-r--r--net/redir/files/patch-Makefile9
-rw-r--r--sysutils/xacpim/Makefile1
-rw-r--r--sysutils/xacpim/files/patch-Makefile2
-rw-r--r--x11/wmcliphist/Makefile2
-rw-r--r--x11/wmcliphist/files/patch-Makefile9
9 files changed, 7 insertions, 23 deletions
diff --git a/archivers/dzip/Makefile b/archivers/dzip/Makefile
index 08fdda82e8c..9bd2636157b 100644
--- a/archivers/dzip/Makefile
+++ b/archivers/dzip/Makefile
@@ -12,7 +12,7 @@ COMMENT= File compression utility specializing in Quake demo compression
LICENSE= ZLIB
-USES= dos2unix zip
+USES= dos2unix gmake zip
NO_WRKSUBDIR= yes
MAKEFILE= ${WRKSRC}/Makefile.linux
@@ -27,7 +27,6 @@ post-extract: .SILENT
${WRKSRC}/dzip.h ${WRKSRC}/conmain.c
${REINPLACE_CMD} -e '4s,^,#include <machine/endian.h>,' \
${WRKSRC}/dzip.h
- ${REINPLACE_CMD} -e 's/) $$(OBJECTS/&:T/' ${MAKEFILE}
${REINPLACE_CMD} -e '21d;23d' ${WRKSRC}/dzipcon.h
do-install:
diff --git a/devel/luafilesystem/Makefile b/devel/luafilesystem/Makefile
index debfa71ed23..8889fcec1d8 100644
--- a/devel/luafilesystem/Makefile
+++ b/devel/luafilesystem/Makefile
@@ -12,6 +12,7 @@ COMMENT= Library to access directory structure and file attributes
LICENSE= MIT
USES?= lua
+USES+= gmake
USE_GITHUB= yes
GH_ACCOUNT= keplerproject
diff --git a/devel/luafilesystem/files/patch-Makefile b/devel/luafilesystem/files/patch-Makefile
index 68fd9e435ee..3e1ff5429a0 100644
--- a/devel/luafilesystem/files/patch-Makefile
+++ b/devel/luafilesystem/files/patch-Makefile
@@ -5,7 +5,7 @@
src/lfs.so: $(OBJS)
- MACOSX_DEPLOYMENT_TARGET="10.3"; export MACOSX_DEPLOYMENT_TARGET; $(CC) $(CFLAGS) $(LIB_OPTION) -o src/lfs.so $(OBJS)
-+ $(CC) $(CFLAGS) $(LIB_OPTION) -o src/lfs.so $T.o
++ $(CC) $(CFLAGS) $(LIB_OPTION) -o src/lfs.so $(OBJS)
test: lib
LUA_CPATH=./src/?.so lua tests/test.lua
diff --git a/net/redir/Makefile b/net/redir/Makefile
index a094ec89bfa..9c878659023 100644
--- a/net/redir/Makefile
+++ b/net/redir/Makefile
@@ -10,6 +10,7 @@ MASTER_SITES= http://sammy.net/~sammy/hacks/
MAINTAINER= ports@FreeBSD.org
COMMENT= TCP connection redirection utility
+USES= gmake
USE_RC_SUBR= redir
PLIST_FILES= bin/redir man/man1/redir.1.gz
diff --git a/net/redir/files/patch-Makefile b/net/redir/files/patch-Makefile
index da1e2f68548..ce69c2c16b7 100644
--- a/net/redir/files/patch-Makefile
+++ b/net/redir/files/patch-Makefile
@@ -23,12 +23,3 @@
LDFLAGS = -s
# solaris, and others, may also need these libraries to link
-@@ -49,7 +48,7 @@
- rm -f $(OBJS) redir core
-
- redir: ${OBJS}
-- ${CC} ${LDFLAGS} -o redir ${OBJS} ${LIBS}
-+ ${CC} ${LDFLAGS} -o redir redir.o getopt.o getopt1.o ${LIBS}
-
-
-
diff --git a/sysutils/xacpim/Makefile b/sysutils/xacpim/Makefile
index 5103c6843a3..f246daa0a79 100644
--- a/sysutils/xacpim/Makefile
+++ b/sysutils/xacpim/Makefile
@@ -10,6 +10,7 @@ MASTER_SITES= http://shapeshifter.se/pub/xacpim/
MAINTAINER= henriknj@0xmilk.org
COMMENT= Utility to display battery status and temperature on the root-display
+USES= gmake
USE_XORG= x11
PLIST_FILES= bin/xacpim
diff --git a/sysutils/xacpim/files/patch-Makefile b/sysutils/xacpim/files/patch-Makefile
index cc019995d8d..0b8b98211dc 100644
--- a/sysutils/xacpim/files/patch-Makefile
+++ b/sysutils/xacpim/files/patch-Makefile
@@ -9,7 +9,7 @@
all:: ${OBJS}
- ${CC} -o xacpim *.o -lX11 -L/usr/X11R6/lib -I/usr/X11R6/include
-+ ${CC} -o xacpim *.o -lX11 -L${LOCALBASE}/lib -I${LOCALBASE}/include
++ ${CC} -o xacpim ${OBJS} -lX11 -L${LOCALBASE}/lib -I${LOCALBASE}/include
install:: xacpim
strip xacpim
diff --git a/x11/wmcliphist/Makefile b/x11/wmcliphist/Makefile
index 4fe05c18dab..02951159441 100644
--- a/x11/wmcliphist/Makefile
+++ b/x11/wmcliphist/Makefile
@@ -14,7 +14,7 @@ COMMENT= Clipboard history management dockapp for Window Maker
SUB_FILES= pkg-message
WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= pkgconfig
+USES= gmake pkgconfig
USE_GNOME= gtk20
USE_XORG= x11
diff --git a/x11/wmcliphist/files/patch-Makefile b/x11/wmcliphist/files/patch-Makefile
index 319e5225db6..a90b03f4e57 100644
--- a/x11/wmcliphist/files/patch-Makefile
+++ b/x11/wmcliphist/files/patch-Makefile
@@ -21,12 +21,3 @@
OBJECTS = wmcliphist.o clipboard.o gui.o rcconfig.o history.o hotkeys.o utils.o $(DEBUG)
TARGET = wmcliphist
-@@ -23,7 +23,7 @@ lclint:
- lclint $(INCLUDES) +posixlib *.c >lclint.log
-
- wmcliphist: $(OBJECTS) foodock/foodock.o
-- $(CC) $(LDFLAGS) $(OBJECTS) foodock/foodock.o $(LIBS) -o $@
-+ $(CC) $(LDFLAGS) $(OBJECTS) foodock.o $(LIBS) -o $@
-
- wmcliphist.o: wmcliphist.c wmcliphist.h \
- icon/ico_60x60_black.xpm icon/ico_60x60_gray.xpm \