aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-04-03 13:32:58 +0800
committerijliao <ijliao@FreeBSD.org>2003-04-03 13:32:58 +0800
commit6a15405f4bf5ff6514e16aa0053fb9ae3fb679ad (patch)
tree4e526372e977a2ea87d754ec3b61b7701bb7da45
parent1fabea7ec98d6ab8f98bfbd95c6f1bfdfc738f38 (diff)
downloadfreebsd-ports-graphics-6a15405f4bf5ff6514e16aa0053fb9ae3fb679ad.tar.gz
freebsd-ports-graphics-6a15405f4bf5ff6514e16aa0053fb9ae3fb679ad.tar.zst
freebsd-ports-graphics-6a15405f4bf5ff6514e16aa0053fb9ae3fb679ad.zip
add jtans 1.0
A (not so) ancient puzzle
-rw-r--r--games/Makefile1
-rw-r--r--games/jtans/Makefile35
-rw-r--r--games/jtans/distinfo1
-rw-r--r--games/jtans/files/jtans3
-rw-r--r--games/jtans/pkg-descr5
-rw-r--r--games/jtans/pkg-plist2
6 files changed, 47 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 9384f8d0a31..a3de5d196ea 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -180,6 +180,7 @@
SUBDIR += ishido
SUBDIR += jetpack
SUBDIR += jfk
+ SUBDIR += jtans
SUBDIR += jumpnbump
SUBDIR += jzip
SUBDIR += kdegames3
diff --git a/games/jtans/Makefile b/games/jtans/Makefile
new file mode 100644
index 00000000000..d716fc921f9
--- /dev/null
+++ b/games/jtans/Makefile
@@ -0,0 +1,35 @@
+# ex:ts=8
+# Ports collection makefile for: jtans
+# Date created: Apr 3, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= jtans
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}_appli-${PORTVERSION}
+EXTRACT_SUFX= .jar
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A (not so) ancient puzzle
+
+NO_WRKSUBDIR= yes
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS= # empty
+EXTRACT_AFTER_ARGS= .
+USE_JAVA= 1.3+
+NO_BUILD= yes
+
+post-patch:
+ @${SED} 's,%%DATADIR%%,${DATADIR},' ${FILESDIR}/jtans > ${WRKSRC}/jtans
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/jtans ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/jtans_appli-1.0.jar ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/games/jtans/distinfo b/games/jtans/distinfo
new file mode 100644
index 00000000000..56c25156393
--- /dev/null
+++ b/games/jtans/distinfo
@@ -0,0 +1 @@
+MD5 (jtans_appli-1.0.jar) = 35cd1d82f917d432c787281f39e9b243
diff --git a/games/jtans/files/jtans b/games/jtans/files/jtans
new file mode 100644
index 00000000000..37023904b41
--- /dev/null
+++ b/games/jtans/files/jtans
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+java -jar %%DATADIR%%/jtans_appli-1.0.jar
diff --git a/games/jtans/pkg-descr b/games/jtans/pkg-descr
new file mode 100644
index 00000000000..2e7ebb08276
--- /dev/null
+++ b/games/jtans/pkg-descr
@@ -0,0 +1,5 @@
+The Tangram is a (not so) ancient puzzle. The object is to put seven
+geometric shapes together so as to form a given outline. All the pieces
+must be used and are laid next to one another.
+
+WWW: http://jtans.sourceforge.net/
diff --git a/games/jtans/pkg-plist b/games/jtans/pkg-plist
new file mode 100644
index 00000000000..2ed7b801776
--- /dev/null
+++ b/games/jtans/pkg-plist
@@ -0,0 +1,2 @@
+bin/jtans
+share/jtans/jtans_appli-1.0.jar