aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2015-06-25 14:02:14 +0800
committerkoobs <koobs@FreeBSD.org>2015-06-25 14:02:14 +0800
commit6af11782c17d4c79afb7bd36a3362db3c9d03904 (patch)
treece6ef6f5d3938701cd68430d48be431ef5366f5e
parentb0c9fb2d342e41449d991b103e05230ca1b7722e (diff)
downloadfreebsd-ports-graphics-6af11782c17d4c79afb7bd36a3362db3c9d03904.tar.gz
freebsd-ports-graphics-6af11782c17d4c79afb7bd36a3362db3c9d03904.tar.zst
freebsd-ports-graphics-6af11782c17d4c79afb7bd36a3362db3c9d03904.zip
devel/py-futures: Update to 3.0.3
- Update to 3.0.3 [1] - Add LICENSE_FILE - Sort USE_PYTHON - Add regression-test target for QA - Update pkg-descr WWW: URL Changes: https://github.com/agronholm/pythonfutures/blob/3.0.3/CHANGES Based on: PR: 201068 [1] Submitted by: Gasol Wu <gasol dot wu gmail com> [1]
-rw-r--r--devel/py-futures/Makefile8
-rw-r--r--devel/py-futures/distinfo4
-rw-r--r--devel/py-futures/pkg-descr2
3 files changed, 9 insertions, 5 deletions
diff --git a/devel/py-futures/Makefile b/devel/py-futures/Makefile
index 88a15b896e9..d4d4ebd0055 100644
--- a/devel/py-futures/Makefile
+++ b/devel/py-futures/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= futures
-PORTVERSION= 2.1.6
+PORTVERSION= 3.0.3
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,8 +11,12 @@ MAINTAINER= koobs@FreeBSD.org
COMMENT= Backport of the concurrent.futures package from Python 3.2
LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
USES= python:2
-USE_PYTHON= distutils autoplist
+USE_PYTHON= autoplist distutils
+
+regression-test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} test_futures.py
.include <bsd.port.mk>
diff --git a/devel/py-futures/distinfo b/devel/py-futures/distinfo
index 5d8553d2cb3..6250f1033d1 100644
--- a/devel/py-futures/distinfo
+++ b/devel/py-futures/distinfo
@@ -1,2 +1,2 @@
-SHA256 (futures-2.1.6.tar.gz) = 33f39102b631fa0a030b24c4341ba1f48558e435946d6735d47fe1f739d757c4
-SIZE (futures-2.1.6.tar.gz) = 26445
+SHA256 (futures-3.0.3.tar.gz) = 2fe2342bb4fe8b8e217f0d21b5921cbe5408bf966d9f92025e707e881b198bed
+SIZE (futures-3.0.3.tar.gz) = 24959
diff --git a/devel/py-futures/pkg-descr b/devel/py-futures/pkg-descr
index d6d89ae688e..04a54b4b044 100644
--- a/devel/py-futures/pkg-descr
+++ b/devel/py-futures/pkg-descr
@@ -5,4 +5,4 @@ asynchronously executing callables.
This is described in PEP-3148 and is included in Python 3.2+
-WWW: http://code.google.com/p/pythonfutures/
+WWW: https://github.com/agronholm/pythonfutures