aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2008-07-10 05:27:14 +0800
committergahr <gahr@FreeBSD.org>2008-07-10 05:27:14 +0800
commit6cb158c410d02be4003bf1a1ca9bb160cb8e1291 (patch)
tree1c4b9336bbed4fe62764b3f3dacb0f96c67f5865
parent5df8015be0f093f722e67cec74d81c65563ccf21 (diff)
downloadfreebsd-ports-graphics-6cb158c410d02be4003bf1a1ca9bb160cb8e1291.tar.gz
freebsd-ports-graphics-6cb158c410d02be4003bf1a1ca9bb160cb8e1291.tar.zst
freebsd-ports-graphics-6cb158c410d02be4003bf1a1ca9bb160cb8e1291.zip
- New port: ansifilter
Ansifilter is a customizable ANSI Code converter. ansifilter can output to plain text, HTML, and RTF. PR: 125444 Submitted by: Yi-Jheng Lin <yzlin@cs.nctu.edu.tw> (new maintainer)
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/ansifilter/Makefile47
-rw-r--r--textproc/ansifilter/distinfo3
-rw-r--r--textproc/ansifilter/pkg-descr4
4 files changed, 55 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 25a14b23111..5750f12ab05 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -13,6 +13,7 @@
SUBDIR += aiksaurus-gtk
SUBDIR += align
SUBDIR += am-aspell
+ SUBDIR += ansifilter
SUBDIR += ant-xinclude-task
SUBDIR += antiword
SUBDIR += archmage
diff --git a/textproc/ansifilter/Makefile b/textproc/ansifilter/Makefile
new file mode 100644
index 00000000000..8524d3aa8d5
--- /dev/null
+++ b/textproc/ansifilter/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: ansifilter
+# Date created: 09 July 2008
+# Whom: Yi-Jheng Lin <yzlin@cs.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ansifilter
+PORTVERSION= 1.1
+CATEGORIES= textproc
+MASTER_SITES= http://www.andre-simon.de/zip/
+
+MAINTAINER= yzlin@cs.nctu.edu.tw
+COMMENT= Customizable ANSI Code Converter
+
+USE_BZIP2= yes
+MAKEFILE= makefile
+MAKE_ARGS= CC="${CXX}" \
+ CFLAGS="${CXXFLAGS} ${CPPFLAGS} -c" \
+ LDFLAGS="${LDFLAGS}"
+
+PLIST_FILES= bin/ansifilter
+
+MAN1= ${PORTNAME}.1
+MANCOMPRESSED= yes
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= ChangeLog INSTALL README
+.endif
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|^PREFIX =|PREFIX ?=|' ${WRKSRC}/${MAKEFILE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/${MAN1}.gz ${MANPREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/ansifilter/distinfo b/textproc/ansifilter/distinfo
new file mode 100644
index 00000000000..2dcd52a52be
--- /dev/null
+++ b/textproc/ansifilter/distinfo
@@ -0,0 +1,3 @@
+MD5 (ansifilter-1.1.tar.bz2) = 293581816a08f8ac7a49934958cfac14
+SHA256 (ansifilter-1.1.tar.bz2) = ffa02d1e5b98bec6156d9f4cc9ce3b1cf9653434caadb1537aba4b3f001d8f73
+SIZE (ansifilter-1.1.tar.bz2) = 46893
diff --git a/textproc/ansifilter/pkg-descr b/textproc/ansifilter/pkg-descr
new file mode 100644
index 00000000000..87a8146b4db
--- /dev/null
+++ b/textproc/ansifilter/pkg-descr
@@ -0,0 +1,4 @@
+ansifilter is a customizable ANSI Code converter. ansifilter can
+output to plain text, HTML, and RTF.
+
+WWW: http://www.andre-simon.de/