aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2014-11-12 19:34:38 +0800
committerrakuco <rakuco@FreeBSD.org>2014-11-12 19:34:38 +0800
commit6f7215cd3879bcdc95fb1f18786d1bc355d87c15 (patch)
tree035fef54bc7244adbc1c5e82f24da39e02c37535
parentaf02faa83f3f701bb94ee7381d97fa287d17739b (diff)
downloadfreebsd-ports-graphics-6f7215cd3879bcdc95fb1f18786d1bc355d87c15.tar.gz
freebsd-ports-graphics-6f7215cd3879bcdc95fb1f18786d1bc355d87c15.tar.zst
freebsd-ports-graphics-6f7215cd3879bcdc95fb1f18786d1bc355d87c15.zip
Use a smarter strategy to avoid building src/qml and src/qmldevtools.
Simply patching src/src.pro to remove those directories from the build does not work in all cases. If an older version of qt5-quick is installed, their .pri files in mkspecs/modules will be picked up, and in the end when linking programs such as tools/qmltestrunner something like this happens: c++ [...] -Wl,-rpath-link,/usr/local/lib -o ../../bin/qmltestrunner -L${WRKSRC}/lib -lQt5QuickTest [...] The -rpath-link linker option will make ${LOCALBASE}/lib take precedence in directory lookups, so when the newly-built libQt5QuickTest.so asks for libQt5Quick.so in its DT_NEEDED section the older version installed in ${LOCALBASE}/lib will be used instead of the one that has just been built. If the new version has symbols the older one does not (Qt releases are backwards, not forwards, compatible), the build will fail. So instead of patching src/src.pro, we let the configuration process proceed without any patching so that the local .pri files are created in ${WRKSRC}/mkspecs and the Makefiles are created in a way that -rpath-link is not passed to the linker anymore. We only need to symlink the existing libraries built by lang/qt5-qml (this is similar to what we do with qtbase ports to avoid rebuilding tools such as qmake and moc), and then change the Makefiles in src/qml and src/qmldevtools so that nothing gets built. This might even be a solution for other ports that got .pro patches in r372179, since depending on which parts depend on which the same thing could happen in the future. I'm not bumping PORTREVISION because the resulting binaries will not change and this only fixes the build where it was broken before. PR: 194870
-rw-r--r--x11-toolkits/qt5-quick/Makefile19
-rw-r--r--x11-toolkits/qt5-quick/files/patch-src__src.pro22
2 files changed, 19 insertions, 22 deletions
diff --git a/x11-toolkits/qt5-quick/Makefile b/x11-toolkits/qt5-quick/Makefile
index 938abe48274..c0d4b921fde 100644
--- a/x11-toolkits/qt5-quick/Makefile
+++ b/x11-toolkits/qt5-quick/Makefile
@@ -17,4 +17,23 @@ USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
QT_DEFINES= ACCESSIBILITY
QT_CONFIG= accessibility accessibility-atspi-bridge
+# libQt5Qml.so and libQt5QmlDevTools.a come from lang/qt5-qml, so we do not
+# want to build them again here. On the other hand, if we just remove qml/ and
+# qmldevtools/ from src/src.pro the versions installed in ${LOCALBASE} will be
+# picked up and their .pri files will make -Wl,-rpath-link,${LOCALBASE}/lib be
+# used when building targets such as tools/qmltestrunner. This causes problems
+# when building the port with an older version installed (bug 194870).
+# Instead, we let the .pri modules be created in ${WRKSRC}/mkspecs but symlink
+# the existing libraries and trick the existing Makefiles into doing nothing
+# (it is more future-proof than whitelisting the other directories).
+post-configure:
+ ${LN} -s ${QT_LIBDIR}/libQt5Qml.so \
+ ${CONFIGURE_WRKSRC}/lib/libQt5Qml.so
+ ${LN} -s ${QT_LIBDIR}/libQt5QmlDevTools.a \
+ ${CONFIGURE_WRKSRC}/lib/libQt5QmlDevTools.a
+ ${PRINTF} ".DEFAULT:\n\t@${DO_NADA}" \
+ > ${CONFIGURE_WRKSRC}/src/qml/Makefile
+ ${PRINTF} ".DEFAULT:\n\t@${DO_NADA}" \
+ > ${CONFIGURE_WRKSRC}/src/qmldevtools/Makefile
+
.include <bsd.port.mk>
diff --git a/x11-toolkits/qt5-quick/files/patch-src__src.pro b/x11-toolkits/qt5-quick/files/patch-src__src.pro
deleted file mode 100644
index 6bcdf731fb5..00000000000
--- a/x11-toolkits/qt5-quick/files/patch-src__src.pro
+++ /dev/null
@@ -1,22 +0,0 @@
-Only enter the directories we want to build, otherwise we might fail due to
-missing dependencies.
-
---- src/src.pro
-+++ src/src.pro
-@@ -1,7 +1,5 @@
- TEMPLATE = subdirs
- CONFIG += ordered
--SUBDIRS += \
-- qml
-
- qtHaveModule(gui):contains(QT_CONFIG, opengl(es1|es2)?) {
- SUBDIRS += \
-@@ -14,7 +12,4 @@ qtHaveModule(gui):contains(QT_CONFIG, opengl(es1|es2)?) {
-
- SUBDIRS += \
- plugins \
-- imports \
-- qmldevtools
--
--qmldevtools.CONFIG = host_build
-+ imports