aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2002-07-17 00:27:34 +0800
committermi <mi@FreeBSD.org>2002-07-17 00:27:34 +0800
commit7163f177c095a86196ed570b172069f8e6427ff8 (patch)
tree6b2389be46db4294c12cc0ec4375ef7337bf68d1
parent30d071bbb7f95a420d9138e0d57b5917b06f45f8 (diff)
downloadfreebsd-ports-graphics-7163f177c095a86196ed570b172069f8e6427ff8.tar.gz
freebsd-ports-graphics-7163f177c095a86196ed570b172069f8e6427ff8.tar.zst
freebsd-ports-graphics-7163f177c095a86196ed570b172069f8e6427ff8.zip
Add some defines to CFLAGS to avoid clashing with the newer system
headers. While here, change PERL to RE_INPLACE and lock things down with -Werror (in CFLAGS only, the C++ files generate some warnings, fixing which is in the domain of the authors). Submitted by: Naoya Nishimura
-rw-r--r--graphics/libfpx/Makefile7
-rw-r--r--graphics/libfpx/files/Makefile.bsd1
2 files changed, 6 insertions, 2 deletions
diff --git a/graphics/libfpx/Makefile b/graphics/libfpx/Makefile
index 29a44a23f55..2dfb5993b1d 100644
--- a/graphics/libfpx/Makefile
+++ b/graphics/libfpx/Makefile
@@ -31,12 +31,15 @@ MAINTAINER= mi@aldan.algebra.com
LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
MAKE_ARGS+= -j2
+#CFLAGS+= -DHAVE_WCHAR_H=1 -DHAVE_DLFCN_H=1
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i ""
post-patch:
# Replacing references to <malloc.h> with <stdlib.h>
# Ignore the /dev/stderr warning below. (What a hack!)
- ${PERL} -pi -e 's/<malloc.h>/<stdlib.h>/' \
- `find ${WRKSRC} -type f | xargs ${GREP} -l '<malloc.h>'` /dev/stderr
+ ${REINPLACE_CMD} -e 's,<malloc\.h>,<stdlib\.h>,' \
+ ${WRKSRC}/oless/h/ref.hxx ${WRKSRC}/oless/h/vect.hxx
INSTALLS_SHLIB= yes
MAKEFILE= ${FILESDIR}/Makefile.bsd
diff --git a/graphics/libfpx/files/Makefile.bsd b/graphics/libfpx/files/Makefile.bsd
index f425028c092..65446df0aa4 100644
--- a/graphics/libfpx/files/Makefile.bsd
+++ b/graphics/libfpx/files/Makefile.bsd
@@ -7,6 +7,7 @@ LIBDIR = ${LOCALBASE}/lib
INCDIR = ${LOCALBASE}/include
NOPROFILE= Don't want it
+CFLAGS+= -DHAVE_WCHAR_H=1 -DHAVE_DLFCN_H=1 -Werror
CPPS != find ${.CURDIR} -name \*.cpp -print
# Some of the .cxx files are #include-ed into others, so can't use `find' here: