aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2005-04-29 15:06:01 +0800
committerijliao <ijliao@FreeBSD.org>2005-04-29 15:06:01 +0800
commit71a2ae466c1543aaf74525d65f5cf0f972f2291e (patch)
treeb1587d860c8f9a874769848621b0b9915eb50f80
parent9194866f35d57909f02de30da7a1ffd997809f44 (diff)
downloadfreebsd-ports-graphics-71a2ae466c1543aaf74525d65f5cf0f972f2291e.tar.gz
freebsd-ports-graphics-71a2ae466c1543aaf74525d65f5cf0f972f2291e.tar.zst
freebsd-ports-graphics-71a2ae466c1543aaf74525d65f5cf0f972f2291e.zip
add py-mechanize 0.0.9.a
Stateful programmatic web browsing in Python
-rw-r--r--www/Makefile1
-rw-r--r--www/py-mechanize/Makefile33
-rw-r--r--www/py-mechanize/distinfo2
-rw-r--r--www/py-mechanize/pkg-descr4
4 files changed, 40 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index fb9e8100f16..68ab3535242 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -643,6 +643,7 @@
SUBDIR += py-forgethtml
SUBDIR += py-htmltestcase
SUBDIR += py-imdbpy
+ SUBDIR += py-mechanize
SUBDIR += py-mt
SUBDIR += py-nevow
SUBDIR += py-pullparser
diff --git a/www/py-mechanize/Makefile b/www/py-mechanize/Makefile
new file mode 100644
index 00000000000..2e64d14f1bb
--- /dev/null
+++ b/www/py-mechanize/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: py-mechanize
+# Date created: Apr 29, 2005
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= mechanize
+PORTVERSION= 0.0.9.a
+CATEGORIES= www python
+MASTER_SITES= http://wwwsearch.sourceforge.net/mechanize/src/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Stateful programmatic web browsing in Python
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/ClientCookie/__init__.py:${PORTSDIR}/devel/py-clientcookie \
+ ${PYTHON_SITELIBDIR}/ClientForm.py:${PORTSDIR}/www/py-clientform \
+ ${PYTHON_SITELIBDIR}/pullparser.py:${PORTSDIR}/www/py-pullparser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+post-install:
+ @${FIND} ${PYTHON_SITELIBDIR}/mechanize ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${PYTHON_SITELIBDIR}/mechanize -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/www/py-mechanize/distinfo b/www/py-mechanize/distinfo
new file mode 100644
index 00000000000..c12ae210dec
--- /dev/null
+++ b/www/py-mechanize/distinfo
@@ -0,0 +1,2 @@
+MD5 (mechanize-0.0.9a.tar.gz) = 7c805a9d3596b9e3267b1f88a9bbe1da
+SIZE (mechanize-0.0.9a.tar.gz) = 25378
diff --git a/www/py-mechanize/pkg-descr b/www/py-mechanize/pkg-descr
new file mode 100644
index 00000000000..90488479267
--- /dev/null
+++ b/www/py-mechanize/pkg-descr
@@ -0,0 +1,4 @@
+Stateful programmatic web browsing in Python, after Andy Lester's Perl module
+WWW::Mechanize.
+
+WWW: http://wwwsearch.sourceforge.net/mechanize/