aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2011-08-10 17:00:12 +0800
committerlinimon <linimon@FreeBSD.org>2011-08-10 17:00:12 +0800
commit73cea8bf02924869e6f603b0285449f54f3715c6 (patch)
tree7932e1c4cb5cb409e19db4046d51e19de599cd7f
parent98e8709d87c90e95b14d3fea2733093bb4563296 (diff)
downloadfreebsd-ports-graphics-73cea8bf02924869e6f603b0285449f54f3715c6.tar.gz
freebsd-ports-graphics-73cea8bf02924869e6f603b0285449f54f3715c6.tar.zst
freebsd-ports-graphics-73cea8bf02924869e6f603b0285449f54f3715c6.zip
Mark as broken on tier-2: uses x86-specific compiler flags.
-rw-r--r--games/megaglest/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/megaglest/Makefile b/games/megaglest/Makefile
index 0c93247d35a..bf455c30cd9 100644
--- a/games/megaglest/Makefile
+++ b/games/megaglest/Makefile
@@ -64,4 +64,10 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64: unrecognized compiler flags
+.endif
+
+.include <bsd.port.post.mk>