aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2004-05-15 09:01:59 +0800
committerlinimon <linimon@FreeBSD.org>2004-05-15 09:01:59 +0800
commit7446e67fb84274a61c37b4446690cedb26d30acf (patch)
tree2ec52020d92415486bce6ba01a94ea29fa44fe16
parentd959c5c064930c414b1cae2c57a0fe985d4316e9 (diff)
downloadfreebsd-ports-graphics-7446e67fb84274a61c37b4446690cedb26d30acf.tar.gz
freebsd-ports-graphics-7446e67fb84274a61c37b4446690cedb26d30acf.tar.zst
freebsd-ports-graphics-7446e67fb84274a61c37b4446690cedb26d30acf.zip
As previously announced, remove lang/ruby-python. Its dependendencies are
broken, and it relies on an antique version of Python. Per the manintainer, "Ruby now has hundreds of native libraries, and no one would need or want to use ruby-python to borrow libraries from python."
-rw-r--r--lang/ruby-python/Makefile47
-rw-r--r--lang/ruby-python/distinfo2
-rw-r--r--lang/ruby-python/files/patch-aa80
-rw-r--r--lang/ruby-python/pkg-descr15
-rw-r--r--lang/ruby-python/pkg-plist26
5 files changed, 0 insertions, 170 deletions
diff --git a/lang/ruby-python/Makefile b/lang/ruby-python/Makefile
deleted file mode 100644
index 1e28f999934..00000000000
--- a/lang/ruby-python/Makefile
+++ /dev/null
@@ -1,47 +0,0 @@
-# New ports collection makefile for: Ruby/Python
-# Date created: 7 Aug 2000
-# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= python
-PORTVERSION= 0.3.3
-PORTREVISION= 2
-CATEGORIES= lang ruby python
-MASTER_SITES= http://www.goto.info.waseda.ac.jp/~fukusima/ruby/
-PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
-DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
-DIST_SUBDIR= ruby
-
-MAINTAINER= knu@FreeBSD.org
-COMMENT= Ruby extension library for embedding Python in Ruby
-
-BUILD_DEPENDS= ${NONEXISTENT}:${PYTHON_PORTSDIR}:-DWITHOUT_THREADS
-
-BROKEN= "Broken dependency"
-DEPRECATED= "obsolete now that hundreds of native libraries have been added to Ruby"
-EXPIRATION_DATE= "May 14, 2004"
-
-USE_PYTHON= yes
-PYTHON_VERSION?= python1.5
-
-USE_RUBY= yes
-USE_RUBY_EXTCONF= yes
-
-WRKSRC= ${WRKDIR}/${PORTNAME}
-CONFIGURE_ARGS= --with-python-lib=`cd ${PYTHON_PORTSDIR}; ${MAKE} -V WRKSRC`
-INSTALL_TARGET= site-install
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}
- ${CP} -R ${WRKSRC}/examples/ ${RUBY_MODEXAMPLESDIR}/
- ${MKDIR} ${RUBY_MODDOCDIR}/ja
- ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${WRKSRC}/README ${WRKSRC}/doc/* \
- ${RUBY_MODDOCDIR}/
- ${INSTALL_DATA} ${WRKSRC}/README.ja ${WRKSRC}/doc-ja/* \
- ${RUBY_MODDOCDIR}/ja/
-.endif
-
-.include <bsd.port.mk>
diff --git a/lang/ruby-python/distinfo b/lang/ruby-python/distinfo
deleted file mode 100644
index dc5c9985011..00000000000
--- a/lang/ruby-python/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (ruby/ruby-python-0.3.3.tar.gz) = f2a736494718e00147ef69dfe0c74807
-SIZE (ruby/ruby-python-0.3.3.tar.gz) = 36148
diff --git a/lang/ruby-python/files/patch-aa b/lang/ruby-python/files/patch-aa
deleted file mode 100644
index ccc2e4a2534..00000000000
--- a/lang/ruby-python/files/patch-aa
+++ /dev/null
@@ -1,80 +0,0 @@
---- extconf.rb.orig Mon Sep 11 01:14:42 2000
-+++ extconf.rb Thu Mar 29 17:01:54 2001
-@@ -1,35 +1,29 @@
- require 'mkmf'
-
--py_dir = with_config("python-dir")
--if py_dir
-- dirs = [py_dir]
--else
-- dirs = ['/usr/local', '/usr']
-- if File.executable? `which python`.chomp
-- d = `python -c 'import sys; print sys.exec_prefix' < /dev/null`
-- d = d.split(/\n/).shift
-- dirs.unshift d if d and File.directory? d
-- end
--end
-+python = with_config("python", "python1.5")
-+python = `which #{python}`.chomp
-
--for py_dir in dirs
-- py_includedir = py_dir + "/include/python1.5"
-- py_libdir = py_dir + "/lib/python1.5"
-- py_configdir = py_libdir + "/config"
-- py_makefile = py_configdir + "/Makefile"
-+exit(1) unless File.executable? python
-
-- print "checking for #{py_makefile}... "
-- if File.exists? py_makefile
-- print "yes\n"
-- break
-- else
-- print "no\n"
-- end
--end
--exit(1) unless File.exists? py_makefile
-+py_name = File.basename(python)
-+py_dir = `#{python} -c 'import sys; print sys.exec_prefix' < /dev/null`.split(/\n/)[0]
-+
-+exit(1) unless File.directory? py_dir
-
--$CFLAGS = "-I#{py_includedir}"
--$LDFLAGS = "-L#{py_configdir}"
-+dir_config("python",
-+ py_dir + "/include/" + py_name,
-+ py_dir + "/lib/" + py_name + "/config")
-+
-+py_makefile = with_config("python-makefile",
-+ py_dir + "/lib/" + py_name + "/config/Makefile")
-+
-+print "checking for #{py_makefile}... "
-+if File.exists? py_makefile
-+ print "yes\n"
-+else
-+ print "no\n"
-+ exit(1)
-+end
-
- # If python is linked with extra libraries (e.g. -lpthread on Linux,
- # -lsocket on Solaris, etc.), have_library test will fail and built
-@@ -59,11 +53,13 @@
- end
- $LOCAL_LIBS << py_extralibs
-
--if have_library("python1.5", "Py_Initialize") && have_header("Python.h")
-- # If DEBUG defined, you need python compiled with Py_DEBUG defined,
-- # like as building python with "make OPT='-g -O2 -DPy_DEBUG'"
-- if have_func('_Py_NewReference')
-- $CFLAGS += " -DDEBUG"
-- end
-- create_makefile("python")
-+if !have_library(py_name, "Py_Initialize") || !have_header("Python.h")
-+ exit(1)
-+end
-+
-+# If DEBUG defined, you need python compiled with Py_DEBUG defined,
-+# like as building python with "make OPT='-g -O2 -DPy_DEBUG'"
-+if have_func('_Py_NewReference')
-+ $CFLAGS += " -DDEBUG"
- end
-+create_makefile("python")
diff --git a/lang/ruby-python/pkg-descr b/lang/ruby-python/pkg-descr
deleted file mode 100644
index 3bbc7944178..00000000000
--- a/lang/ruby-python/pkg-descr
+++ /dev/null
@@ -1,15 +0,0 @@
-Ruby extension library for embedding Python in Ruby. With this
-library, Ruby scripts can directly call arbitrary Python modules.
-Both extension modules and modules written in Python can be used.
-
-Ruby and Python have some differences as described here. This library
-enables Ruby users to have the advantages of both languages:
-
- - Straightforward and easy-to-learn OO functionality of Ruby.
- - Plenty of modules written for Python.
-
-If you are attracted by Python modules but not fully satisfied with
-Python's syntax or type system, try this library!
-
-Author: Masaki Fukushima <fukusima@goto.info.waseda.ac.jp>
-WWW: http://www.goto.info.waseda.ac.jp/~fukusima/ruby/python-e.html
diff --git a/lang/ruby-python/pkg-plist b/lang/ruby-python/pkg-plist
deleted file mode 100644
index cd45cf9fb23..00000000000
--- a/lang/ruby-python/pkg-plist
+++ /dev/null
@@ -1,26 +0,0 @@
-%%RUBY_SITEARCHLIBDIR%%/python.so
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/Lib/BaseHTTPServer.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/Lib/README
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/Lib/base64.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/Lib/rfc822.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/Lib/urllib.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/hello.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/html.py
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/html.rb
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/README.ja
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/Mapping.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/Object.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/Py.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/Sequence.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/index.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/Mapping.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/Object.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/Py.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/Sequence.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/index.html
-%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%/Lib
-%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
-%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%/ja
-%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%