aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-04-24 03:54:18 +0800
committerknu <knu@FreeBSD.org>2002-04-24 03:54:18 +0800
commit750100049e77034af5171ca341b5f8aa8dead582 (patch)
treef78ddd22fa7ee81830c8e221f3322575c6e40f69
parente0a4063bb98b0d5d164d4c75e74f8f4864f5eebe (diff)
downloadfreebsd-ports-graphics-750100049e77034af5171ca341b5f8aa8dead582.tar.gz
freebsd-ports-graphics-750100049e77034af5171ca341b5f8aa8dead582.tar.zst
freebsd-ports-graphics-750100049e77034af5171ca341b5f8aa8dead582.zip
Add ruby-aspectr 0.3.5.
AspectR is a library interface that lets Ruby developers program in an aspect oriented style (similar to AspectJ). PR: ports/36905 Submitted by: Sean Chittenden <sean@chittenden.org>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ruby-aspectr/Makefile37
-rw-r--r--devel/ruby-aspectr/distinfo1
-rw-r--r--devel/ruby-aspectr/pkg-comment1
-rw-r--r--devel/ruby-aspectr/pkg-descr6
-rw-r--r--devel/ruby-aspectr/pkg-plist7
6 files changed, 53 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index af7a39a489e..27a8ba3b888 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -573,6 +573,7 @@
SUBDIR += rpc2
SUBDIR += rtems-gcc
SUBDIR += ruby-amstd
+ SUBDIR += ruby-aspectr
SUBDIR += ruby-avl
SUBDIR += ruby-bsearch
SUBDIR += ruby-byaccr
diff --git a/devel/ruby-aspectr/Makefile b/devel/ruby-aspectr/Makefile
new file mode 100644
index 00000000000..fa41fcc8a1a
--- /dev/null
+++ b/devel/ruby-aspectr/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: ruby-aspectr
+# Date created: 08 April 2002
+# Whom: Sean Chittenden <sean@chittenden.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aspectr
+PORTVERSION= 0.3.5
+CATEGORIES= devel ruby
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/./-/g}
+DIST_SUBDIR= ruby
+
+MAINTAINER= sean@chittenden.org
+
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/runit/error.rb:${PORTSDIR}/devel/ruby-unit
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+DOCS= CHANGELOG README TODO
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/lib/aspectr.rb ${RUBY_SITELIBDIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PORTDOCS}${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/examples/logger.rb ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-aspectr/distinfo b/devel/ruby-aspectr/distinfo
new file mode 100644
index 00000000000..60209983194
--- /dev/null
+++ b/devel/ruby-aspectr/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/aspectr-0-3-5.tar.gz) = c640a1a82802ddb107c3ee1245a22705
diff --git a/devel/ruby-aspectr/pkg-comment b/devel/ruby-aspectr/pkg-comment
new file mode 100644
index 00000000000..254ec65f2c8
--- /dev/null
+++ b/devel/ruby-aspectr/pkg-comment
@@ -0,0 +1 @@
+Ruby libraries for Aspect programming
diff --git a/devel/ruby-aspectr/pkg-descr b/devel/ruby-aspectr/pkg-descr
new file mode 100644
index 00000000000..39bd0093638
--- /dev/null
+++ b/devel/ruby-aspectr/pkg-descr
@@ -0,0 +1,6 @@
+This package allows Ruby developers to write their code using aspect-
+oriented programming style. AspectR is somewhat similar to AspectJ.
+
+WWW: http://aspectr.sourceforge.net/
+
+- Sean Chittenden <sean@chittenden.org>
diff --git a/devel/ruby-aspectr/pkg-plist b/devel/ruby-aspectr/pkg-plist
new file mode 100644
index 00000000000..c45a420b6e3
--- /dev/null
+++ b/devel/ruby-aspectr/pkg-plist
@@ -0,0 +1,7 @@
+%%RUBY_SITELIBDIR%%/aspectr.rb
+%%PORTDOCS%%%%RUBY_DOCDIR%%/aspectr/CHANGELOG
+%%PORTDOCS%%%%RUBY_DOCDIR%%/aspectr/README
+%%PORTDOCS%%%%RUBY_DOCDIR%%/aspectr/TODO
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/aspectr
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/aspectr/logger.rb
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/aspectr