aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2008-06-28 05:21:19 +0800
committeritetcu <itetcu@FreeBSD.org>2008-06-28 05:21:19 +0800
commit75eead1e0b8230320946f93be2bfbee5e10685fa (patch)
tree32d205a2018f27ba57cbf840657d9c61aa0cf4da
parentddcbf354c14be4e051d6e81232698d96626f909d (diff)
downloadfreebsd-ports-graphics-75eead1e0b8230320946f93be2bfbee5e10685fa.tar.gz
freebsd-ports-graphics-75eead1e0b8230320946f93be2bfbee5e10685fa.tar.zst
freebsd-ports-graphics-75eead1e0b8230320946f93be2bfbee5e10685fa.zip
- use PORTDOCS, DOCSDIR macros
- fix plist for -DNOPORTDOCS - move pkg-message to SUB_FILES - bump PORTREVISION
-rw-r--r--graphics/gracula/Makefile9
-rw-r--r--graphics/gracula/files/pkg-message.in (renamed from graphics/gracula/pkg-message)5
-rw-r--r--graphics/gracula/pkg-plist6
3 files changed, 12 insertions, 8 deletions
diff --git a/graphics/gracula/Makefile b/graphics/gracula/Makefile
index 335fe742871..ed753ca3abd 100644
--- a/graphics/gracula/Makefile
+++ b/graphics/gracula/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gracula
PORTVERSION= 3.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.whizkidtech.redprince.net/cgi/gcl/ \
http://www.whizkidtech.redprince.net/gcl/
@@ -14,13 +15,15 @@ MASTER_SITES= ftp://ftp.whizkidtech.redprince.net/cgi/gcl/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= A Graphic Counter Language compiler/interpreter
+SUB_FILES= pkg-message
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gracula ${PREFIX}/bin
$(INSTALL_PROGRAM) ${WRKSRC}/sec2000 ${PREFIX}/bin
.if !defined (NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/gracula
- ${INSTALL_MAN} ${WRKSRC}/NNL ${PREFIX}/share/doc/gracula
- ${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/gracula
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/NNL ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
.endif
@${CAT} ${PKGMESSAGE}
diff --git a/graphics/gracula/pkg-message b/graphics/gracula/files/pkg-message.in
index b638de8677b..b844528c039 100644
--- a/graphics/gracula/pkg-message
+++ b/graphics/gracula/files/pkg-message.in
@@ -1,6 +1,7 @@
- Please read the file ${PREFIX}/share/doc/gracula/README
- to learn how to use Graphic Counter Language.
+ Please read the file %%DOCSDIR%%/README
+ to learn how to use Graphic Counter Language (if you haven't
+ installed with -D NOPORTDOCS).
An introductory tutorial, and a GCL FAQ, can be found at
http://www.whizkidtech.redprince.net/gcl/
diff --git a/graphics/gracula/pkg-plist b/graphics/gracula/pkg-plist
index 22d5907dcad..bb0d061844b 100644
--- a/graphics/gracula/pkg-plist
+++ b/graphics/gracula/pkg-plist
@@ -1,5 +1,5 @@
bin/gracula
bin/sec2000
-share/doc/gracula/NNL
-share/doc/gracula/README
-@dirrm share/doc/gracula
+%%PORTDOCS%%%%DOCSDIR%%/NNL
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%