aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2008-01-24 10:47:24 +0800
committerclsung <clsung@FreeBSD.org>2008-01-24 10:47:24 +0800
commit774584d4ec8308104e9534bc3d0a8adf2b1c0167 (patch)
treeb2ff18c0d801ccde303dd9d1f05d95fe51681a6e
parent509b67a996bdc333677ca6bb4b240c2e9c9fd4b1 (diff)
downloadfreebsd-ports-graphics-774584d4ec8308104e9534bc3d0a8adf2b1c0167.tar.gz
freebsd-ports-graphics-774584d4ec8308104e9534bc3d0a8adf2b1c0167.tar.zst
freebsd-ports-graphics-774584d4ec8308104e9534bc3d0a8adf2b1c0167.zip
Consistent hashing is a scheme that provides hash table functionality
in a way that the addition or removal of one slot does not significantly change the mapping of keys to slots. In contrast, in most traditional hash tables, a change in the number of array slots causes nearly all keys to be remapped. Consistent hashing was introduced in 1997 as a way of distributing requests among a changing population of web servers. More recently, it and similar techniques have been employed in distributed hash tables. WWW: http://search.cpan.org/dist/Set-ConsistentHash/ PR: ports/119587 Submitted by: Gea-Suan Lin <gslin at gslin.org>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Set-ConsistentHash/Makefile24
-rw-r--r--devel/p5-Set-ConsistentHash/distinfo3
-rw-r--r--devel/p5-Set-ConsistentHash/pkg-descr11
-rw-r--r--devel/p5-Set-ConsistentHash/pkg-plist6
5 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ae1b2980661..c8ae88e8bee 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1521,6 +1521,7 @@
SUBDIR += p5-Scope-Guard
SUBDIR += p5-Search-Binary
SUBDIR += p5-Set-Array
+ SUBDIR += p5-Set-ConsistentHash
SUBDIR += p5-Set-Crontab
SUBDIR += p5-Set-Infinite
SUBDIR += p5-Set-NestedGroups
diff --git a/devel/p5-Set-ConsistentHash/Makefile b/devel/p5-Set-ConsistentHash/Makefile
new file mode 100644
index 00000000000..4339d82e419
--- /dev/null
+++ b/devel/p5-Set-ConsistentHash/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Set-ConsistentHash
+# Date created: 2008-01-12
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Set-ConsistentHash
+PORTVERSION= 0.91
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Set
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Library for doing consistent hashing
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+
+PERL_CONFIGURE= yes
+
+MAN3= Set::ConsistentHash.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Set-ConsistentHash/distinfo b/devel/p5-Set-ConsistentHash/distinfo
new file mode 100644
index 00000000000..efde76cd5e3
--- /dev/null
+++ b/devel/p5-Set-ConsistentHash/distinfo
@@ -0,0 +1,3 @@
+MD5 (Set-ConsistentHash-0.91.tar.gz) = 9ffc6a8c4d525e5cf36e5c3f3a442587
+SHA256 (Set-ConsistentHash-0.91.tar.gz) = 990f0c06e2a5b19993cd1281ee71eccd278f6c517b05a3aba918a702e9ce31f9
+SIZE (Set-ConsistentHash-0.91.tar.gz) = 4980
diff --git a/devel/p5-Set-ConsistentHash/pkg-descr b/devel/p5-Set-ConsistentHash/pkg-descr
new file mode 100644
index 00000000000..2092ae0eb66
--- /dev/null
+++ b/devel/p5-Set-ConsistentHash/pkg-descr
@@ -0,0 +1,11 @@
+Consistent hashing is a scheme that provides hash table functionality
+in a way that the addition or removal of one slot does not
+significantly change the mapping of keys to slots. In contrast, in
+most traditional hash tables, a change in the number of array slots
+causes nearly all keys to be remapped.
+
+Consistent hashing was introduced in 1997 as a way of distributing
+requests among a changing population of web servers. More recently, it
+and similar techniques have been employed in distributed hash tables.
+
+WWW: http://search.cpan.org/dist/Set-ConsistentHash/
diff --git a/devel/p5-Set-ConsistentHash/pkg-plist b/devel/p5-Set-ConsistentHash/pkg-plist
new file mode 100644
index 00000000000..781c413b401
--- /dev/null
+++ b/devel/p5-Set-ConsistentHash/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Set/ConsistentHash/.packlist
+%%SITE_PERL%%/Set/ConsistentHash.pm
+@dirrmtry %%SITE_PERL%%/Set
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Set/ConsistentHash
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Set
td>2006-05-252-6/+4 * - Fix master sitesmnag2006-05-251-1/+2 * - suppress debug message for nocem filterleeym2006-05-251-0/+2 * Update 2.2erwin2006-05-193-13/+12 * Fix plistvs2006-05-161-0/+1 * Add USE_GETTEXT to appease portlint.mezz2006-05-161-0/+1 * - Pass maintainership to submitter.itetcu2006-05-141-1/+1 * Remove USE_REINPLACE from all categories starting with Nedwin2006-05-1226-32/+0 * Update to 2.5vs2006-05-093-13/+17 * - Update to 2.4.3pav2006-05-087-38/+76 * Update to 1.01skv2006-05-052-5/+11 * - Hand maintainership to submittererwin2006-05-052-18/+17 * - Drop maintainershipclement2006-05-013-3/+3 * Switch the pcre dependency to pcre-utf8 to fix conflict problems inmarcus2006-05-011-1/+1 * The author of this program seems to have gone awol. His domain has expired,vs2006-04-261-1/+4 * Pet portlint(1).anray2006-04-171-4/+2 * Reset mph due to no response to email about status, and maintainer-timeouts.linimon2006-04-151-1/+1 * Reset petef due to no response to email. We hope to see him back sometime.linimon2006-04-153-3/+3 * - Update to 1.11.5vs2006-04-094-17/+17 * - disable mkinfo and fix plistdinoex2006-04-021-1/+3 * - new option WITHOUT_IFCICOdinoex2006-03-262-7/+2 * - Update to 0.1.8.1pav2006-03-266-22/+22 * - Update to 0.9pav2006-03-264-14/+34 * Update to 5.1.4anray2006-03-242-4/+4 * A web-interface based standalone binary newsgrabber written in python, supportspav2006-03-2113-0/+279 * - Update to 2.8tdb2006-03-202-4/+4 * - remove BEFOREleeym2006-03-171-3/+1 * Remove FreeBSD KEYWORD, which has been a noop for some time now.dougb2006-03-171-1/+1 * - use %%RC_SUBR%% instead of hardcoded /etc/rc.subr [1]leeym2006-03-173-2/+13 * Upgrade to 1.8.1ache2006-03-164-16/+5 * - update to 3.0.2leeym2006-03-166-659/+59 * - Update to 0.2.3pav2006-03-152-5/+4 * Bump PORTREVISION on glib12/gtk12 consumer ports to ease the upgrade path.ade2006-03-074-4/+4 * Conversion to a single libtool environment.ade2006-02-234-6/+6 * Remove the FreeBSD KEYWORD from all rc.d scripts where it appears.dougb2006-02-211-1/+0 * Remove deprecated USE_REINPLACEehaupt2006-02-191-2/+0 * - Fix possibility of "infinite make fork" when "Registering install for ..."linimon2006-01-281-0/+1 * SHA256ifyedwin2006-01-241-1/+2 * SHA256ifyedwin2006-01-24