aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-02-06 16:14:45 +0800
committermiwi <miwi@FreeBSD.org>2011-02-06 16:14:45 +0800
commit79d27e7dc97eef56a468556369645de6f5d64eda (patch)
treebd2bd52dc8da1c946fffb93dffdb5736c4d421a0
parentdc758a3d71b8f33453e92c8a341c7dbde3a0f551 (diff)
downloadfreebsd-ports-graphics-79d27e7dc97eef56a468556369645de6f5d64eda.tar.gz
freebsd-ports-graphics-79d27e7dc97eef56a468556369645de6f5d64eda.tar.zst
freebsd-ports-graphics-79d27e7dc97eef56a468556369645de6f5d64eda.zip
- Update to 0.12.7
PR: 153718 Submitted by: Jui-Nan Lin <jnlin@csie.nctu.edu.tw> Approved by: flz via irc (maintainer) Feature safe: yes
-rw-r--r--net-p2p/libtorrent/Makefile10
-rw-r--r--net-p2p/libtorrent/distinfo5
-rw-r--r--net-p2p/libtorrent/pkg-plist69
3 files changed, 46 insertions, 38 deletions
diff --git a/net-p2p/libtorrent/Makefile b/net-p2p/libtorrent/Makefile
index 6fca3e9c4bc..b3e73069cbd 100644
--- a/net-p2p/libtorrent/Makefile
+++ b/net-p2p/libtorrent/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME?= libtorrent
-PORTVERSION?= 0.12.6
-PORTREVISION?= 1
+PORTVERSION?= 0.12.7
CATEGORIES= net-p2p
MASTER_SITES= http://libtorrent.rakshasa.no/downloads/ \
${MASTER_SITE_LOCAL}
@@ -28,7 +27,8 @@ USE_OPENSSL= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-OPTIONS= KQUEUE "Use kqueue(2) support" on
+OPTIONS= KQUEUE "Use kqueue(2) support" on \
+ IPV6 "Enable IPv6 support" off
.include <bsd.port.pre.mk>
@@ -48,4 +48,8 @@ post-patch:
CONFIGURE_ARGS+= --with-kqueue
.endif
+.if defined(WITH_IPV6)
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
+
.include <bsd.port.post.mk>
diff --git a/net-p2p/libtorrent/distinfo b/net-p2p/libtorrent/distinfo
index 993c5a8cb9a..cbc58df4e55 100644
--- a/net-p2p/libtorrent/distinfo
+++ b/net-p2p/libtorrent/distinfo
@@ -1,3 +1,2 @@
-MD5 (libtorrent-0.12.6.tar.gz) = 037499ed708aaf72988cee60e5a8d96b
-SHA256 (libtorrent-0.12.6.tar.gz) = 7b02f33164966a05261e83bad76eef537198fefe76eaf57dfd64bb27c7d77129
-SIZE (libtorrent-0.12.6.tar.gz) = 594113
+SHA256 (libtorrent-0.12.7.tar.gz) = 96f59ec9593cd77ef9bad78cadef9ce6f1040243cccf1108aa7844e58d632a97
+SIZE (libtorrent-0.12.7.tar.gz) = 632060
diff --git a/net-p2p/libtorrent/pkg-plist b/net-p2p/libtorrent/pkg-plist
index 3b03b754981..5ebc0bdac07 100644
--- a/net-p2p/libtorrent/pkg-plist
+++ b/net-p2p/libtorrent/pkg-plist
@@ -1,48 +1,53 @@
-@comment $FreeBSD: /tmp/pcvs/ports/net-p2p/libtorrent/pkg-plist,v 1.14 2008-12-09 11:30:31 flz Exp $
-include/torrent/bitfield.h
-include/torrent/chunk_manager.h
+@comment $FreeBSD: /tmp/pcvs/ports/net-p2p/libtorrent/pkg-plist,v 1.15 2011-02-06 08:14:45 miwi Exp $
include/torrent/common.h
-include/torrent/connection_manager.h
+include/torrent/throttle.h
+include/torrent/peer/client_list.h
+include/torrent/peer/peer_list.h
+include/torrent/peer/client_info.h
+include/torrent/peer/peer.h
+include/torrent/peer/connection_list.h
+include/torrent/peer/peer_info.h
+include/torrent/object_raw_bencode.h
+include/torrent/download_info.h
+include/torrent/torrent.h
+include/torrent/tracker.h
+include/torrent/http.h
+include/torrent/hash_string.h
+include/torrent/chunk_manager.h
+include/torrent/bitfield.h
+include/torrent/object.h
+include/torrent/object_stream.h
+include/torrent/dht_manager.h
+include/torrent/poll_epoll.h
+include/torrent/exceptions.h
+include/torrent/poll_kqueue.h
+include/torrent/rate.h
include/torrent/data/block.h
-include/torrent/data/block_list.h
-include/torrent/data/block_transfer.h
-include/torrent/data/file.h
-include/torrent/data/file_list.h
-include/torrent/data/file_list_iterator.h
include/torrent/data/file_manager.h
+include/torrent/data/block_transfer.h
include/torrent/data/file_utils.h
+include/torrent/data/chunk_utils.h
+include/torrent/data/file_list.h
include/torrent/data/piece.h
+include/torrent/data/block_list.h
+include/torrent/data/file.h
include/torrent/data/transfer_list.h
-include/torrent/dht_manager.h
+include/torrent/data/file_list_iterator.h
include/torrent/download.h
+include/torrent/object_static_map.h
+include/torrent/poll_select.h
+include/torrent/tracker_list.h
+include/torrent/connection_manager.h
+include/torrent/poll.h
include/torrent/error.h
+include/torrent/thread_base.h
include/torrent/event.h
-include/torrent/exceptions.h
-include/torrent/hash_string.h
-include/torrent/http.h
-include/torrent/object.h
-include/torrent/object_stream.h
include/torrent/path.h
-include/torrent/peer/client_info.h
-include/torrent/peer/client_list.h
-include/torrent/peer/connection_list.h
-include/torrent/peer/peer.h
-include/torrent/peer/peer_info.h
-include/torrent/peer/peer_list.h
-include/torrent/poll.h
-include/torrent/poll_epoll.h
-include/torrent/poll_kqueue.h
-include/torrent/poll_select.h
-include/torrent/rate.h
include/torrent/resume.h
-include/torrent/throttle.h
-include/torrent/torrent.h
-include/torrent/tracker.h
-include/torrent/tracker_list.h
lib/libtorrent.a
-lib/libtorrent.la
lib/libtorrent.so
-lib/libtorrent.so.11
+lib/libtorrent.so.13
+lib/libtorrent.la
libdata/pkgconfig/libtorrent.pc
@dirrmtry include/torrent/peer
@dirrmtry include/torrent/data