aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2004-03-19 00:02:49 +0800
committerale <ale@FreeBSD.org>2004-03-19 00:02:49 +0800
commit7b75540432a083fff96131c4598184df98208342 (patch)
tree77e8bdd0b6e787d10dfe60717fa6e389524a81a9
parentcd7db93a2ec64ab62fd246ca4b88e5faf02c8d54 (diff)
downloadfreebsd-ports-graphics-7b75540432a083fff96131c4598184df98208342.tar.gz
freebsd-ports-graphics-7b75540432a083fff96131c4598184df98208342.tar.zst
freebsd-ports-graphics-7b75540432a083fff96131c4598184df98208342.zip
Fix build with new freetype2 library.
PR: ports/64417 Submitted by: Renato Botelho <renato@galle.com.br>
-rw-r--r--lang/php4/files/patch-ext::gd::libgd::gdft.c14
-rw-r--r--lang/php5/Makefile1
-rw-r--r--lang/php5/files/patch-ext::gd::libgd::gdft.c11
-rw-r--r--lang/php53/Makefile1
-rw-r--r--lang/php53/files/patch-ext::gd::libgd::gdft.c11
5 files changed, 36 insertions, 2 deletions
diff --git a/lang/php4/files/patch-ext::gd::libgd::gdft.c b/lang/php4/files/patch-ext::gd::libgd::gdft.c
new file mode 100644
index 00000000000..31e16dc71e8
--- /dev/null
+++ b/lang/php4/files/patch-ext::gd::libgd::gdft.c
@@ -0,0 +1,14 @@
+--- ext/gd/libgd/gdft.c.orig Thu Mar 18 16:41:43 2004
++++ ext/gd/libgd/gdft.c Thu Mar 18 16:49:39 2004
+@@ -60,8 +60,9 @@
+ #else
+
+ #include "gdcache.h"
+-#include "freetype/freetype.h"
+-#include "freetype/ftglyph.h"
++#include <ft2build.h>
++#include FT_FREETYPE_H
++#include FT_GLYPH_H
+
+ /* number of fonts cached before least recently used is replaced */
+ #define FONTCACHESIZE 6
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index aa5516fb032..b0e011afaaf 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -45,7 +45,6 @@ PKGNAMESUFFIX= -cli
.endif
.endif
DISTNAME= php-${PORTVERSION:S/.a/a/}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER?= ale@FreeBSD.org
COMMENT?= PHP Scripting Language (Apache Module and CLI)
diff --git a/lang/php5/files/patch-ext::gd::libgd::gdft.c b/lang/php5/files/patch-ext::gd::libgd::gdft.c
new file mode 100644
index 00000000000..beadf4bf393
--- /dev/null
+++ b/lang/php5/files/patch-ext::gd::libgd::gdft.c
@@ -0,0 +1,11 @@
+--- ext/gd/libgd/gdft.c.orig Sun Dec 28 22:07:18 2003
++++ ext/gd/libgd/gdft.c Thu Mar 18 16:54:09 2004
+@@ -63,7 +63,7 @@
+ #include "gdcache.h"
+ #include <ft2build.h>
+ #include FT_FREETYPE_H
+-#include "freetype/ftglyph.h"
++#include FT_GLYPH_H
+
+ /* number of fonts cached before least recently used is replaced */
+ #define FONTCACHESIZE 6
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index aa5516fb032..b0e011afaaf 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -45,7 +45,6 @@ PKGNAMESUFFIX= -cli
.endif
.endif
DISTNAME= php-${PORTVERSION:S/.a/a/}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER?= ale@FreeBSD.org
COMMENT?= PHP Scripting Language (Apache Module and CLI)
diff --git a/lang/php53/files/patch-ext::gd::libgd::gdft.c b/lang/php53/files/patch-ext::gd::libgd::gdft.c
new file mode 100644
index 00000000000..beadf4bf393
--- /dev/null
+++ b/lang/php53/files/patch-ext::gd::libgd::gdft.c
@@ -0,0 +1,11 @@
+--- ext/gd/libgd/gdft.c.orig Sun Dec 28 22:07:18 2003
++++ ext/gd/libgd/gdft.c Thu Mar 18 16:54:09 2004
+@@ -63,7 +63,7 @@
+ #include "gdcache.h"
+ #include <ft2build.h>
+ #include FT_FREETYPE_H
+-#include "freetype/ftglyph.h"
++#include FT_GLYPH_H
+
+ /* number of fonts cached before least recently used is replaced */
+ #define FONTCACHESIZE 6