aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornsayer <nsayer@FreeBSD.org>2001-05-22 11:56:36 +0800
committernsayer <nsayer@FreeBSD.org>2001-05-22 11:56:36 +0800
commit7d4b467b3ff4929262a1080a1dc8b39574005cb1 (patch)
tree0311d4aa69ee2f5c817ef4bfef9d02f4bfc24ef2
parent5e9f24249e6961cffc353d5dbd824e1bb40a62f9 (diff)
downloadfreebsd-ports-graphics-7d4b467b3ff4929262a1080a1dc8b39574005cb1.tar.gz
freebsd-ports-graphics-7d4b467b3ff4929262a1080a1dc8b39574005cb1.tar.zst
freebsd-ports-graphics-7d4b467b3ff4929262a1080a1dc8b39574005cb1.zip
Add support for the Airport Host and Link monitors. The port won't be
able to track the version numbers of those, but if they increment before the configurator does, we can use PORTREVISION. We'll bump that now too, of course. We can't add the modem utility because there isn't a distfile available that has a version number in it. :-(
-rw-r--r--net-mgmt/airport/Makefile12
-rw-r--r--net-mgmt/airport/distinfo2
-rw-r--r--net-mgmt/airport/files/airport22
-rw-r--r--net-mgmt/airport/pkg-descr4
-rw-r--r--net-mgmt/airport/pkg-plist4
-rw-r--r--net/airport/Makefile12
-rw-r--r--net/airport/distinfo2
-rw-r--r--net/airport/files/airport22
-rw-r--r--net/airport/pkg-descr4
-rw-r--r--net/airport/pkg-plist4
10 files changed, 80 insertions, 8 deletions
diff --git a/net-mgmt/airport/Makefile b/net-mgmt/airport/Makefile
index ffb6585bcfa..a2d95bb0536 100644
--- a/net-mgmt/airport/Makefile
+++ b/net-mgmt/airport/Makefile
@@ -7,10 +7,12 @@
PORTNAME= airport
PORTVERSION= 1.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net java
MASTER_SITES= http://edge.mcs.drexel.edu/GICL/people/sevy/airport/
-DISTFILES= configurator_${PORTVERSION:S/.//}${EXTRACT_SUFX}
+DISTFILES= configurator_${PORTVERSION:S/.//}${EXTRACT_SUFX} \
+ link_monitor_${LINKMONVERSION:S/.//}${EXTRACT_SUFX} \
+ host_monitor_${HOSTMONVERSION:S/.//}${EXTRACT_SUFX}
MAINTAINER= nsayer@freebsd.org
@@ -18,12 +20,16 @@ RUN_DEPENDS= ${LOCALBASE}/jdk${JDK_VERSION}/bin/java:${PORTSDIR}/java/jdk \
${LOCALBASE}/share/java/classes/jfc-${JFC_VERSION}/swingall.jar:${PORTSDIR}/java/jfc \
${LOCALBASE}/bin/javavm:${PORTSDIR}/java/javavmwrapper
+EXTRACT_BEFORE_ARGS= -q -o
+
USE_ZIP= YES
NO_WRKSUBDIR= YES
JDK_VERSION= 1.1.8
JFC_VERSION= 1.1.1
+LINKMONVERSION= 1.1
+HOSTMONVERSION= 1.0
NO_BUILD= yes
@@ -43,5 +49,7 @@ do-install:
-e s/%%JDK_VERSION%%/${JDK_VERSION}/ \
< ${FILESDIR}/airport > ${PREFIX}/bin/airport; \
${CHMOD} a+x ${PREFIX}/bin/airport
+ ${LN} ${PREFIX}/bin/airport ${PREFIX}/bin/hostmon
+ ${LN} ${PREFIX}/bin/airport ${PREFIX}/bin/linkmon
.include <bsd.port.post.mk>
diff --git a/net-mgmt/airport/distinfo b/net-mgmt/airport/distinfo
index a2c24450b11..7c701666edf 100644
--- a/net-mgmt/airport/distinfo
+++ b/net-mgmt/airport/distinfo
@@ -1 +1,3 @@
MD5 (configurator_14.zip) = b9dbbf78e7a69e358a0237def72cad32
+MD5 (link_monitor_11.zip) = e6837268e0edcdfd1566dec35b09deb7
+MD5 (host_monitor_10.zip) = 8f413a9a283c28d3e7ba461b79da1b45
diff --git a/net-mgmt/airport/files/airport b/net-mgmt/airport/files/airport
index 2ae406c629c..5d0084f0287 100644
--- a/net-mgmt/airport/files/airport
+++ b/net-mgmt/airport/files/airport
@@ -1,9 +1,27 @@
#! /bin/sh
+case $0 in
+ *airport)
+ class=AirportBaseStationConfigurator
+ file=AirportBaseStationConfigurator
+ ;;
+ *hostmon)
+ class=HostMonitor
+ file=HostMonitor
+ ;;
+ *linkmon)
+ class=LinkMonitor
+ file=LinkMonitor
+ ;;
+ *)
+ echo "Unknown command"
+ exit 1
+esac
+
# Use this one for JDK 1.2 and beyond:
-# exec %%PREFIX%%/bin/javavm -jar %%PREFIX%%/share/java/AirportBaseStationConfig.jar
+# exec %%PREFIX%%/bin/javavm -jar %%PREFIX%%/share/java/${file}.jar
# Use this one for the default installation -- JDK 1.1.x + JFC:
-exec %%PREFIX%%/bin/javavm -classpath "%%PREFIX%%/jdk%%JDK_VERSION%%/lib/classes.zip:%%PREFIX%%/share/java/classes/jfc-%%JFC_VERSION%%/swingall.jar:%%PREFIX%%/share/java/AirportBaseStationConfig.jar" AirportBaseStationConfigurator
+exec %%PREFIX%%/bin/javavm -classpath "%%PREFIX%%/jdk%%JDK_VERSION%%/lib/classes.zip:%%PREFIX%%/share/java/classes/jfc-%%JFC_VERSION%%/swingall.jar:%%PREFIX%%/share/java/${file}.jar" $class
exit 1
diff --git a/net-mgmt/airport/pkg-descr b/net-mgmt/airport/pkg-descr
index 42cc9b7a5ba..d2ae916d0ff 100644
--- a/net-mgmt/airport/pkg-descr
+++ b/net-mgmt/airport/pkg-descr
@@ -5,4 +5,8 @@ The Airport and Lucent RG-1000 are the same, except for one detail:
On the RG-1000 the net name cannot be changed and is overridden by
the hex number on the label on the bottom.
+This port also installs the Link Monitor and Host Monitor utilities.
+It doesn't install the modem utility because there's no version numbered
+distfile available.
+
WWW: http://edge.mcs.drexel.edu/GICL/people/sevy/airport/index.html
diff --git a/net-mgmt/airport/pkg-plist b/net-mgmt/airport/pkg-plist
index cbfeb33023f..4f76b119a17 100644
--- a/net-mgmt/airport/pkg-plist
+++ b/net-mgmt/airport/pkg-plist
@@ -1,5 +1,9 @@
bin/airport
+bin/hostmon
+bin/linkmon
share/java/AirportBaseStationConfig.jar
+share/java/HostMonitor.jar
+share/java/LinkMonitor.jar
share/doc/airport/AUTHORS
share/doc/airport/COPYING
share/doc/airport/helpdocs/ReadMe.txt
diff --git a/net/airport/Makefile b/net/airport/Makefile
index ffb6585bcfa..a2d95bb0536 100644
--- a/net/airport/Makefile
+++ b/net/airport/Makefile
@@ -7,10 +7,12 @@
PORTNAME= airport
PORTVERSION= 1.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net java
MASTER_SITES= http://edge.mcs.drexel.edu/GICL/people/sevy/airport/
-DISTFILES= configurator_${PORTVERSION:S/.//}${EXTRACT_SUFX}
+DISTFILES= configurator_${PORTVERSION:S/.//}${EXTRACT_SUFX} \
+ link_monitor_${LINKMONVERSION:S/.//}${EXTRACT_SUFX} \
+ host_monitor_${HOSTMONVERSION:S/.//}${EXTRACT_SUFX}
MAINTAINER= nsayer@freebsd.org
@@ -18,12 +20,16 @@ RUN_DEPENDS= ${LOCALBASE}/jdk${JDK_VERSION}/bin/java:${PORTSDIR}/java/jdk \
${LOCALBASE}/share/java/classes/jfc-${JFC_VERSION}/swingall.jar:${PORTSDIR}/java/jfc \
${LOCALBASE}/bin/javavm:${PORTSDIR}/java/javavmwrapper
+EXTRACT_BEFORE_ARGS= -q -o
+
USE_ZIP= YES
NO_WRKSUBDIR= YES
JDK_VERSION= 1.1.8
JFC_VERSION= 1.1.1
+LINKMONVERSION= 1.1
+HOSTMONVERSION= 1.0
NO_BUILD= yes
@@ -43,5 +49,7 @@ do-install:
-e s/%%JDK_VERSION%%/${JDK_VERSION}/ \
< ${FILESDIR}/airport > ${PREFIX}/bin/airport; \
${CHMOD} a+x ${PREFIX}/bin/airport
+ ${LN} ${PREFIX}/bin/airport ${PREFIX}/bin/hostmon
+ ${LN} ${PREFIX}/bin/airport ${PREFIX}/bin/linkmon
.include <bsd.port.post.mk>
diff --git a/net/airport/distinfo b/net/airport/distinfo
index a2c24450b11..7c701666edf 100644
--- a/net/airport/distinfo
+++ b/net/airport/distinfo
@@ -1 +1,3 @@
MD5 (configurator_14.zip) = b9dbbf78e7a69e358a0237def72cad32
+MD5 (link_monitor_11.zip) = e6837268e0edcdfd1566dec35b09deb7
+MD5 (host_monitor_10.zip) = 8f413a9a283c28d3e7ba461b79da1b45
diff --git a/net/airport/files/airport b/net/airport/files/airport
index 2ae406c629c..5d0084f0287 100644
--- a/net/airport/files/airport
+++ b/net/airport/files/airport
@@ -1,9 +1,27 @@
#! /bin/sh
+case $0 in
+ *airport)
+ class=AirportBaseStationConfigurator
+ file=AirportBaseStationConfigurator
+ ;;
+ *hostmon)
+ class=HostMonitor
+ file=HostMonitor
+ ;;
+ *linkmon)
+ class=LinkMonitor
+ file=LinkMonitor
+ ;;
+ *)
+ echo "Unknown command"
+ exit 1
+esac
+
# Use this one for JDK 1.2 and beyond:
-# exec %%PREFIX%%/bin/javavm -jar %%PREFIX%%/share/java/AirportBaseStationConfig.jar
+# exec %%PREFIX%%/bin/javavm -jar %%PREFIX%%/share/java/${file}.jar
# Use this one for the default installation -- JDK 1.1.x + JFC:
-exec %%PREFIX%%/bin/javavm -classpath "%%PREFIX%%/jdk%%JDK_VERSION%%/lib/classes.zip:%%PREFIX%%/share/java/classes/jfc-%%JFC_VERSION%%/swingall.jar:%%PREFIX%%/share/java/AirportBaseStationConfig.jar" AirportBaseStationConfigurator
+exec %%PREFIX%%/bin/javavm -classpath "%%PREFIX%%/jdk%%JDK_VERSION%%/lib/classes.zip:%%PREFIX%%/share/java/classes/jfc-%%JFC_VERSION%%/swingall.jar:%%PREFIX%%/share/java/${file}.jar" $class
exit 1
diff --git a/net/airport/pkg-descr b/net/airport/pkg-descr
index 42cc9b7a5ba..d2ae916d0ff 100644
--- a/net/airport/pkg-descr
+++ b/net/airport/pkg-descr
@@ -5,4 +5,8 @@ The Airport and Lucent RG-1000 are the same, except for one detail:
On the RG-1000 the net name cannot be changed and is overridden by
the hex number on the label on the bottom.
+This port also installs the Link Monitor and Host Monitor utilities.
+It doesn't install the modem utility because there's no version numbered
+distfile available.
+
WWW: http://edge.mcs.drexel.edu/GICL/people/sevy/airport/index.html
diff --git a/net/airport/pkg-plist b/net/airport/pkg-plist
index cbfeb33023f..4f76b119a17 100644
--- a/net/airport/pkg-plist
+++ b/net/airport/pkg-plist
@@ -1,5 +1,9 @@
bin/airport
+bin/hostmon
+bin/linkmon
share/java/AirportBaseStationConfig.jar
+share/java/HostMonitor.jar
+share/java/LinkMonitor.jar
share/doc/airport/AUTHORS
share/doc/airport/COPYING
share/doc/airport/helpdocs/ReadMe.txt