aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2002-02-09 03:03:10 +0800
committerade <ade@FreeBSD.org>2002-02-09 03:03:10 +0800
commit7d64fe11b035a82c69400b1ce48f909d01b1be99 (patch)
treeeb9134992d23052158c6116e361c4cd3e6f728bc
parente105a6c8e48c870a7594ea5a8d6b22919b8ec11c (diff)
downloadfreebsd-ports-graphics-7d64fe11b035a82c69400b1ce48f909d01b1be99.tar.gz
freebsd-ports-graphics-7d64fe11b035a82c69400b1ce48f909d01b1be99.tar.zst
freebsd-ports-graphics-7d64fe11b035a82c69400b1ce48f909d01b1be99.zip
glibconfig.h was getting installed in /, rather than below PREFIX
and was being compensated for by a post-install target. Fix the underlying problem, bumping PORTREVISION.
-rw-r--r--devel/glib13/Makefile4
-rw-r--r--devel/glib13/files/patch-ag21
-rw-r--r--devel/glib20/Makefile4
-rw-r--r--devel/glib20/files/patch-ag21
4 files changed, 14 insertions, 36 deletions
diff --git a/devel/glib13/Makefile b/devel/glib13/Makefile
index ca5d22fcf75..4739bb5ba77 100644
--- a/devel/glib13/Makefile
+++ b/devel/glib13/Makefile
@@ -7,6 +7,7 @@
PORTNAME= glib
PORTVERSION= 1.3.12
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
ftp://ftp.cs.umn.edu/pub/gimp/%SUBDIR%/ \
@@ -39,7 +40,4 @@ pre-patch:
@find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
-post-install:
- ${INSTALL_DATA} ${WRKSRC}/glibconfig.h ${PREFIX}/include/glib-2.0
-
.include <bsd.port.mk>
diff --git a/devel/glib13/files/patch-ag b/devel/glib13/files/patch-ag
index a73c1cf91a6..3e8fbfbf46e 100644
--- a/devel/glib13/files/patch-ag
+++ b/devel/glib13/files/patch-ag
@@ -1,23 +1,14 @@
-
-$FreeBSD$
-
---- Makefile.in.orig Fri Jan 18 09:43:54 2002
-+++ Makefile.in Fri Jan 18 09:45:49 2002
-@@ -149,7 +149,7 @@
-
- AUTOMAKE_OPTIONS = 1.4
+--- Makefile.in.orig Sun Dec 23 16:53:53 2001
++++ Makefile.in Fri Feb 8 12:44:30 2002
+@@ -151,3 +151,3 @@
-SUBDIRS = . m4macros glib gobject gmodule gthread tests build po docs
+SUBDIRS = . m4macros glib gobject gmodule gthread build po docs
- bin_SCRIPTS = glib-gettextize
-
-@@ -191,7 +191,7 @@
- glib-zip
-
+@@ -192,4 +192,4 @@
+-
-configexecincludedir = $(libdir)/glib-2.0/include
++glibincludedir = $(includedir)/glib-2.0
+configexecincludedir = $(glibincludedir)
- CONFIGURE_DEPENDENCIES = acglib.m4
-
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index ca5d22fcf75..4739bb5ba77 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -7,6 +7,7 @@
PORTNAME= glib
PORTVERSION= 1.3.12
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
ftp://ftp.cs.umn.edu/pub/gimp/%SUBDIR%/ \
@@ -39,7 +40,4 @@ pre-patch:
@find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
-post-install:
- ${INSTALL_DATA} ${WRKSRC}/glibconfig.h ${PREFIX}/include/glib-2.0
-
.include <bsd.port.mk>
diff --git a/devel/glib20/files/patch-ag b/devel/glib20/files/patch-ag
index a73c1cf91a6..3e8fbfbf46e 100644
--- a/devel/glib20/files/patch-ag
+++ b/devel/glib20/files/patch-ag
@@ -1,23 +1,14 @@
-
-$FreeBSD$
-
---- Makefile.in.orig Fri Jan 18 09:43:54 2002
-+++ Makefile.in Fri Jan 18 09:45:49 2002
-@@ -149,7 +149,7 @@
-
- AUTOMAKE_OPTIONS = 1.4
+--- Makefile.in.orig Sun Dec 23 16:53:53 2001
++++ Makefile.in Fri Feb 8 12:44:30 2002
+@@ -151,3 +151,3 @@
-SUBDIRS = . m4macros glib gobject gmodule gthread tests build po docs
+SUBDIRS = . m4macros glib gobject gmodule gthread build po docs
- bin_SCRIPTS = glib-gettextize
-
-@@ -191,7 +191,7 @@
- glib-zip
-
+@@ -192,4 +192,4 @@
+-
-configexecincludedir = $(libdir)/glib-2.0/include
++glibincludedir = $(includedir)/glib-2.0
+configexecincludedir = $(glibincludedir)
- CONFIGURE_DEPENDENCIES = acglib.m4
-