aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlesi <lesi@FreeBSD.org>2006-02-07 17:56:51 +0800
committerlesi <lesi@FreeBSD.org>2006-02-07 17:56:51 +0800
commit802cbea2e1bdf9bbd3dd1b0f610965a54b9f6c5b (patch)
treec367f72cc56c051a2420e7573a9b542390e57fc2
parentccd66d950b36b313da2c3716e11a4584aca162da (diff)
downloadfreebsd-ports-graphics-802cbea2e1bdf9bbd3dd1b0f610965a54b9f6c5b.tar.gz
freebsd-ports-graphics-802cbea2e1bdf9bbd3dd1b0f610965a54b9f6c5b.tar.zst
freebsd-ports-graphics-802cbea2e1bdf9bbd3dd1b0f610965a54b9f6c5b.zip
Take care of font cache files on installation and uninstallation of port:
On installation try running fc-cache for directory where fonts from this port are installed and don't complain if fc-cache (from fontconfig) is missing. Do a bit more dancing on uninstall, just in case users have their own fonts installed in same directory: - first remove fonts.cache-1 if it is there since it won't be accurate after fonts from this port are gone anyway, - next try to regenerate cache with fc-cache for this directory - if previous step generates empty cache file, remove it If directory contained only fonts from this port, it should get properly removed at the end. If there were other fonts there and fontconfig is installed, this will leave proper cache file for remaining fonts behind after uninstall of this port.
-rw-r--r--x11-fonts/XFree86-4-font100dpi/Makefile4
-rw-r--r--x11-fonts/XFree86-4-font100dpi/pkg-plist4
-rw-r--r--x11-fonts/XFree86-4-font75dpi/Makefile4
-rw-r--r--x11-fonts/XFree86-4-font75dpi/pkg-plist4
-rw-r--r--x11-fonts/XFree86-4-fontCyrillic/Makefile4
-rw-r--r--x11-fonts/XFree86-4-fontCyrillic/pkg-plist4
-rw-r--r--x11-fonts/XFree86-4-fontDefaultBitmaps/Makefile4
-rw-r--r--x11-fonts/XFree86-4-fontDefaultBitmaps/pkg-plist4
-rw-r--r--x11-fonts/XFree86-4-fontScalable/Makefile7
-rw-r--r--x11-fonts/XFree86-4-fontScalable/pkg-plist14
10 files changed, 53 insertions, 0 deletions
diff --git a/x11-fonts/XFree86-4-font100dpi/Makefile b/x11-fonts/XFree86-4-font100dpi/Makefile
index 98cb21c194f..4ec99aabc26 100644
--- a/x11-fonts/XFree86-4-font100dpi/Makefile
+++ b/x11-fonts/XFree86-4-font100dpi/Makefile
@@ -7,6 +7,7 @@
PORTNAME= font100dpi
PORTVERSION= 4.5.0
+PORTREVISION= 1
CATEGORIES= x11-fonts
MASTER_SITES= ${MASTER_SITE_XFREE}
MASTER_SITE_SUBDIR= ${PORTVERSION}
@@ -44,6 +45,9 @@ pre-build:
(cd ${WRKDIR}/xc/fonts/encodings && \
${MAKE} all)
+post-install:
+ @command fc-cache -v ${PREFIX}/lib/X11/fonts/100dpi || true
+
.include <bsd.port.pre.mk>
.if ${X_WINDOW_SYSTEM:L} != xfree86-4
IGNORE= is part of XFree86 and you have ${X_WINDOW_SYSTEM} set for X11\
diff --git a/x11-fonts/XFree86-4-font100dpi/pkg-plist b/x11-fonts/XFree86-4-font100dpi/pkg-plist
index 27093bbdb16..3abfa064b64 100644
--- a/x11-fonts/XFree86-4-font100dpi/pkg-plist
+++ b/x11-fonts/XFree86-4-font100dpi/pkg-plist
@@ -1896,4 +1896,8 @@ lib/X11/fonts/100dpi/timR24-ISO8859-3.pcf.gz
lib/X11/fonts/100dpi/timR24-ISO8859-4.pcf.gz
lib/X11/fonts/100dpi/timR24-ISO8859-9.pcf.gz
lib/X11/fonts/100dpi/timR24.pcf.gz
+@exec command fc-cache -v %D/lib/X11/fonts/100dpi 2>/dev/null || true
+@unexec rm %D/lib/X11/fonts/100dpi/fonts.cache-1 2>/dev/null || true
+@unexec command fc-cache -v %D/lib/X11/fonts/100dpi 2>/dev/null || true
+@unexec if [ -e %D/lib/X11/fonts/100dpi/fonts.cache-1 -a ! -s %D/lib/X11/fonts/100dpi/fonts.cache-1 ]; then rm %D/lib/X11/fonts/100dpi/fonts.cache-1; fi
@dirrmtry lib/X11/fonts/100dpi
diff --git a/x11-fonts/XFree86-4-font75dpi/Makefile b/x11-fonts/XFree86-4-font75dpi/Makefile
index 2b94b1ac1ce..d053307b77c 100644
--- a/x11-fonts/XFree86-4-font75dpi/Makefile
+++ b/x11-fonts/XFree86-4-font75dpi/Makefile
@@ -7,6 +7,7 @@
PORTNAME= font75dpi
PORTVERSION= 4.5.0
+PORTREVISION= 1
CATEGORIES= x11-fonts
MASTER_SITES= ${MASTER_SITE_XFREE}
MASTER_SITE_SUBDIR= ${PORTVERSION}
@@ -44,6 +45,9 @@ pre-build:
(cd ${WRKDIR}/xc/fonts/encodings && \
${MAKE} all)
+post-install:
+ @command fc-cache -v ${PREFIX}/lib/X11/fonts/75dpi || true
+
.include <bsd.port.pre.mk>
.if ${X_WINDOW_SYSTEM:L} != xfree86-4
IGNORE= is part of XFree86 and you have ${X_WINDOW_SYSTEM} set for X11\
diff --git a/x11-fonts/XFree86-4-font75dpi/pkg-plist b/x11-fonts/XFree86-4-font75dpi/pkg-plist
index e7bb739efb2..b8153cdcb28 100644
--- a/x11-fonts/XFree86-4-font75dpi/pkg-plist
+++ b/x11-fonts/XFree86-4-font75dpi/pkg-plist
@@ -1896,4 +1896,8 @@ lib/X11/fonts/75dpi/timR24-ISO8859-3.pcf.gz
lib/X11/fonts/75dpi/timR24-ISO8859-4.pcf.gz
lib/X11/fonts/75dpi/timR24-ISO8859-9.pcf.gz
lib/X11/fonts/75dpi/timR24.pcf.gz
+@exec command fc-cache -v %D/lib/X11/fonts/75dpi 2>/dev/null || true
+@unexec rm %D/lib/X11/fonts/75dpi/fonts.cache-1 2>/dev/null || true
+@unexec command fc-cache -v %D/lib/X11/fonts/75dpi 2>/dev/null || true
+@unexec if [ -e %D/lib/X11/fonts/75dpi/fonts.cache-1 -a ! -s %D/lib/X11/fonts/75dpi/fonts.cache-1 ]; then rm %D/lib/X11/fonts/75dpi/fonts.cache-1; fi
@dirrmtry lib/X11/fonts/75dpi
diff --git a/x11-fonts/XFree86-4-fontCyrillic/Makefile b/x11-fonts/XFree86-4-fontCyrillic/Makefile
index 23747d3ec75..34c545c1748 100644
--- a/x11-fonts/XFree86-4-fontCyrillic/Makefile
+++ b/x11-fonts/XFree86-4-fontCyrillic/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fontCyrillic
PORTVERSION= 4.5.0
+PORTREVISION= 1
CATEGORIES= x11-fonts
MASTER_SITES= ${MASTER_SITE_XFREE}
MASTER_SITE_SUBDIR= ${PORTVERSION}
@@ -44,6 +45,9 @@ pre-build:
(cd ${WRKDIR}/xc/fonts/encodings && \
${MAKE} all)
+post-install:
+ @command fc-cache -v ${PREFIX}/lib/X11/fonts/cyrillic || true
+
.include <bsd.port.pre.mk>
.if ${X_WINDOW_SYSTEM:L} != xfree86-4
IGNORE= is part of XFree86 and you have ${X_WINDOW_SYSTEM} set for X11\
diff --git a/x11-fonts/XFree86-4-fontCyrillic/pkg-plist b/x11-fonts/XFree86-4-fontCyrillic/pkg-plist
index b76ad7fdb12..420ee72f398 100644
--- a/x11-fonts/XFree86-4-fontCyrillic/pkg-plist
+++ b/x11-fonts/XFree86-4-fontCyrillic/pkg-plist
@@ -84,4 +84,8 @@ lib/X11/fonts/cyrillic/koinil2.pcf.gz
lib/X11/fonts/cyrillic/proof9x16.pcf.gz
lib/X11/fonts/cyrillic/screen8x16.pcf.gz
lib/X11/fonts/cyrillic/screen8x16b.pcf.gz
+@exec command fc-cache -v %D/lib/X11/fonts/cyrillic 2>/dev/null || true
+@unexec rm %D/lib/X11/fonts/cyrillic/fonts.cache-1 2>/dev/null || true
+@unexec command fc-cache -v %D/lib/X11/fonts/cyrillic 2>/dev/null || true
+@unexec if [ -e %D/lib/X11/fonts/cyrillic/fonts.cache-1 -a ! -s %D/lib/X11/fonts/cyrillic/fonts.cache-1 ]; then rm %D/lib/X11/fonts/cyrillic/fonts.cache-1; fi
@dirrmtry lib/X11/fonts/cyrillic
diff --git a/x11-fonts/XFree86-4-fontDefaultBitmaps/Makefile b/x11-fonts/XFree86-4-fontDefaultBitmaps/Makefile
index 0a62b96dda2..bf4638defec 100644
--- a/x11-fonts/XFree86-4-fontDefaultBitmaps/Makefile
+++ b/x11-fonts/XFree86-4-fontDefaultBitmaps/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fontDefaultBitmaps
PORTVERSION= 4.5.0
+PORTREVISION= 1
CATEGORIES= x11-fonts
MASTER_SITES= ${MASTER_SITE_XFREE}
MASTER_SITE_SUBDIR= ${PORTVERSION}
@@ -52,6 +53,9 @@ pre-build:
(cd ${WRKDIR}/xc/fonts/encodings && \
${MAKE} all)
+post-install:
+ @command fc-cache -v ${PREFIX}/lib/X11/fonts/cyrillic || true
+
.include <bsd.port.pre.mk>
.if ${X_WINDOW_SYSTEM:L} != xfree86-4
IGNORE= is part of XFree86 and you have ${X_WINDOW_SYSTEM} set for X11\
diff --git a/x11-fonts/XFree86-4-fontDefaultBitmaps/pkg-plist b/x11-fonts/XFree86-4-fontDefaultBitmaps/pkg-plist
index 6469a26932f..1f4cf008082 100644
--- a/x11-fonts/XFree86-4-fontDefaultBitmaps/pkg-plist
+++ b/x11-fonts/XFree86-4-fontDefaultBitmaps/pkg-plist
@@ -411,4 +411,8 @@ lib/X11/fonts/misc/olgl10.pcf.gz
lib/X11/fonts/misc/olgl12.pcf.gz
lib/X11/fonts/misc/olgl14.pcf.gz
lib/X11/fonts/misc/olgl19.pcf.gz
+@exec command fc-cache -v %D/lib/X11/fonts/misc 2>/dev/null || true
+@unexec rm %D/lib/X11/fonts/misc/fonts.cache-1 2>/dev/null || true
+@unexec command fc-cache -v %D/lib/X11/fonts/misc 2>/dev/null || true
+@unexec if [ -e %D/lib/X11/fonts/misc/fonts.cache-1 -a ! -s %D/lib/X11/fonts/misc/fonts.cache-1 ]; then rm %D/lib/X11/fonts/misc/fonts.cache-1; fi
@dirrmtry lib/X11/fonts/misc
diff --git a/x11-fonts/XFree86-4-fontScalable/Makefile b/x11-fonts/XFree86-4-fontScalable/Makefile
index 0ec04ab7186..07944ef57e2 100644
--- a/x11-fonts/XFree86-4-fontScalable/Makefile
+++ b/x11-fonts/XFree86-4-fontScalable/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fontScalable
PORTVERSION= 4.5.0
+PORTREVISION= 1
CATEGORIES= x11-fonts
MASTER_SITES= ${MASTER_SITE_XFREE}
MASTER_SITE_SUBDIR= ${PORTVERSION}
@@ -91,6 +92,12 @@ pre-build:
(cd ${WRKDIR}/xc/fonts/encodings && \
${MAKE} all)
+post-install:
+ @command fc-cache -v ${PREFIX}/lib/X11/fonts/CID || true
+ @command fc-cache -v ${PREFIX}/lib/X11/fonts/Speedo || true
+ @command fc-cache -v ${PREFIX}/lib/X11/fonts/TTF || true
+ @command fc-cache -v ${PREFIX}/lib/X11/fonts/Type1 || true
+
.include <bsd.port.pre.mk>
.if ${X_WINDOW_SYSTEM:L} != xfree86-4
IGNORE= is part of XFree86 and you have ${X_WINDOW_SYSTEM} set for X11\
diff --git a/x11-fonts/XFree86-4-fontScalable/pkg-plist b/x11-fonts/XFree86-4-fontScalable/pkg-plist
index 53eb3b6b8d2..32c1b31fc7a 100644
--- a/x11-fonts/XFree86-4-fontScalable/pkg-plist
+++ b/x11-fonts/XFree86-4-fontScalable/pkg-plist
@@ -86,8 +86,22 @@
%%TYPE1:%%lib/X11/fonts/Type1/l049033t.pfa
%%TYPE1:%%lib/X11/fonts/Type1/l049036t.afm
%%TYPE1:%%lib/X11/fonts/Type1/l049036t.pfa
+@exec command fc-cache -v %D/lib/X11/fonts/CID || true
+@exec command fc-cache -v %D/lib/X11/fonts/Speedo || true
+@exec command fc-cache -v %D/lib/X11/fonts/TTF || true
+@exec command fc-cache -v %D/lib/X11/fonts/Type1 || true
+@unexec rm %D/lib/X11/fonts/CID/fonts.cache-1 2>/dev/null || true
+@unexec rm %D/lib/X11/fonts/Speedo/fonts.cache-1 2>/dev/null || true
@unexec rm %D/lib/X11/fonts/TTF/fonts.cache-1 2>/dev/null || true
@unexec rm %D/lib/X11/fonts/Type1/fonts.cache-1 2>/dev/null || true
+@unexec command fc-cache -v %D/lib/X11/fonts/CID || true
+@unexec command fc-cache -v %D/lib/X11/fonts/Speedo || true
+@unexec command fc-cache -v %D/lib/X11/fonts/TTF || true
+@unexec command fc-cache -v %D/lib/X11/fonts/Type1 || true
+@unexec if [ -e %D/lib/X11/fonts/CID/fonts.cache-1 -a ! -s %D/lib/X11/fonts/CID/fonts.cache-1 ]; then rm %D/lib/X11/fonts/CID/fonts.cache-1; fi
+@unexec if [ -e %D/lib/X11/fonts/Speedo/fonts.cache-1 -a ! -s %D/lib/X11/fonts/Speedo/fonts.cache-1 ]; then rm %D/lib/X11/fonts/Speedo/fonts.cache-1; fi
+@unexec if [ -e %D/lib/X11/fonts/TTF/fonts.cache-1 -a ! -s %D/lib/X11/fonts/TTF/fonts.cache-1 ]; then rm %D/lib/X11/fonts/TTF/fonts.cache-1; fi
+@unexec if [ -e %D/lib/X11/fonts/Type1/fonts.cache-1 -a ! -s %D/lib/X11/fonts/Type1/fonts.cache-1 ]; then rm %D/lib/X11/fonts/Type1/fonts.cache-1; fi
@dirrmtry lib/X11/fonts/Speedo
@dirrmtry lib/X11/fonts/Type1
@dirrmtry lib/X11/fonts/CID