aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoranders <anders@FreeBSD.org>2001-11-22 08:10:56 +0800
committeranders <anders@FreeBSD.org>2001-11-22 08:10:56 +0800
commit812516aa0f8d50e2ed2c9284bb9701ef0b0fe96f (patch)
tree94ef7a9a52a9a9203a7c5fda0ea98c0ad35248cc
parentcb991af7dd07cfb651ac42c965fd1b6c2a861cb1 (diff)
downloadfreebsd-ports-graphics-812516aa0f8d50e2ed2c9284bb9701ef0b0fe96f.tar.gz
freebsd-ports-graphics-812516aa0f8d50e2ed2c9284bb9701ef0b0fe96f.tar.zst
freebsd-ports-graphics-812516aa0f8d50e2ed2c9284bb9701ef0b0fe96f.zip
Update thttpd to 2.22beta4. This fixes the recently announced off-by-one
security issue, and eliminates the need for the kqueue -current fix.
-rw-r--r--www/thttpd/Makefile5
-rw-r--r--www/thttpd/distinfo2
-rw-r--r--www/thttpd/files/patch-fdwatch.c12
3 files changed, 4 insertions, 15 deletions
diff --git a/www/thttpd/Makefile b/www/thttpd/Makefile
index db29b939e53..9cef4692b30 100644
--- a/www/thttpd/Makefile
+++ b/www/thttpd/Makefile
@@ -6,14 +6,15 @@
#
PORTNAME= thttpd
-PORTVERSION= 2.21b
+PORTVERSION= 2.22
CATEGORIES= www ipv6
MASTER_SITES= http://www.acme.com/software/thttpd/ \
http://www.freenix.no/~anders/
+DISTNAME= ${PORTNAME}-${PORTVERSION}beta4
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} notes.html
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= anders@FreeBSD.org
IGNOREFILES= notes.html
diff --git a/www/thttpd/distinfo b/www/thttpd/distinfo
index 4b6fff2146a..dc5777bc8f5 100644
--- a/www/thttpd/distinfo
+++ b/www/thttpd/distinfo
@@ -1,2 +1,2 @@
-MD5 (thttpd-2.21b.tar.gz) = 0041d478af3ab838fae2c1c2a3288c85
+MD5 (thttpd-2.22beta4.tar.gz) = 1124aa13ab57e4939ed94f6a0f8e08ae
MD5 (notes.html) = IGNORE
diff --git a/www/thttpd/files/patch-fdwatch.c b/www/thttpd/files/patch-fdwatch.c
deleted file mode 100644
index 7e5b9182372..00000000000
--- a/www/thttpd/files/patch-fdwatch.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- fdwatch.c.orig Fri Aug 24 00:19:39 2001
-+++ fdwatch.c Fri Aug 24 00:20:30 2001
-@@ -311,6 +311,9 @@
- if ( kqchanges == (struct kevent*) 0 || kqevents == (struct kevent*) 0 ||
- kqrfdidx == (int*) 0 )
- return -1;
-+ memset(kqchanges, '\0', sizeof(struct kevent) * 2 * nfiles);
-+ memset(kqevents, '\0', sizeof(struct kevent) * nfiles);
-+ memset(kqrfdidx, '\0', sizeof(int) * nfiles);
- return 0;
- }
-