aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-12-16 14:53:18 +0800
committersobomax <sobomax@FreeBSD.org>2001-12-16 14:53:18 +0800
commit82176784998924dc45c6a3625165d5ecf7a64c96 (patch)
tree0a3475629f7584cd97c84f9b5ce8bfdaafab18fd
parente6882a6083aac54f9a3aa507c0edeec170286148 (diff)
downloadfreebsd-ports-graphics-82176784998924dc45c6a3625165d5ecf7a64c96.tar.gz
freebsd-ports-graphics-82176784998924dc45c6a3625165d5ecf7a64c96.tar.zst
freebsd-ports-graphics-82176784998924dc45c6a3625165d5ecf7a64c96.zip
When building package forcefully turn optional GNOME components on, otherwise
gnome and gnome-fifth-toe packages contain incorrect dependencies list.
-rw-r--r--graphics/dia/Makefile3
-rw-r--r--x11-toolkits/rep-gtk/Makefile3
-rw-r--r--x11-toolkits/rep-gtk2/Makefile3
-rw-r--r--x11-wm/sawfish/Makefile3
-rw-r--r--x11-wm/sawfish2/Makefile3
5 files changed, 10 insertions, 5 deletions
diff --git a/graphics/dia/Makefile b/graphics/dia/Makefile
index a83294e9259..4675a036a72 100644
--- a/graphics/dia/Makefile
+++ b/graphics/dia/Makefile
@@ -28,7 +28,8 @@ MAN1= dia.1
.include <bsd.port.pre.mk>
-.if exists(${X11BASE}/bin/panel) || defined(WITH_GNOME)
+.if exists(${X11BASE}/bin/panel) || defined(WITH_GNOME) || defined(PACKAGE_BUILDING)
+.undef WITHOUT_GNOME
USE_GNOME= yes
PKGNAMESUFFIX= -gnome
CONFIGURE_ARGS= --enable-gnome \
diff --git a/x11-toolkits/rep-gtk/Makefile b/x11-toolkits/rep-gtk/Makefile
index 673b5240675..f01992c042c 100644
--- a/x11-toolkits/rep-gtk/Makefile
+++ b/x11-toolkits/rep-gtk/Makefile
@@ -29,7 +29,8 @@ CONFIGURE_TARGET= ${ARCH}-pc-freebsd${OSREL:C/\..*//}
.include <bsd.port.pre.mk>
-.if defined(HAVE_GNOME)
+.if defined(HAVE_GNOME) || defined(PACKAGE_BUILDING)
+.undef WITHOUT_GNOME
USE_GNOME= yes
CONFIGURE_ARGS= --with-gnome --with-libglade --with-gdk-pixbuf \
--with-gnome-canvas-pixbuf
diff --git a/x11-toolkits/rep-gtk2/Makefile b/x11-toolkits/rep-gtk2/Makefile
index 673b5240675..f01992c042c 100644
--- a/x11-toolkits/rep-gtk2/Makefile
+++ b/x11-toolkits/rep-gtk2/Makefile
@@ -29,7 +29,8 @@ CONFIGURE_TARGET= ${ARCH}-pc-freebsd${OSREL:C/\..*//}
.include <bsd.port.pre.mk>
-.if defined(HAVE_GNOME)
+.if defined(HAVE_GNOME) || defined(PACKAGE_BUILDING)
+.undef WITHOUT_GNOME
USE_GNOME= yes
CONFIGURE_ARGS= --with-gnome --with-libglade --with-gdk-pixbuf \
--with-gnome-canvas-pixbuf
diff --git a/x11-wm/sawfish/Makefile b/x11-wm/sawfish/Makefile
index 4b1ccd2b770..b8d81c277e2 100644
--- a/x11-wm/sawfish/Makefile
+++ b/x11-wm/sawfish/Makefile
@@ -34,7 +34,8 @@ CONFIGURE_TARGET= ${ARCH}-pc-freebsd${OSREL:C/\..*//}
.include <bsd.port.pre.mk>
-.if defined(HAVE_GNOME)
+.if defined(HAVE_GNOME) || defined(PACKAGE_BUILDING)
+.undef WITHOUT_GNOME
USE_GNOME= yes
CONFIGURE_ARGS+=--enable-capplet
PLIST_SUB+= GNOME:=""
diff --git a/x11-wm/sawfish2/Makefile b/x11-wm/sawfish2/Makefile
index 4b1ccd2b770..b8d81c277e2 100644
--- a/x11-wm/sawfish2/Makefile
+++ b/x11-wm/sawfish2/Makefile
@@ -34,7 +34,8 @@ CONFIGURE_TARGET= ${ARCH}-pc-freebsd${OSREL:C/\..*//}
.include <bsd.port.pre.mk>
-.if defined(HAVE_GNOME)
+.if defined(HAVE_GNOME) || defined(PACKAGE_BUILDING)
+.undef WITHOUT_GNOME
USE_GNOME= yes
CONFIGURE_ARGS+=--enable-capplet
PLIST_SUB+= GNOME:=""