aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorfluffy <fluffy@FreeBSD.org>2010-09-24 20:07:37 +0800
committerfluffy <fluffy@FreeBSD.org>2010-09-24 20:07:37 +0800
commit84301bcc0dbc045db2e752d2d21d4e365e26998b (patch)
treee96a6b0f619745056b1b82781e71f31adb9d4d6e
parent2d2ec0cc7e8c7d5bdb05bb897ea1dfff4eb5cb31 (diff)
downloadfreebsd-ports-graphics-84301bcc0dbc045db2e752d2d21d4e365e26998b.tar.gz
freebsd-ports-graphics-84301bcc0dbc045db2e752d2d21d4e365e26998b.tar.zst
freebsd-ports-graphics-84301bcc0dbc045db2e752d2d21d4e365e26998b.zip
- Add dependency on kwebkitpart
- Don't mess with FindQJson.cmake, it's handled by devel/qjson port Note to everyone: please reinstall devel/jqson after finishing choqok upgrade to restore FindQJson.cmake
-rw-r--r--www/choqok/Makefile6
-rw-r--r--www/choqok/files/patch-cmake__modules__CMakeLists.txt9
2 files changed, 13 insertions, 2 deletions
diff --git a/www/choqok/Makefile b/www/choqok/Makefile
index 952c715c997..f294608ad58 100644
--- a/www/choqok/Makefile
+++ b/www/choqok/Makefile
@@ -7,7 +7,7 @@
PORTNAME= choqok
PORTVERSION= 0.9.90
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www kde
MASTER_SITES= http://d10xg45o6p6dbl.cloudfront.net/projects/c/choqok/
@@ -16,8 +16,10 @@ COMMENT= KDE micro-blogging client
LICENSE= GPLv3
+BUILD_DEPENDS= ${LOCALBASE}/share/xml/docbook/4.2/docbookx.dtd:${PORTSDIR}/textproc/docbook-xml
LIB_DEPENDS= qjson.0:${PORTSDIR}/devel/qjson \
- qoauth.1:${PORTSDIR}/net/qoauth
+ qoauth.1:${PORTSDIR}/net/qoauth \
+ kwebkit.1:${PORTSDIR}/www/kwebkitpart
USE_BZIP2= yes
USE_CMAKE= yes
diff --git a/www/choqok/files/patch-cmake__modules__CMakeLists.txt b/www/choqok/files/patch-cmake__modules__CMakeLists.txt
new file mode 100644
index 00000000000..47341e257db
--- /dev/null
+++ b/www/choqok/files/patch-cmake__modules__CMakeLists.txt
@@ -0,0 +1,9 @@
+--- ./cmake/modules/CMakeLists.txt.orig 2010-08-15 16:22:32.000000000 +0400
++++ ./cmake/modules/CMakeLists.txt 2010-08-21 02:07:15.958529747 +0400
+@@ -1,4 +1,4 @@
+ # install the cmake files
+
+-set(cmakeFiles FindChoqok.cmake FindQJson.cmake FindQtOAuth.cmake)
++set(cmakeFiles FindChoqok.cmake FindQtOAuth.cmake)
+ install( FILES ${cmakeFiles} DESTINATION ${DATA_INSTALL_DIR}/cmake/modules )
+\ No newline at end of file