aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2004-03-18 23:25:14 +0800
committerume <ume@FreeBSD.org>2004-03-18 23:25:14 +0800
commit8434c28450e0c8205d9b16497509385a3a0f8187 (patch)
tree8f624acf7e6c3d11b3ae1d8ad3a36310c0541868
parent9b62ea5a16f04b596a5c30bb4402dd54c37aa1f6 (diff)
downloadfreebsd-ports-graphics-8434c28450e0c8205d9b16497509385a3a0f8187.tar.gz
freebsd-ports-graphics-8434c28450e0c8205d9b16497509385a3a0f8187.tar.zst
freebsd-ports-graphics-8434c28450e0c8205d9b16497509385a3a0f8187.zip
Don't allow enabling MySQL or PGSQL implicitly.
Submitted by: nork
-rw-r--r--security/cyrus-sasl2/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index 196a5887f9c..42cec3bda0f 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -86,12 +86,16 @@ WANT_MYSQL_VER= 323
.if defined(WITH_MYSQL)
USE_MYSQL= YES
CONFIGURE_ARGS+=--with-mysql=${PREFIX}
+.else
+CONFIGURE_ARGS+=--without-mysql
.endif
.if defined(WITH_PGSQL)
POSTGRESQL_PORT?= databases/postgresql-client
LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
CONFIGURE_ARGS+=--with-pgsql=${PREFIX}
+.else
+CONFIGURE_ARGS+=--without-pgsql
.endif
.if defined(WITH_MYSQL) || defined(WITH_PGSQL)