aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-05-18 19:48:21 +0800
committerkris <kris@FreeBSD.org>2003-05-18 19:48:21 +0800
commit847fff39451bfce3fc1971c4007073296f7221f2 (patch)
tree511f81ef4dac31ae22a43884c5fb3fc508ab3562
parent3ddaf469382eaedeb2ac17057914ea4839e31db6 (diff)
downloadfreebsd-ports-graphics-847fff39451bfce3fc1971c4007073296f7221f2.tar.gz
freebsd-ports-graphics-847fff39451bfce3fc1971c4007073296f7221f2.tar.zst
freebsd-ports-graphics-847fff39451bfce3fc1971c4007073296f7221f2.zip
BROKEN on 5.1: does not compile
-rw-r--r--devel/gcvs/Makefile8
-rw-r--r--editors/nvi-devel/Makefile8
-rw-r--r--editors/nvi-perl/Makefile4
-rw-r--r--editors/vigor/Makefile8
-rw-r--r--graphics/cqcam/Makefile8
-rw-r--r--graphics/rayshade/Makefile8
-rw-r--r--graphics/xglurbules/Makefile8
-rw-r--r--lang/gcc30/Makefile4
-rw-r--r--lang/moscow_ml/Makefile8
-rw-r--r--math/R-letter/Makefile8
-rw-r--r--math/R-project/Makefile8
-rw-r--r--math/R/Makefile8
-rw-r--r--multimedia/dvdauthor/Makefile8
-rw-r--r--net/netdude/Makefile4
-rw-r--r--sysutils/xperfmon3/Makefile8
-rw-r--r--sysutils/xsysinfo/Makefile8
-rw-r--r--x11/XFree86-aoutlibs/Makefile4
-rw-r--r--x11/rxvt-devel/Makefile8
18 files changed, 114 insertions, 14 deletions
diff --git a/devel/gcvs/Makefile b/devel/gcvs/Makefile
index 74b38e285f3..0df1994ad96 100644
--- a/devel/gcvs/Makefile
+++ b/devel/gcvs/Makefile
@@ -22,6 +22,12 @@ BUILD_DEPENDS+= glade:${PORTSDIR}/devel/glade
BUILD_DEPENDS+= wish8.3:${PORTSDIR}/x11-toolkits/tk83
RUN_DEPENDS+= wish8.3:${PORTSDIR}/x11-toolkits/tk83
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
USE_X_PREFIX= yes
USE_GNOME= gtk12
GNU_CONFIGURE= yes
@@ -38,4 +44,4 @@ MAN8= cvsbug.8
#USE_AUTOMAKE_VER= 14
#USE_AUTOCONF_VER= 213
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/editors/nvi-devel/Makefile b/editors/nvi-devel/Makefile
index d0f1736dc8c..6fd4b401f58 100644
--- a/editors/nvi-devel/Makefile
+++ b/editors/nvi-devel/Makefile
@@ -19,6 +19,12 @@ COMMENT= Development snapshot of the world-renown nvi editor
BUILD_DEPENDS= iconv:${PORTSDIR}/converters/libiconv
LIB_DEPENDS= db3.3:${PORTSDIR}/databases/db3
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
USE_BZIP2= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/build.unix
GNU_CONFIGURE= yes
@@ -39,4 +45,4 @@ post-install:
${RM} ${PREFIX}/man/cat1/${__p}.0
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/editors/nvi-perl/Makefile b/editors/nvi-perl/Makefile
index 02dab9ef0da..dcfa5e84531 100644
--- a/editors/nvi-perl/Makefile
+++ b/editors/nvi-perl/Makefile
@@ -18,6 +18,10 @@ COMMENT= A clone of vi/ex, with perl5 linked into
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
# can't say PATCH_DIST_STRIP=-p1 because contains files outside ${WRKSRC}
PATCH_DIST_ARGS=-d ${WRKSRC}/.. --forward --quiet -E -p0
PATCH_ARGS= -d ${WRKSRC}/.. --forward --quiet -E -p0
diff --git a/editors/vigor/Makefile b/editors/vigor/Makefile
index 61a5b262864..3ec6d429369 100644
--- a/editors/vigor/Makefile
+++ b/editors/vigor/Makefile
@@ -17,6 +17,12 @@ COMMENT= A vi clone inspired by the userfriendly comic strip
LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82 \
tcl82.1:${PORTSDIR}/lang/tcl82
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--program-transform-name="s,0,1,"
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
@@ -31,4 +37,4 @@ post-patch:
-e 's#-ltk#-ltk82#g' \
< ${WRKSRC}/configure.orig > ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/cqcam/Makefile b/graphics/cqcam/Makefile
index 2e090d44cfb..ea121b53e80 100644
--- a/graphics/cqcam/Makefile
+++ b/graphics/cqcam/Makefile
@@ -16,6 +16,12 @@ COMMENT= Color Quickcam control program
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
ONLY_FOR_ARCHS= i386
USE_XLIB= yes
@@ -48,4 +54,4 @@ post-install:
.endif
@${SED} -e "s:/usr/local:${PREFIX}:" ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/rayshade/Makefile b/graphics/rayshade/Makefile
index 075079175db..c70520398a1 100644
--- a/graphics/rayshade/Makefile
+++ b/graphics/rayshade/Makefile
@@ -18,6 +18,12 @@ COMMENT= An extensible system for creating ray-traced images
BUILD_DEPENDS= $(LOCALBASE)/lib/librle.a:${PORTSDIR}/graphics/urt
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
CONFIGURE_ARGS+= < ${WRKDIR}/config.ans
@@ -38,4 +44,4 @@ do-install:
$(MKDIR) $(PREFIX)/share/examples/rayshade
$(INSTALL_DATA) $(WRKSRC)/Examples/* $(PREFIX)/share/examples/rayshade
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/xglurbules/Makefile b/graphics/xglurbules/Makefile
index 11072b59a66..2f0ef41f0bb 100644
--- a/graphics/xglurbules/Makefile
+++ b/graphics/xglurbules/Makefile
@@ -13,6 +13,12 @@ MASTER_SITES= http://www.pepcross.com/glurbules/
MAINTAINER= steve@pepcross.com
COMMENT= Burning particle system eye candy program thingy for X11
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
MAN1= xglurbules.1
USE_XLIB= yes
@@ -20,4 +26,4 @@ USE_X_PREFIX= yes
MANCOMPRESSED= yes
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/lang/gcc30/Makefile b/lang/gcc30/Makefile
index 6ac80a4666c..661db39a338 100644
--- a/lang/gcc30/Makefile
+++ b/lang/gcc30/Makefile
@@ -30,6 +30,10 @@ CONFIGURE_SCRIPT= ../${SRCDIR:C/${WRKDIR}//}/configure
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
.if ${PORTOBJFORMAT} == "elf"
CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
.else
diff --git a/lang/moscow_ml/Makefile b/lang/moscow_ml/Makefile
index e701cd5c043..e65cd73882a 100644
--- a/lang/moscow_ml/Makefile
+++ b/lang/moscow_ml/Makefile
@@ -18,6 +18,12 @@ COMMENT= Moscow ML, a lightweight implementation of Standard ML
LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
MOSMLHOME= $(PREFIX)/moscow_ml
ALL_TARGET= world MOSMLHOME=$(MOSMLHOME)
@@ -39,4 +45,4 @@ post-install:
if [ -f $${file} ]; then \
$(LN) -sf $${file} $(PREFIX)/bin; fi; done
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/R-letter/Makefile b/math/R-letter/Makefile
index 1b5a604292b..c550cf5e469 100644
--- a/math/R-letter/Makefile
+++ b/math/R-letter/Makefile
@@ -28,6 +28,12 @@ COMMENT= A language for statistical computing and graphics
LIB_DEPENDS= tcl84:${PORTSDIR}/lang/tcl84 \
tk84:${PORTSDIR}/x11-toolkits/tk84
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
GNU_CONFIGURE= yes
USE_XLIB= yes
USE_PERL5= yes
@@ -48,4 +54,4 @@ test check: build
fullcheck: build
@(cd ${WRKSRC}; make fullcheck)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/R-project/Makefile b/math/R-project/Makefile
index 1b5a604292b..c550cf5e469 100644
--- a/math/R-project/Makefile
+++ b/math/R-project/Makefile
@@ -28,6 +28,12 @@ COMMENT= A language for statistical computing and graphics
LIB_DEPENDS= tcl84:${PORTSDIR}/lang/tcl84 \
tk84:${PORTSDIR}/x11-toolkits/tk84
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
GNU_CONFIGURE= yes
USE_XLIB= yes
USE_PERL5= yes
@@ -48,4 +54,4 @@ test check: build
fullcheck: build
@(cd ${WRKSRC}; make fullcheck)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/R/Makefile b/math/R/Makefile
index 1b5a604292b..c550cf5e469 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -28,6 +28,12 @@ COMMENT= A language for statistical computing and graphics
LIB_DEPENDS= tcl84:${PORTSDIR}/lang/tcl84 \
tk84:${PORTSDIR}/x11-toolkits/tk84
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
GNU_CONFIGURE= yes
USE_XLIB= yes
USE_PERL5= yes
@@ -48,4 +54,4 @@ test check: build
fullcheck: build
@(cd ${WRKSRC}; make fullcheck)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/multimedia/dvdauthor/Makefile b/multimedia/dvdauthor/Makefile
index e3d471751ab..c06985dd7e1 100644
--- a/multimedia/dvdauthor/Makefile
+++ b/multimedia/dvdauthor/Makefile
@@ -17,6 +17,12 @@ COMMENT= Makes a DVD file structure from one or more MPEG2 streams
LIB_DEPENDS= dvdread.3:${PORTSDIR}/multimedia/libdvdread \
gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -26,4 +32,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/dvdauthor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/netdude/Makefile b/net/netdude/Makefile
index e2a6afb4a1b..f524a4a3c96 100644
--- a/net/netdude/Makefile
+++ b/net/netdude/Makefile
@@ -32,6 +32,10 @@ MAN1= netdude.1
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
.if ${OSVERSION} >= 500000
EXTRA_PATCHES= ${FILESDIR}/protocols-fddi::nd_fddi.h.patch
.endif
diff --git a/sysutils/xperfmon3/Makefile b/sysutils/xperfmon3/Makefile
index c9c003459e0..4c5982f74e1 100644
--- a/sysutils/xperfmon3/Makefile
+++ b/sysutils/xperfmon3/Makefile
@@ -17,9 +17,15 @@ EXTRACT_SUFX= v1.1.tar.Z
MAINTAINER= Lars.Koeller@Uni-Bielefeld.DE
COMMENT= Xperfmon++ : A graphical X11 system performance monitor
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
LATEST_LINK= xperfmon3
USE_IMAKE= yes
MAN1= xperfmon++.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/xsysinfo/Makefile b/sysutils/xsysinfo/Makefile
index 5cc436c182e..bc314c278c2 100644
--- a/sysutils/xsysinfo/Makefile
+++ b/sysutils/xsysinfo/Makefile
@@ -13,6 +13,12 @@ MASTER_SITES= ftp://freebsd.csie.nctu.edu.tw/pub/jdli/source/
MAINTAINER= jdli@csie.nctu.edu.tw
COMMENT= A system information display tool
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
USE_IMAKE= yes
MANCOMPRESSED= yes
MAN1= xsysinfo.1
@@ -25,4 +31,4 @@ pre-configure:
${SED} -e "s:-lkvm:-lkvm -ldevstat:" Imakefile.i1 > Imakefile ; \
fi
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/XFree86-aoutlibs/Makefile b/x11/XFree86-aoutlibs/Makefile
index 868a4e6362e..3b28e715d2f 100644
--- a/x11/XFree86-aoutlibs/Makefile
+++ b/x11/XFree86-aoutlibs/Makefile
@@ -22,6 +22,10 @@ USE_X_PREFIX= yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
pre-configure:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGREQ} ${PKGNAME} INSTALL
diff --git a/x11/rxvt-devel/Makefile b/x11/rxvt-devel/Makefile
index f8c30f57b63..773b224d67b 100644
--- a/x11/rxvt-devel/Makefile
+++ b/x11/rxvt-devel/Makefile
@@ -24,6 +24,12 @@ COMMENT= A low memory usage xterm replacement that supports color
BUILD_DEPENDS= libtool:${PORTSDIR}/devel/libtool
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
USE_X_PREFIX= yes
USE_XPM= yes
GNU_CONFIGURE= yes
@@ -128,4 +134,4 @@ post-patch:
post-install:
@${CHMOD} 4711 ${PREFIX}/bin/rxvt
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>