aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjkoshy <jkoshy@FreeBSD.org>2004-03-01 01:06:20 +0800
committerjkoshy <jkoshy@FreeBSD.org>2004-03-01 01:06:20 +0800
commit8565865fab17ed80c758b132ccad0bd8343628bd (patch)
tree6f63828447590860ad752bacb72d3348314b2467
parent0015d523c7def27d6307abfcc6348a4ae3b782b0 (diff)
downloadfreebsd-ports-graphics-8565865fab17ed80c758b132ccad0bd8343628bd.tar.gz
freebsd-ports-graphics-8565865fab17ed80c758b132ccad0bd8343628bd.tar.zst
freebsd-ports-graphics-8565865fab17ed80c758b132ccad0bd8343628bd.zip
Add a `WITH_PTHREAD' knob.
Submitted by: Peter Schultz <pmes@bis.midco.net>
-rw-r--r--graphics/xaos/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/graphics/xaos/Makefile b/graphics/xaos/Makefile
index aa176d2f285..2991f176c41 100644
--- a/graphics/xaos/Makefile
+++ b/graphics/xaos/Makefile
@@ -30,6 +30,12 @@ CONFIGURE_ENV= LDFLAGS=-L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-svga-driver=no
.endif
+.if defined(WITH_PTHREAD)
+CONFIGURE_ARGS+= --with-pthread=yes
+CONFIGURE_ENV+= LIBS="${PTHREAD_LIBS}" \
+ CFLAGS="${PTHREAD_CFLAGS} ${CFLAGS}"
+.endif
+
CFLAGS= -DHAVE_SYS_PARAM_H \
-I${PREFIX}/include \
-pipe -O6 -fstrength-reduce -ffast-math -fomit-frame-pointer\