aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-09-21 01:53:26 +0800
committermarino <marino@FreeBSD.org>2014-09-21 01:53:26 +0800
commit89088b39ad8e6242fabb3495ed303c1763e1a4e9 (patch)
tree6a8bfb36e9f6ea25847e65f5acf1ed2a51795eaa
parentd557164e9612146ecb7ca9cb86101b629b394279 (diff)
downloadfreebsd-ports-graphics-89088b39ad8e6242fabb3495ed303c1763e1a4e9.tar.gz
freebsd-ports-graphics-89088b39ad8e6242fabb3495ed303c1763e1a4e9.tar.zst
freebsd-ports-graphics-89088b39ad8e6242fabb3495ed303c1763e1a4e9.zip
www/spawn-fcgi: Add flag to set command_interpreter in RC script
PR: 192676 Submitted by: mitsuruike (gmail) Approved by: maintainer (rsimmons)
-rw-r--r--www/spawn-fcgi/Makefile1
-rw-r--r--www/spawn-fcgi/files/spawn-fcgi.in5
2 files changed, 6 insertions, 0 deletions
diff --git a/www/spawn-fcgi/Makefile b/www/spawn-fcgi/Makefile
index fa947e46e05..36e3f0edd6b 100644
--- a/www/spawn-fcgi/Makefile
+++ b/www/spawn-fcgi/Makefile
@@ -3,6 +3,7 @@
PORTNAME= spawn-fcgi
PORTVERSION= 1.6.4
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://download.lighttpd.net/spawn-fcgi/releases-1.6.x/
diff --git a/www/spawn-fcgi/files/spawn-fcgi.in b/www/spawn-fcgi/files/spawn-fcgi.in
index 75bd8939ab4..3aca90913d1 100644
--- a/www/spawn-fcgi/files/spawn-fcgi.in
+++ b/www/spawn-fcgi/files/spawn-fcgi.in
@@ -14,6 +14,7 @@
# spawn_fcgi_bindsocket
# spawn_fcgi_web_server_addrs
# spawn_fcgi_allowed_env
+# spawn_fcgi_command_interpreter
. /etc/rc.subr
@@ -50,6 +51,10 @@ else
_spawn_fcgi_chroot=""
fi
+if [ -n "${spawn_fcgi_command_interpreter}" ]; then
+ command_interpreter=${spawn_fcgi_command_interpreter}
+fi
+
command="/usr/local/bin/spawn-fcgi"
command_args="-u ${spawn_fcgi_username} -g ${spawn_fcgi_groupname} ${_spawn_fcgi_bind} ${_spawn_fcgi_chroot} -P ${spawn_fcgi_pidfile} -- ${spawn_fcgi_app} ${spawn_fcgi_app_args}"
pidfile=${spawn_fcgi_pidfile}