aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2003-10-17 15:46:55 +0800
committervanilla <vanilla@FreeBSD.org>2003-10-17 15:46:55 +0800
commit89743f302301eeff277ed16e14a23d32a82b58ab (patch)
tree9a33356f265dc2cef400dfdbfaf29eefeaa18856
parent7891ce66d36e92b3cc8cbb33af735bee7af7c856 (diff)
downloadfreebsd-ports-graphics-89743f302301eeff277ed16e14a23d32a82b58ab.tar.gz
freebsd-ports-graphics-89743f302301eeff277ed16e14a23d32a82b58ab.tar.zst
freebsd-ports-graphics-89743f302301eeff277ed16e14a23d32a82b58ab.zip
Add p5-RTF-Tokenizer 1.04, perl module for reading RTF files.
PR: 58046 Submitted by: clsung@dragon2.net
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-RTF-Tokenizer/Makefile22
-rw-r--r--textproc/p5-RTF-Tokenizer/distinfo1
-rw-r--r--textproc/p5-RTF-Tokenizer/pkg-descr13
-rw-r--r--textproc/p5-RTF-Tokenizer/pkg-plist7
5 files changed, 44 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 583e10d83c8..7ff310d575d 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -216,6 +216,7 @@
SUBDIR += p5-RDF-Core
SUBDIR += p5-RDF-Notation3
SUBDIR += p5-RDFStore
+ SUBDIR += p5-RTF-Tokenizer
SUBDIR += p5-RTF-Writer
SUBDIR += p5-Regex-PreSuf
SUBDIR += p5-Regexp-Common
diff --git a/textproc/p5-RTF-Tokenizer/Makefile b/textproc/p5-RTF-Tokenizer/Makefile
new file mode 100644
index 00000000000..cc9501416b7
--- /dev/null
+++ b/textproc/p5-RTF-Tokenizer/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: textproc/p5-RTF-Tokenizer
+# Date created: Oct 15th 2003
+# Whom: clsung@dragon2.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= RTF-Tokenizer
+PORTVERSION= 1.04
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= RTF
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@dragon2.net
+COMMENT= Perl module for reading RTF files
+
+PERL_CONFIGURE= yes
+
+MAN3= RTF::Tokenizer.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-RTF-Tokenizer/distinfo b/textproc/p5-RTF-Tokenizer/distinfo
new file mode 100644
index 00000000000..01d7f8bb767
--- /dev/null
+++ b/textproc/p5-RTF-Tokenizer/distinfo
@@ -0,0 +1 @@
+MD5 (RTF-Tokenizer-1.04.tar.gz) = a2a211374c638dec34ebbd8fda91be3c
diff --git a/textproc/p5-RTF-Tokenizer/pkg-descr b/textproc/p5-RTF-Tokenizer/pkg-descr
new file mode 100644
index 00000000000..f940f4e3a67
--- /dev/null
+++ b/textproc/p5-RTF-Tokenizer/pkg-descr
@@ -0,0 +1,13 @@
+ RTF::Tokenizer is an object-orientated low-level RTF reader. If
+you're looking to render RTF, or want a higher-level RTF processor,
+this is not the module for you - you want RTF::Reader. This is the
+sixth release of RTF::Tokenizer - it's faster, higher quality, and
+implements the RTF standard better than any previous release.
+
+ It's also philosophically a better module, and conforms more
+strictly to Object Orientated guidelines - it can be sub-classed
+and the interface is cleaner.
+
+--
+Peter Sergeant
+rtft@clueball.com
diff --git a/textproc/p5-RTF-Tokenizer/pkg-plist b/textproc/p5-RTF-Tokenizer/pkg-plist
new file mode 100644
index 00000000000..67ff59031f6
--- /dev/null
+++ b/textproc/p5-RTF-Tokenizer/pkg-plist
@@ -0,0 +1,7 @@
+bin/rtfdiff
+bin/rtfdump
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/RTF/Tokenizer/.packlist
+%%SITE_PERL%%/RTF/Tokenizer.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/RTF/Tokenizer
+@dirrm %%SITE_PERL%%/RTF
+@unexec rmdir %D/%%SITE_PERL%%/RTF 2>/dev/null || true