aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2010-12-15 06:49:47 +0800
committernork <nork@FreeBSD.org>2010-12-15 06:49:47 +0800
commit897454d9c7c53e65200f93abbed6fc253ebcefb0 (patch)
treed51604ea5c119e47b42d0c9e5c2aea9ebeb9393b
parentaea1fe7331c4ba3e613412b6301424f989b96066 (diff)
downloadfreebsd-ports-graphics-897454d9c7c53e65200f93abbed6fc253ebcefb0.tar.gz
freebsd-ports-graphics-897454d9c7c53e65200f93abbed6fc253ebcefb0.tar.zst
freebsd-ports-graphics-897454d9c7c53e65200f93abbed6fc253ebcefb0.zip
All cleanup done (PREFIX clean, permission clean), and bump PORTREVISION.
-rw-r--r--emulators/tpm-emulator/Makefile10
-rw-r--r--emulators/tpm-emulator/files/patch-CMakeLists.txt9
-rw-r--r--emulators/tpm-emulator/pkg-plist1
-rw-r--r--security/trousers/Makefile17
4 files changed, 27 insertions, 10 deletions
diff --git a/emulators/tpm-emulator/Makefile b/emulators/tpm-emulator/Makefile
index 8786332e580..a065d26c9b5 100644
--- a/emulators/tpm-emulator/Makefile
+++ b/emulators/tpm-emulator/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tpm-emulator
PORTVERSION= 0.7.1
+PORTREVISION= 1
CATEGORIES= emulators security
MASTER_SITES= BERLIOS/${PORTNAME}
DISTNAME= ${PORTNAME:S/-/_/}-${PORTVERSION}
@@ -47,4 +48,13 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
post-extract:
@${MKDIR} ${WRKSRC}/build
+post-install:
+ @${INSTALL} -d -o ${USERS} -g ${GROUPS} -m 0700 ${PREFIX}/var/lib/tpm
+ @${INSTALL} -d -o ${USERS} -g ${GROUPS} -m 0700 /var/run/tpm
+
+add-plist-post:
+ @${ECHO_CMD} "@cwd /" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec ${RMDIR} var/run/tpm 2>/dev/null || true" >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec ${INSTALL} -d -o ${USERS} -g ${GROUPS} -m 0700 var/run/tpm" >> ${TMPPLIST}
+
.include <bsd.port.mk>
diff --git a/emulators/tpm-emulator/files/patch-CMakeLists.txt b/emulators/tpm-emulator/files/patch-CMakeLists.txt
index 33f4b1b0ae1..076defe218f 100644
--- a/emulators/tpm-emulator/files/patch-CMakeLists.txt
+++ b/emulators/tpm-emulator/files/patch-CMakeLists.txt
@@ -1,6 +1,11 @@
--- CMakeLists.txt.orig 2010-07-06 06:21:20.000000000 +0900
-+++ CMakeLists.txt 2010-12-15 07:24:08.279834034 +0900
-@@ -36,7 +36,7 @@
++++ CMakeLists.txt 2010-12-15 07:33:54.234887143 +0900
+@@ -32,11 +32,11 @@
+ else()
+ set(TPM_LOG_FILE "/var/log/tpmd.log")
+ set(TPM_SOCKET_NAME "/var/run/tpm/tpmd_socket:0")
+-set(TPM_STORAGE_NAME "/var/lib/tpm/tpm_emulator-1_2_${${PROJECT_NAME}_VERSION_MAJOR}_${${PROJECT_NAME}_VERSION_MINOR}")
++set(TPM_STORAGE_NAME "$ENV{PREFIX}/var/lib/tpm/tpm_emulator-1_2_${${PROJECT_NAME}_VERSION_MAJOR}_${${PROJECT_NAME}_VERSION_MINOR}")
set(TPM_DEVICE_NAME "/dev/tpm")
endif()
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/config.h.in ${CMAKE_CURRENT_BINARY_DIR}/config.h)
diff --git a/emulators/tpm-emulator/pkg-plist b/emulators/tpm-emulator/pkg-plist
index 15185f639fe..1e106fbe20d 100644
--- a/emulators/tpm-emulator/pkg-plist
+++ b/emulators/tpm-emulator/pkg-plist
@@ -4,3 +4,4 @@ lib/libtddl.a
lib/libtddl.so
lib/libtddl.so.1
lib/libtddl.so.1.2.0.7
+@dirrmtry var/lib/tpm
diff --git a/security/trousers/Makefile b/security/trousers/Makefile
index 800f7051dcd..edfb90a6692 100644
--- a/security/trousers/Makefile
+++ b/security/trousers/Makefile
@@ -7,7 +7,7 @@
PORTNAME= trousers
PORTVERSION= 0.3.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
@@ -86,15 +86,16 @@ post-install:
${WRKSRC}/dist/tcsd.conf ${EXAMPLESDIR}/tcsd.conf
@[ -f ${PREFIX}/etc/tcsd.conf ] || \
${CP} -p ${EXAMPLESDIR}/tcsd.conf ${PREFIX}/etc/tcsd.conf
- @${INSTALL} -d -o root -g ${GROUPS} -m 0700 /var/run/tpm
- @${INSTALL} -d -o root -g ${GROUPS} -m 0700 /var/run/ima
- @${INSTALL} -d -o root -g ${GROUPS} -m 0700 ${PREFIX}/var/lib/tpm
+ @${INSTALL} -d -o ${USERS} -g ${GROUPS} -m 0700 /var/run/tpm
+ @${INSTALL} -d -o ${USERS} -g ${GROUPS} -m 0700 /var/run/ima
+ @${INSTALL} -d -o ${USERS} -g ${GROUPS} -m 0700 ${PREFIX}/var/lib/tpm
@${CAT} ${PKGMESSAGE}
add-plist-post:
- @${ECHO_CMD} "@unexec ${RMDIR} /var/run/tpm 2>/dev/null || true" >> ${TMPPLIST}
- @${ECHO_CMD} "@exec ${INSTALL} -d -o root -g ${GROUPS} -m 0700 /var/run/tpm" >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec ${RMDIR} /var/run/ima 2>/dev/null || true" >> ${TMPPLIST}
- @${ECHO_CMD} "@exec ${INSTALL} -d -o root -g ${GROUPS} -m 0700 /var/run/ima" >> ${TMPPLIST}
+ @${ECHO_CMD} "@cwd /" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec ${RMDIR} var/run/tpm 2>/dev/null || true" >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec ${INSTALL} -d -o ${USERS} -g ${GROUPS} -m 0700 var/run/tpm" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec ${RMDIR} var/run/ima 2>/dev/null || true" >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec ${INSTALL} -d -o ${USERS} -g ${GROUPS} -m 0700 var/run/ima" >> ${TMPPLIST}
.include <bsd.port.post.mk>