aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2008-02-17 22:12:28 +0800
committeritetcu <itetcu@FreeBSD.org>2008-02-17 22:12:28 +0800
commit8e242f05d809858dcf91ce61007efedf9949e46c (patch)
tree4b2cd68ae24a691c115bed9f9c8e6ed8ad0e9b73
parent941ce7a1f89bfdb37c44c52b4f94f148654d81f3 (diff)
downloadfreebsd-ports-graphics-8e242f05d809858dcf91ce61007efedf9949e46c.tar.gz
freebsd-ports-graphics-8e242f05d809858dcf91ce61007efedf9949e46c.tar.zst
freebsd-ports-graphics-8e242f05d809858dcf91ce61007efedf9949e46c.zip
This plugin will check and display users' mail quota status. Current and
maximum quota usage is displayed in easy-to-read graphical format. Optional warnings may also be displayed to users who are nearing their quota allocation when they log in (where the "Message Of The Day" would normally be displayed). This plugin is compatible with three types of mail quota systems: UNIX (filesystem), IMAP-based, and cPanel quotas. WWW: http://www.squirrelmail.org/plugin_view.php?id=237
-rw-r--r--mail/Makefile1
-rw-r--r--mail/squirrelmail-check_quota-plugin/Makefile82
-rw-r--r--mail/squirrelmail-check_quota-plugin/distinfo3
-rw-r--r--mail/squirrelmail-check_quota-plugin/files/pkg-message.in7
-rw-r--r--mail/squirrelmail-check_quota-plugin/pkg-descr9
-rw-r--r--mail/squirrelmail-check_quota-plugin/pkg-plist32
6 files changed, 134 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index eeef6dc20af..4cbd82af957 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -591,6 +591,7 @@
SUBDIR += squirrelmail-calendar_sql_backend-plugin
SUBDIR += squirrelmail-change_ldappass-plugin
SUBDIR += squirrelmail-change_sqlpass-plugin
+ SUBDIR += squirrelmail-check_quota-plugin
SUBDIR += squirrelmail-compatibility-plugin
SUBDIR += squirrelmail-compatibility-plugin1
SUBDIR += squirrelmail-devel
diff --git a/mail/squirrelmail-check_quota-plugin/Makefile b/mail/squirrelmail-check_quota-plugin/Makefile
new file mode 100644
index 00000000000..4cee5e0dca1
--- /dev/null
+++ b/mail/squirrelmail-check_quota-plugin/Makefile
@@ -0,0 +1,82 @@
+# New ports collection makefile for: squirrelmail-check_quota-plugin
+# Date created: 2008-02-16
+# Whom: Ion-Mihai "IOnut" Tetcu <itetcu@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= check-quota
+PORTVERSION= 2.2
+CATEGORIES= mail www
+MASTER_SITES= http://www.squirrelmail.org/plugins/
+PKGNAMEPREFIX= squirrelmail-
+PKGNAMESUFFIX= -plugin
+DISTNAME= ${PORTNAME:S/-/_/}-${PORTVERSION}-1.4.0
+DIST_SUBDIR= squirrelmail
+
+MAINTAINER= itetcu@FreeBSD.org
+COMMENT= Check/display users' mail quota (filesystem, IMAP-based and cPanel)
+
+RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
+ ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
+
+SQUIRREL_PLUGIN_NAME= ${PORTNAME:S/-/_/}
+
+.ifdef SQUIRRELDIR
+PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
+SUB_LIST+= SQUIRRELDIR=${SQUIRRELDIR}
+.else
+.ifndef WITHOUT_WWWDIR
+SQUIRRELDIR= ${PREFIX}/www/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
+SUB_LIST+= SQUIRRELDIR=www/squirrelmail
+.else
+SQUIRRELDIR= ${PREFIX}/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=squirrelmail
+SUB_LIST+= SQUIRRELDIR=squirrelmail
+.endif
+.endif
+PLIST_SUB+= SQUIRREL_PLUGIN_NAME=${SQUIRREL_PLUGIN_NAME}
+
+SUB_FILES+= pkg-message
+SUB_LIST+= SQUIRREL_PLUGIN_NAME=${SQUIRREL_PLUGIN_NAME}
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PERL5_BUILD= yes
+USE_PHP= yes
+WANT_PHP_WEB= yes
+
+.include <bsd.port.pre.mk>
+
+pre-everything::
+ @${ECHO} ""
+.ifndef WITHOUT_ACTIVATE
+ @${ECHO} "Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you don't want to automatically activate the plug-in set"
+ @${ECHO} "WITHOUT_ACTIVATE=yes"
+.else
+ @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you want to automatically activate the plug-in unset"
+ @${ECHO} "WITHOUT_ACTIVATE"
+.endif
+ @${ECHO} ""
+
+do-install:
+ ${CP} -R ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
+
+post-install:
+.ifndef WITHOUT_ACTIVATE
+.if exists( ${SQUIRRELDIR}/config/config.php )
+ @${ECHO} "Activating plug-in in SquirrelMail"
+ ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
+.endif
+.else
+ @${ECHO} "To activate the plug-in in SquirrelMail use"
+ @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
+.endif
+ @${ECHO} ""
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/mail/squirrelmail-check_quota-plugin/distinfo b/mail/squirrelmail-check_quota-plugin/distinfo
new file mode 100644
index 00000000000..e1b16adeb6e
--- /dev/null
+++ b/mail/squirrelmail-check_quota-plugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (squirrelmail/check_quota-2.2-1.4.0.tar.gz) = aa26b781559680ba91e7398c01e2f248
+SHA256 (squirrelmail/check_quota-2.2-1.4.0.tar.gz) = a3241a424fcfd6d14832653e66e279f19f33b4bee31c9920e591bc1f401e677d
+SIZE (squirrelmail/check_quota-2.2-1.4.0.tar.gz) = 41730
diff --git a/mail/squirrelmail-check_quota-plugin/files/pkg-message.in b/mail/squirrelmail-check_quota-plugin/files/pkg-message.in
new file mode 100644
index 00000000000..1a573547780
--- /dev/null
+++ b/mail/squirrelmail-check_quota-plugin/files/pkg-message.in
@@ -0,0 +1,7 @@
+================================================================
+For the port to work properly you must copy the file
+%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.sample.php
+to
+%%PREFIX%%/%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.php
+and edit the configuration to meet your needs.
+================================================================
diff --git a/mail/squirrelmail-check_quota-plugin/pkg-descr b/mail/squirrelmail-check_quota-plugin/pkg-descr
new file mode 100644
index 00000000000..28b4b4753f6
--- /dev/null
+++ b/mail/squirrelmail-check_quota-plugin/pkg-descr
@@ -0,0 +1,9 @@
+This plugin will check and display users' mail quota status. Current and
+maximum quota usage is displayed in easy-to-read graphical format. Optional
+warnings may also be displayed to users who are nearing their quota allocation
+when they log in (where the "Message Of The Day" would normally be displayed).
+
+This plugin is compatible with three types of mail quota systems:
+UNIX (filesystem), IMAP-based, and cPanel quotas.
+
+WWW: http://www.squirrelmail.org/plugin_view.php?id=237
diff --git a/mail/squirrelmail-check_quota-plugin/pkg-plist b/mail/squirrelmail-check_quota-plugin/pkg-plist
new file mode 100644
index 00000000000..07828d28a06
--- /dev/null
+++ b/mail/squirrelmail-check_quota-plugin/pkg-plist
@@ -0,0 +1,32 @@
+@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin %%SQUIRREL_PLUGIN_NAME%%; fi
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/CHANGELOG
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/FAQ
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/INSTALL
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/LICENSE
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/README
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/TRANSLATING
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/check_quota.pot
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/config.sample.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/functions.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/getpot
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/images/gd_bar.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/images/index.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/index.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/make_release.sh
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/setup.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/swf/bar.swf
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/swf/index.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/templates/default/graph.tpl
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/templates/default/horizontal_rule.tpl
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/templates/default/motd_alert.tpl
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/themes/default_theme.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/themes/index.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/troubleshoot.php
+%%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/version
+@dirrm %%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/images/
+@dirrm %%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/swf/
+@dirrm %%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/templates/default/
+@dirrm %%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/templates/
+@dirrm %%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%/themes/
+@dirrm %%SQUIRRELDIR%%/plugins/%%SQUIRREL_PLUGIN_NAME%%
+@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin %%SQUIRREL_PLUGIN_NAME%%; fi