aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-06-12 18:00:11 +0800
committerknu <knu@FreeBSD.org>2002-06-12 18:00:11 +0800
commit8f419a0183c2f302844d38c1ccb4244ba8d02ff4 (patch)
tree89782c3b1d77827460d6cd36165890e32c5b4a8c
parent145f33791527ed29456366803e0b97aa069764ff (diff)
downloadfreebsd-ports-graphics-8f419a0183c2f302844d38c1ccb4244ba8d02ff4.tar.gz
freebsd-ports-graphics-8f419a0183c2f302844d38c1ccb4244ba8d02ff4.tar.zst
freebsd-ports-graphics-8f419a0183c2f302844d38c1ccb4244ba8d02ff4.zip
Cope with a bug in CURRENT's bsd.*.mk infrastructure, that the
beforeinstall target is somehow executed _after_ the realinstall target.
-rw-r--r--ports-mgmt/portupgrade-devel/Makefile8
-rw-r--r--ports-mgmt/portupgrade/Makefile8
-rw-r--r--sysutils/portupgrade-devel/Makefile8
-rw-r--r--sysutils/portupgrade/Makefile8
4 files changed, 32 insertions, 0 deletions
diff --git a/ports-mgmt/portupgrade-devel/Makefile b/ports-mgmt/portupgrade-devel/Makefile
index 74e66937e11..fce5dd56c23 100644
--- a/ports-mgmt/portupgrade-devel/Makefile
+++ b/ports-mgmt/portupgrade-devel/Makefile
@@ -59,6 +59,14 @@ INSTALL_TARGET+= install-doc
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/features/ruby18/file.so:${PORTSDIR}/lang/ruby16-shim-ruby18
.endif
+pre-install:
+.if !defined(NOPORTDOCS)
+# Cope with a bug in CURRENT's bsd.*.mk infrastructure
+ ${MKDIR} ${PREFIX}/share/examples/pkgtools/bash
+ ${MKDIR} ${PREFIX}/share/examples/pkgtools/tcsh
+ ${MKDIR} ${PREFIX}/share/zsh/site-functions
+.endif
+
post-install:
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \
diff --git a/ports-mgmt/portupgrade/Makefile b/ports-mgmt/portupgrade/Makefile
index 74e66937e11..fce5dd56c23 100644
--- a/ports-mgmt/portupgrade/Makefile
+++ b/ports-mgmt/portupgrade/Makefile
@@ -59,6 +59,14 @@ INSTALL_TARGET+= install-doc
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/features/ruby18/file.so:${PORTSDIR}/lang/ruby16-shim-ruby18
.endif
+pre-install:
+.if !defined(NOPORTDOCS)
+# Cope with a bug in CURRENT's bsd.*.mk infrastructure
+ ${MKDIR} ${PREFIX}/share/examples/pkgtools/bash
+ ${MKDIR} ${PREFIX}/share/examples/pkgtools/tcsh
+ ${MKDIR} ${PREFIX}/share/zsh/site-functions
+.endif
+
post-install:
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \
diff --git a/sysutils/portupgrade-devel/Makefile b/sysutils/portupgrade-devel/Makefile
index 74e66937e11..fce5dd56c23 100644
--- a/sysutils/portupgrade-devel/Makefile
+++ b/sysutils/portupgrade-devel/Makefile
@@ -59,6 +59,14 @@ INSTALL_TARGET+= install-doc
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/features/ruby18/file.so:${PORTSDIR}/lang/ruby16-shim-ruby18
.endif
+pre-install:
+.if !defined(NOPORTDOCS)
+# Cope with a bug in CURRENT's bsd.*.mk infrastructure
+ ${MKDIR} ${PREFIX}/share/examples/pkgtools/bash
+ ${MKDIR} ${PREFIX}/share/examples/pkgtools/tcsh
+ ${MKDIR} ${PREFIX}/share/zsh/site-functions
+.endif
+
post-install:
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \
diff --git a/sysutils/portupgrade/Makefile b/sysutils/portupgrade/Makefile
index 74e66937e11..fce5dd56c23 100644
--- a/sysutils/portupgrade/Makefile
+++ b/sysutils/portupgrade/Makefile
@@ -59,6 +59,14 @@ INSTALL_TARGET+= install-doc
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/features/ruby18/file.so:${PORTSDIR}/lang/ruby16-shim-ruby18
.endif
+pre-install:
+.if !defined(NOPORTDOCS)
+# Cope with a bug in CURRENT's bsd.*.mk infrastructure
+ ${MKDIR} ${PREFIX}/share/examples/pkgtools/bash
+ ${MKDIR} ${PREFIX}/share/examples/pkgtools/tcsh
+ ${MKDIR} ${PREFIX}/share/zsh/site-functions
+.endif
+
post-install:
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \