aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-09-20 00:56:32 +0800
committerade <ade@FreeBSD.org>2000-09-20 00:56:32 +0800
commit905faef160c258a799cf4abd3c32c7c63a84a0f1 (patch)
treef8d052413116faf71873ac92f87dce61678e829d
parent483b40e7eebc07d20e70c7a17bb5b50f2e736797 (diff)
downloadfreebsd-ports-graphics-905faef160c258a799cf4abd3c32c7c63a84a0f1.tar.gz
freebsd-ports-graphics-905faef160c258a799cf4abd3c32c7c63a84a0f1.tar.zst
freebsd-ports-graphics-905faef160c258a799cf4abd3c32c7c63a84a0f1.zip
Add p5-Unicode-String, a perl5 module needed for writing CGI programs
with different national languages PR: 21164 Submitted by: Ilia Chipitsine <ilia@jane.cgu.chel.su>
-rw-r--r--converters/Makefile1
-rw-r--r--converters/p5-Unicode-String/Makefile28
-rw-r--r--converters/p5-Unicode-String/distinfo1
-rw-r--r--converters/p5-Unicode-String/pkg-comment1
-rw-r--r--converters/p5-Unicode-String/pkg-descr16
-rw-r--r--converters/p5-Unicode-String/pkg-plist8
6 files changed, 55 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index 9e5158412a2..f6f119b6f1c 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -22,6 +22,7 @@
SUBDIR += p5-Convert-Recode
SUBDIR += p5-Convert-UU
SUBDIR += p5-MIME-Base64
+ SUBDIR += p5-Unicode-String
SUBDIR += recode
SUBDIR += ruby-iconv
SUBDIR += tcs
diff --git a/converters/p5-Unicode-String/Makefile b/converters/p5-Unicode-String/Makefile
new file mode 100644
index 00000000000..54ee6c51069
--- /dev/null
+++ b/converters/p5-Unicode-String/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Unicode-String
+# Date created: 10th September 2000
+# Whom: Ilia Chipitsine <ilia@jane.cgu.chel.su>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Unicode-String
+PORTVERSION= 2.06
+CATEGORIES= converters perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Unicode
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ilia@cgu.chel.su
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+
+USE_PERL5= yes
+
+MAN3= Unicode::CharName.3 Unicode::String.3
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/converters/p5-Unicode-String/distinfo b/converters/p5-Unicode-String/distinfo
new file mode 100644
index 00000000000..15db56edebb
--- /dev/null
+++ b/converters/p5-Unicode-String/distinfo
@@ -0,0 +1 @@
+MD5 (Unicode-String-2.06.tar.gz) = faa22a6d9fadd52451e0c7da0e5aa8f5
diff --git a/converters/p5-Unicode-String/pkg-comment b/converters/p5-Unicode-String/pkg-comment
new file mode 100644
index 00000000000..e8056488749
--- /dev/null
+++ b/converters/p5-Unicode-String/pkg-comment
@@ -0,0 +1 @@
+These are experimental Perl5 modules to handle various Unicode issues
diff --git a/converters/p5-Unicode-String/pkg-descr b/converters/p5-Unicode-String/pkg-descr
new file mode 100644
index 00000000000..4dbca13dd85
--- /dev/null
+++ b/converters/p5-Unicode-String/pkg-descr
@@ -0,0 +1,16 @@
+These are experimental modules to handle various Unicode issues. They
+were made before perl included native UTF8 support.
+
+The current set of modules are:
+
+ Unicode::String - represent strings of Unicode chars
+ Unicode::CharName - look up character names
+ Unicode::Map8 - mapping tables towards 8-bit char sets
+
+(the Unicode::Map8 module is distributed separately)
+
+COPYRIGHT 1997-2000 Gisle Aas. All rights reserved.
+This library is free software; you can redistribute it and/or modify
+it under the same terms as Perl itself.
+
+WWW: http://www.unicode.org/
diff --git a/converters/p5-Unicode-String/pkg-plist b/converters/p5-Unicode-String/pkg-plist
new file mode 100644
index 00000000000..6d1e78a6530
--- /dev/null
+++ b/converters/p5-Unicode-String/pkg-plist
@@ -0,0 +1,8 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Unicode/CharName.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Unicode/String.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Unicode/String/String.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Unicode/String/String.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Unicode/String/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Unicode/String
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Unicode
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Unicode