aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-04-15 18:40:59 +0800
committerpawel <pawel@FreeBSD.org>2014-04-15 18:40:59 +0800
commit91b3246d8bb6622bf216d5249afc7a305c7b91f5 (patch)
treede3f97621b6088b12b66f8e893c3ae6f4d29effc
parentf463710983fe19374e715ec1dd5fdee2753dcba3 (diff)
downloadfreebsd-ports-graphics-91b3246d8bb6622bf216d5249afc7a305c7b91f5.tar.gz
freebsd-ports-graphics-91b3246d8bb6622bf216d5249afc7a305c7b91f5.tar.zst
freebsd-ports-graphics-91b3246d8bb6622bf216d5249afc7a305c7b91f5.zip
- Add staging support
- Convert to USES=tar:bzip2 - Remove Author tag from pkg-descr, info available on homepage
-rw-r--r--games/noegnud-data/Makefile3
-rw-r--r--games/noegnud-data/files/patch-variants::Makefile14
-rw-r--r--games/noegnud-data/pkg-descr1
-rw-r--r--games/noegnud-data/pkg-plist3
4 files changed, 9 insertions, 12 deletions
diff --git a/games/noegnud-data/Makefile b/games/noegnud-data/Makefile
index c41ac64d77b..b8178c25598 100644
--- a/games/noegnud-data/Makefile
+++ b/games/noegnud-data/Makefile
@@ -13,11 +13,10 @@ COMMENT= The noeGNUd Data Files
NOEGNUDVERSION= ${PORTNAME}-0.8.0
DATADIR= ${PREFIX}/share/${NOEGNUDVERSION}
-USE_BZIP2= yes
+USES= tar:bzip2
MAKE_ENV+= DATADIR="${DATADIR}"
WRKSRC= ${WRKDIR}/${DISTNAME}/variants
ALL_TARGET= data
INSTALL_TARGET= install_data
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/games/noegnud-data/files/patch-variants::Makefile b/games/noegnud-data/files/patch-variants::Makefile
index 3675e6cabf2..8d3c7d0515a 100644
--- a/games/noegnud-data/files/patch-variants::Makefile
+++ b/games/noegnud-data/files/patch-variants::Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Tue Sep 2 17:11:03 2003
-+++ Makefile Tue Jun 29 17:23:45 2004
+--- Makefile.orig 2004-08-23 19:13:51.000000000 +0200
++++ Makefile 2014-04-15 12:07:41.640211284 +0200
@@ -1,7 +1,6 @@
NOEGNUDVERSION=noegnud-0.8.0
# you __MUST__ change this if you change the prefix for any variants' install !!!!!!!!!!!!!
@@ -8,7 +8,7 @@
GAMEUID = games
GAMEGRP = bin
CHOWN = chown
-@@ -66,12 +65,12 @@
+@@ -94,12 +93,8 @@
@echo "no data creation scripts exists yet, it er, just, um, works (we hope ;)"
install_data: data
@@ -18,12 +18,8 @@
- $(CHGRP) $(GAMEGRP) $(PREFIX)/lib/$(NOEGNUDVERSION)/data
- $(CHOWN) -R $(GAMEUID) $(PREFIX)/lib/$(NOEGNUDVERSION)/data/*
- $(CHGRP) -R $(GAMEGRP) $(PREFIX)/lib/$(NOEGNUDVERSION)/data/*
-+ -mkdir -p ${DATADIR}
-+ cp -r ../data ${DATADIR}/.
-+ $(CHOWN) $(GAMEUID) ${DATADIR}/data
-+ $(CHGRP) $(GAMEGRP) ${DATADIR}/data
-+ $(CHOWN) -R $(GAMEUID) ${DATADIR}/data/*
-+ $(CHGRP) -R $(GAMEGRP) ${DATADIR}/data/*
++ -mkdir -p ${DESTDIR}${DATADIR}
++ cp -r ../data ${DESTDIR}${DATADIR}/.
# spawn Makefiles
diff --git a/games/noegnud-data/pkg-descr b/games/noegnud-data/pkg-descr
index 5aee5656f18..87f1da80839 100644
--- a/games/noegnud-data/pkg-descr
+++ b/games/noegnud-data/pkg-descr
@@ -6,5 +6,4 @@ and an outstanding 3D-Mode.
This port installs the noeGNUd data files.
-Author: Clive Crous
WWW: http://noegnud.sourceforge.net/
diff --git a/games/noegnud-data/pkg-plist b/games/noegnud-data/pkg-plist
index 43785eec718..5e9a56155e6 100644
--- a/games/noegnud-data/pkg-plist
+++ b/games/noegnud-data/pkg-plist
@@ -1,3 +1,5 @@
+@owner games
+@group bin
share/noegnud-0.8.0/data/char/DeeT.png
share/noegnud-0.8.0/data/char/anethack.png
share/noegnud-0.8.0/data/char/deco.png
@@ -1564,3 +1566,4 @@ share/noegnud-0.8.0/data/widgetthemes/wooden/wooden_window.theme
@dirrmtry share/noegnud-0.8.0/data/char
@dirrmtry share/noegnud-0.8.0/data
@dirrmtry share/noegnud-0.8.0
+@exec chown root:wheel %D/%%DATADIR%%