aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-07 17:02:45 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-07 17:02:45 +0800
commit93e72ab5e52ec1085bc7730923cd364b8a3e88c0 (patch)
treedc1a7895683fb1bd71bc7120de2b2eb53dd937e3
parentf84cab2c546d168047c5e2ed7469a97470203ea9 (diff)
downloadfreebsd-ports-graphics-93e72ab5e52ec1085bc7730923cd364b8a3e88c0.tar.gz
freebsd-ports-graphics-93e72ab5e52ec1085bc7730923cd364b8a3e88c0.tar.zst
freebsd-ports-graphics-93e72ab5e52ec1085bc7730923cd364b8a3e88c0.zip
- Support staging
- Use shebangfix - Convert to new options framework - Don't conditionalize installation of documentation as it is now handled by the new options framework
-rw-r--r--x11-fonts/p5-type1inst/Makefile34
1 files changed, 17 insertions, 17 deletions
diff --git a/x11-fonts/p5-type1inst/Makefile b/x11-fonts/p5-type1inst/Makefile
index 2084f1248f5..cf919d51606 100644
--- a/x11-fonts/p5-type1inst/Makefile
+++ b/x11-fonts/p5-type1inst/Makefile
@@ -12,28 +12,28 @@ PKGNAMEPREFIX= p5-
MAINTAINER= hrs@FreeBSD.org
COMMENT= A script that helps install Postscript fonts in X Window System
-.if !defined(WITHOUT_X11)
-RUN_DEPENDS= ${LOCALBASE}/bin/mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
- ${LOCALBASE}/bin/mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
-.endif
-
-USES= perl5
+USES= perl5 shebangfix
NO_BUILD= yes
PORTDOCS= README
-PLIST_FILES= bin/t1embed bin/type1inst
-MAN1= type1inst.1
+PLIST_FILES= bin/t1embed bin/type1inst man/man1/type1inst.1.gz
+SHEBANG_FILES= type1inst t1embed
+
+OPTIONS_DEFINE= DOCS X11
+OPTIONS_DEFAULT=X11
-NO_STAGE= yes
-pre-install:
- ${REINPLACE_CMD} 's,^#!/usr/bin/perl,#!${PERL},' ${WRKSRC}/type1inst
+X11_RUN_DEPENDS= ${LOCALBASE}/bin/mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
+ ${LOCALBASE}/bin/mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
+
+.include <bsd.port.options.mk>
do-install:
- @cd ${WRKSRC} && ${INSTALL_SCRIPT} type1inst t1embed ${PREFIX}/bin
- @${INSTALL_MAN} ${WRKSRC}/type1inst.man ${PREFIX}/man/man1/type1inst.1
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
+ cd ${WRKSRC} && ${INSTALL_SCRIPT} type1inst t1embed \
+ ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/type1inst.man \
+ ${STAGEDIR}${PREFIX}/man/man1/type1inst.1
+
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>