aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-07-24 01:40:38 +0800
committermarcus <marcus@FreeBSD.org>2006-07-24 01:40:38 +0800
commit9481e0ad60bd0b4ff33e00d8eb343f8164a9d535 (patch)
tree0e754d5991e434150da270e138661e00b824f565
parent7d6c10ecde8ba967c591e629655edd9a6126866b (diff)
downloadfreebsd-ports-graphics-9481e0ad60bd0b4ff33e00d8eb343f8164a9d535.tar.gz
freebsd-ports-graphics-9481e0ad60bd0b4ff33e00d8eb343f8164a9d535.tar.zst
freebsd-ports-graphics-9481e0ad60bd0b4ff33e00d8eb343f8164a9d535.zip
Add a dependency on libgcrypt if it is found. libgcrypt adds the ability
to decrypt IPSec packets. PR: 100645
-rw-r--r--net/wireshark/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index 89d3222afbf..0ce27ca772f 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -113,6 +113,11 @@ LIB_DEPENDS+= gnutls.13:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+=--with-libgnutls-prefix=${LOCALBASE}
.endif
+.if exists(${LOCALBASE}/lib/libgcrypt.so) || defined(WITH_LIBGCRYPT)
+LIB_DEPENDS+= gcrypt.13:${PORTSDIR}/security/libgcrypt
+CONFIGURE_ARGS+=--with-libgcrypt-prefix=${LOCALBASE}
+.endif
+
MAN1+= dumpcap.1 tshark.1
MAN4+= wireshark-filter.4