aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarkus <markus@FreeBSD.org>2004-06-06 19:46:15 +0800
committermarkus <markus@FreeBSD.org>2004-06-06 19:46:15 +0800
commit94a286c61446ee03d23e5bb159d50f1a45c4e85e (patch)
tree6e7652a2f4233c257a8e60a72ef1abfaebb1cb91
parent23cb378997cbf329482404acabd2719d5558dd06 (diff)
downloadfreebsd-ports-graphics-94a286c61446ee03d23e5bb159d50f1a45c4e85e.tar.gz
freebsd-ports-graphics-94a286c61446ee03d23e5bb159d50f1a45c4e85e.tar.zst
freebsd-ports-graphics-94a286c61446ee03d23e5bb159d50f1a45c4e85e.zip
Don't use Makefile.kde anymore
-rw-r--r--deskutils/krefty/Makefile8
-rw-r--r--graphics/kimagemapeditor/Makefile9
-rw-r--r--graphics/kimdaba/Makefile4
-rw-r--r--graphics/kolourpaint/Makefile4
-rw-r--r--graphics/kphotoalbum-kde4/Makefile4
-rw-r--r--graphics/kphotoalbum/Makefile4
-rw-r--r--irc/konversation-kde4/Makefile4
-rw-r--r--irc/konversation/Makefile4
-rw-r--r--lang/klogoturtle/Makefile8
-rw-r--r--sysutils/kkeyled/Makefile7
10 files changed, 21 insertions, 35 deletions
diff --git a/deskutils/krefty/Makefile b/deskutils/krefty/Makefile
index e44e0d04099..bd11536f754 100644
--- a/deskutils/krefty/Makefile
+++ b/deskutils/krefty/Makefile
@@ -16,16 +16,16 @@ COMMENT= Quick Reference sheets for KDE
USE_KDELIBS_VER=3
GNU_CONFIGURE= yes
USE_REINPLACE= yes
+CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
post-extract:
@${TOUCH} ${WRKSRC}/config.h.in
post-patch:
- @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|-O2||g; s|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/kimagemapeditor/Makefile b/graphics/kimagemapeditor/Makefile
index ca6260b4569..1317a33833d 100644
--- a/graphics/kimagemapeditor/Makefile
+++ b/graphics/kimagemapeditor/Makefile
@@ -20,11 +20,10 @@ USE_LIBTOOL_VER=13
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
pre-configure:
- ${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's|-O2||g; s|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/configure
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/kimdaba/Makefile b/graphics/kimdaba/Makefile
index ae2eb36d1cf..6d2d679e176 100644
--- a/graphics/kimdaba/Makefile
+++ b/graphics/kimdaba/Makefile
@@ -27,6 +27,4 @@ post-install:
@${RMDIR} ${PREFIX}/share/locale/xx/LC_MESSAGES/
@${RMDIR} ${PREFIX}/share/locale/xx/
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/kolourpaint/Makefile b/graphics/kolourpaint/Makefile
index 41bddfa296f..2bebabd7bbd 100644
--- a/graphics/kolourpaint/Makefile
+++ b/graphics/kolourpaint/Makefile
@@ -28,6 +28,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|-O2||g; s|^tagnames=|#tagnames=|g;' \
${WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/kphotoalbum-kde4/Makefile b/graphics/kphotoalbum-kde4/Makefile
index ae2eb36d1cf..6d2d679e176 100644
--- a/graphics/kphotoalbum-kde4/Makefile
+++ b/graphics/kphotoalbum-kde4/Makefile
@@ -27,6 +27,4 @@ post-install:
@${RMDIR} ${PREFIX}/share/locale/xx/LC_MESSAGES/
@${RMDIR} ${PREFIX}/share/locale/xx/
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/kphotoalbum/Makefile b/graphics/kphotoalbum/Makefile
index ae2eb36d1cf..6d2d679e176 100644
--- a/graphics/kphotoalbum/Makefile
+++ b/graphics/kphotoalbum/Makefile
@@ -27,6 +27,4 @@ post-install:
@${RMDIR} ${PREFIX}/share/locale/xx/LC_MESSAGES/
@${RMDIR} ${PREFIX}/share/locale/xx/
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/irc/konversation-kde4/Makefile b/irc/konversation-kde4/Makefile
index 6ed42fd88ca..4643fa6450f 100644
--- a/irc/konversation-kde4/Makefile
+++ b/irc/konversation-kde4/Makefile
@@ -24,6 +24,4 @@ USE_GMAKE= yes
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/irc/konversation/Makefile b/irc/konversation/Makefile
index 6ed42fd88ca..4643fa6450f 100644
--- a/irc/konversation/Makefile
+++ b/irc/konversation/Makefile
@@ -24,6 +24,4 @@ USE_GMAKE= yes
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/klogoturtle/Makefile b/lang/klogoturtle/Makefile
index 40ab87e8467..99b2426c3d0 100644
--- a/lang/klogoturtle/Makefile
+++ b/lang/klogoturtle/Makefile
@@ -16,10 +16,10 @@ COMMENT= LOGO Interpreter for the KDE Desktop
USE_KDELIBS_VER= 3
GNU_CONFIGURE= yes
USE_REINPLACE= yes
+CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
post-patch:
- @${REINPLACE_CMD} -e 's/-O2//g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's/-O2//g; s/-lpthread/${PTHREAD_LIBS}/g' \
+ ${WRKSRC}/configure
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/kkeyled/Makefile b/sysutils/kkeyled/Makefile
index 227b0818657..478315fecb4 100644
--- a/sysutils/kkeyled/Makefile
+++ b/sysutils/kkeyled/Makefile
@@ -19,10 +19,9 @@ GNU_CONFIGURE= yes
USE_REINPLACE= yes
post-patch:
- @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|-O2||g; s|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
@${REINPLACE_CMD} -e 's|/opt/kde3|${PREFIX}|g' \
${WRKSRC}/kkeyled/Themicons/kkeyledrc
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>