aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2013-10-14 09:43:16 +0800
committeravilla <avilla@FreeBSD.org>2013-10-14 09:43:16 +0800
commit951d87bea5b1630ba811feca31a34e25e68f4a30 (patch)
tree5b121eb379ec0246e6b5465592100577300c8ea9
parentcea97f30a6bfe24195b8a602f984966531844a04 (diff)
downloadfreebsd-ports-graphics-951d87bea5b1630ba811feca31a34e25e68f4a30.tar.gz
freebsd-ports-graphics-951d87bea5b1630ba811feca31a34e25e68f4a30.tar.zst
freebsd-ports-graphics-951d87bea5b1630ba811feca31a34e25e68f4a30.zip
- Backport patch to fix build of py-libimobiledevice.
Reported by: pkg-fallout - Adapt to LIB_DEPENDS change. - Enable stage support.
-rw-r--r--comms/libimobiledevice/files/patch-git_62ab50f11
-rw-r--r--comms/py-libimobiledevice/Makefile3
2 files changed, 12 insertions, 2 deletions
diff --git a/comms/libimobiledevice/files/patch-git_62ab50f b/comms/libimobiledevice/files/patch-git_62ab50f
new file mode 100644
index 00000000000..66e07a6a512
--- /dev/null
+++ b/comms/libimobiledevice/files/patch-git_62ab50f
@@ -0,0 +1,11 @@
+--- ./cython/lockdown.pxi.orig 2013-03-07 23:05:33.000000000 +0100
++++ ./cython/lockdown.pxi 2013-10-14 02:44:26.489878883 +0200
+@@ -221,7 +221,7 @@
+ char* c_session_id = NULL
+ bint ssl_enabled
+ bytes session_id
+- err = lockdownd_start_session(self._c_client, host_id, &c_session_id, &ssl_enabled)
++ err = lockdownd_start_session(self._c_client, host_id, &c_session_id, <int *>&ssl_enabled)
+ try:
+ self.handle_error(err)
+
diff --git a/comms/py-libimobiledevice/Makefile b/comms/py-libimobiledevice/Makefile
index e5403f1be79..8798435d32f 100644
--- a/comms/py-libimobiledevice/Makefile
+++ b/comms/py-libimobiledevice/Makefile
@@ -7,7 +7,7 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= avilla@FreeBSD.org
COMMENT= Python bindings for libimobiledevice
-LIB_DEPENDS= imobiledevice:${PORTSDIR}/${MASTER_PORT}
+LIB_DEPENDS= libimobiledevice.so:${PORTSDIR}/${MASTER_PORT}
BUILD_DEPENDS= cython:${PORTSDIR}/lang/cython \
${PYTHON_SITELIBDIR}/plist.so:${PORTSDIR}/devel/py-libplist
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/plist.so:${PORTSDIR}/devel/py-libplist
@@ -24,7 +24,6 @@ PLIST_FILES= ${PYTHONPREFIX_SITELIBDIR:S,^${PREFIX}/,,}/imobiledevice.a \
${PYTHONPREFIX_SITELIBDIR:S,^${PREFIX}/,,}/imobiledevice.la \
${PYTHONPREFIX_SITELIBDIR:S,^${PREFIX}/,,}/imobiledevice.so
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's,../src/libimobiledevice.la,${LOCALBASE}/lib/libimobiledevice.la,' \
${BUILD_WRKSRC}/Makefile.in